Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

mac-address table: none

Hello

Cisco 1812, Version 12.3(8)YI1

router#sh mac-address-table  | i 0470

0017.a477.0470          Dynamic     813     none

What does "none" mean ?

Most of mac adressess in cam has specified interface, but several has none....

Thanx

12 REPLIES
Cisco Employee

mac-address table: none

Hi,

Would you mind posting the complete output, or at least its heading? The table has its columns named; in this output, it is not clear what is expressed by a particular column.

Best regards,

Peter

New Member

Re: mac-address table: none

ok, here is the first part of output:

router#sh mac-address-table         

Destination Address  Address Type  VLAN  Destination Port

-------------------  ------------  ----  --------------------

0001.c709.8bfb          Dynamic       1     FastEthernet5

0004.dd31.f958          Dynamic       1     FastEthernet5

0004.dd85.6930          Dynamic       1     FastEthernet4

0014.a817.ba1c          Self          1     Vlan1

0018.19c8.e858          Dynamic       1     FastEthernet8

0004.dd31.f958          Dynamic     702     FastEthernet5

0001.c709.8bff          Dynamic     730     FastEthernet5

0002.4bf8.5e00          Dynamic     730     FastEthernet5

0002.b3f4.00f4          Dynamic     730     FastEthernet5

0002.b903.0100          Dynamic     730     FastEthernet7

0002.b903.0104          Dynamic     730     FastEthernet7

0002.b927.1e40          Dynamic     730     FastEthernet5

0002.ba13.63ff          Dynamic     730     FastEthernet5

0003.4732.ed58          Dynamic     730     FastEthernet7

0004.6ef0.4fff          Dynamic     730     FastEthernet5

0004.dd31.f958          Dynamic     730     FastEthernet5

0005.ddb5.3fff          Dynamic     730     FastEthernet5

0006.d680.37ff          Dynamic     730     FastEthernet5

000d.6046.dd99          Dynamic     730     FastEthernet5

000d.6046.ddcd          Dynamic     730     FastEthernet5

000d.6046.df85          Dynamic     730     FastEthernet5

000d.6046.dfcd          Dynamic     730     FastEthernet5

000d.6046.e052          Dynamic     730     FastEthernet5

000d.6046.e102          Dynamic     730     FastEthernet5

000d.6046.e1a7          Dynamic     730     FastEthernet5

000d.6047.2363          Dynamic     730     FastEthernet5

000d.6047.bc51          Dynamic     730     FastEthernet5

000d.6047.bee3          Dynamic     730     FastEthernet5

000d.6047.d85b          Dynamic     730     FastEthernet5

000d.6047.dbbf          Dynamic     730     FastEthernet5

000d.6047.dbd0          Dynamic     730     FastEthernet5

000d.6047.e819          Dynamic     730     FastEthernet5

0014.5ecf.2982          Dynamic     730     FastEthernet8

0014.5ecf.42fe          Dynamic     730     FastEthernet5

0014.5ecf.7eb8          Dynamic     730     FastEthernet5

0014.5ecf.860c          Dynamic     730     FastEthernet5

0014.5ecf.d2c0          Dynamic     730     FastEthernet5

0014.5ecf.e457          Dynamic     730     FastEthernet5

0014.5ecf.e461          Dynamic     730     FastEthernet5

0014.a817.ba1c          Dynamic     730     Vlan730

0018.19c8.e858          Dynamic     730     FastEthernet8

0018.8b39.8a58          Dynamic     730     FastEthernet5

0018.8b3a.3ce2          Dynamic     730     FastEthernet5

0018.8b3a.3d0c          Dynamic     730     FastEthernet5

0018.8b3b.5d77          Dynamic     730     FastEthernet5

0018.8b40.2972          Dynamic     730     FastEthernet5

0018.8b40.2b35          Dynamic     730     FastEthernet5

0018.8b4b.5ba7          Dynamic     730     FastEthernet5

0018.8b51.ba57          Dynamic     730     FastEthernet5

0018.8b51.ba63          Dynamic     730     FastEthernet5

0018.8b51.bb1b          Dynamic     730     FastEthernet5

0019.b9b4.0dac          Dynamic     730     FastEthernet5

0019.b9ca.beac          Dynamic     730     FastEthernet5

0019.e254.21c2          Dynamic     730     FastEthernet5

001a.6481.70c5          Dynamic     730     FastEthernet8

001c.23d9.4535          Dynamic     730     FastEthernet5

001e.4f16.06b3          Dynamic     730     FastEthernet5

001e.4f16.06b7          Dynamic     730     FastEthernet5

001e.4f16.06c9          Dynamic     730     FastEthernet5

001e.4f16.0a6f          Dynamic     730     FastEthernet5

001e.4f16.0abd          Dynamic     730     FastEthernet5

001e.4f16.0ad1          Dynamic     730     FastEthernet5

001e.4f16.235f          Dynamic     730     FastEthernet5

001e.4f16.2381          Dynamic     730     FastEthernet5

001e.4f16.23bf          Dynamic     730     FastEthernet5

001e.4f16.2678          Dynamic     730     FastEthernet5

001e.4f16.267c          Dynamic     730     FastEthernet5

001e.4f16.2a0f          Dynamic     730     FastEthernet5

001e.4f16.2a17          Dynamic     730     FastEthernet5

001e.4f2a.c3db          Dynamic     730     FastEthernet5

001e.4f31.33da          Dynamic     730     FastEthernet5

001e.4f31.365c          Dynamic     730     FastEthernet5

001f.6c03.4140          Dynamic     730     FastEthernet5

001f.6c7b.5a40          Dynamic     730     FastEthernet5

0021.5e2a.416f          Dynamic     730     FastEthernet5

0021.5e2a.46db          Dynamic     730     FastEthernet5

0022.1984.a859          Dynamic     730     FastEthernet5

0022.1984.a875          Dynamic     730     FastEthernet5

0022.1991.1444          Dynamic     730     FastEthernet5

0022.1998.472b          Dynamic     730     FastEthernet5

0024.e856.0234          Dynamic     730     FastEthernet5

0024.e881.158f          Dynamic     730     FastEthernet5

0026.b950.9f45          Dynamic     730     FastEthernet5

0030.4894.ebd1          Dynamic     730     FastEthernet4

0030.7814.f7ff          Dynamic     730     FastEthernet5

2c6b.f584.1fc2          Dynamic     730     FastEthernet5

a4ba.db16.216a          Dynamic     730     FastEthernet5

a4ba.db1b.55e9          Dynamic     730     FastEthernet5

a4ba.db45.4d31          Dynamic     730     FastEthernet5

0000.0c07.ac01          Dynamic     813     FastEthernet5

0000.0c07.ac02          Dynamic     813     FastEthernet5

0000.0c07.ac03          Dynamic     813     FastEthernet5

0000.212f.5bde          Dynamic     813     FastEthernet8

0003.ba10.002a          Dynamic     813     FastEthernet5

0004.23bb.299d          Dynamic     813     FastEthernet5

0004.dd31.f958          Dynamic     813     FastEthernet5

0005.1e05.321b          Dynamic     813     FastEthernet8

0005.1e05.3270          Dynamic     813     FastEthernet8

0005.1e05.7e4f          Dynamic     813     FastEthernet4

0005.1e05.7e6b          Dynamic     813     FastEthernet4

0014.4f46.4dc5          Dynamic     813     FastEthernet5

0014.4fa9.3ea6          Dynamic     813     FastEthernet5

0014.4fe3.114f          Dynamic     813     FastEthernet5

0014.4fe3.1285          Dynamic     813     FastEthernet5

0014.4fe5.cec9          Dynamic     813     FastEthernet5

0014.4ff2.154d          Dynamic     813     FastEthernet5

0014.4ff3.55f4          Dynamic     813     FastEthernet5

0014.4ff3.7782          Dynamic     813     FastEthernet5

0014.4ff3.778c          Dynamic     813     FastEthernet5

0014.4ff9.65fd          Dynamic     813     FastEthernet5

0014.4ff9.7c2e          Dynamic     813     FastEthernet5

0014.4ff9.9f9f          Dynamic     813     FastEthernet5

0014.4ff9.ba84          Dynamic     813     FastEthernet5

0014.4ff9.c70f          Dynamic     813     FastEthernet5

0014.4ffa.1965          Dynamic     813     FastEthernet5

0014.5e60.8b84          Dynamic     813     FastEthernet5

0014.5e60.8b8a          Dynamic     813     FastEthernet5

0014.5ecf.3df2          Dynamic     813     FastEthernet8

0014.5ee0.5cae          Dynamic     813     FastEthernet5

0014.5ee0.8d8c          Dynamic     813     FastEthernet5

0014.5ee0.ff28          Dynamic     813     FastEthernet5

0014.5ee1.2794          Dynamic     813     FastEthernet5

0014.5ee1.76d4          Dynamic     813     FastEthernet5

0014.5ee1.9d36          Dynamic     813     FastEthernet5

0014.5ef0.41fa          Dynamic     813     FastEthernet8

0014.5ef0.4632          Dynamic     813     FastEthernet5

0014.5ef0.580c          Dynamic     813     FastEthernet8

0014.5ef0.dfe6          Dynamic     813     FastEthernet5

0014.5ef0.e120          Dynamic     813     FastEthernet5

0014.5ef0.e130          Dynamic     813     FastEthernet5

0014.5ef9.1f13          Dynamic     813     FastEthernet5

0017.a477.0070          Dynamic     813     none

0017.a477.0080          Dynamic     813     none

router#sh mac-address-table | i none    

0017.a477.0070          Dynamic     813     none

0017.a477.0080          Dynamic     813     none

0023.e904.d380          Dynamic     813     none

0023.e904.f680          Dynamic     813     none

Thanx

Cisco Employee

Re: mac-address table: none

Hello,

To be honest, I am not sure what the "none" means here. I have went over available documentation but I was not able to find any relevant information. Does the communication work correctly with the stations with these MAC addresses? Is there any feature configured that might treat these MAC addresses specially, like port security, MAC ACLs, ...?

Best regards,

Peter

New Member

Re: mac-address table: none

Two of my mac-address are flapping between switchA and router.

About 50% of time switchA points to router for mac-adddressA and router has "none" for that mac-addressA.

No special features enabled. Config:

version 12.3

service nagle

service timestamps debug datetime

service timestamps log datetime

service password-encryption

!

hostname router

!

boot-start-marker

boot-end-marker

!

logging buffered 64000 debugging

!

username cisco privilege 15 secret 5 $xxxWuVGayyDWjJqR/

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

aaa new-model

!

!

aaa authentication login default group tacacs+ line enable

aaa authentication login CONSOLE none

aaa authorization exec default group tacacs+

aaa session-id common

ip subnet-zero

!

!

ip cef

!

!

no ip domain lookup

ip domain name dev.agora.pl

ip name-server 10.1.1.1

ip ips po max-events 100

no ftp-server write-enable

!

!

!

!

!

!

!

interface BRI0

no ip address

shutdown

no cdp enable

!

interface FastEthernet0

description Outside

ip address 10.205.30.9 255.255.255.0

ip access-group z_outside in

ip nbar protocol-discovery

speed 100

full-duplex

!

interface FastEthernet1

description ssw03t1

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

shutdown

speed 100

full-duplex

!

interface FastEthernet2

description ssw03t1

switchport access vlan 731

switchport trunk native vlan 730

switchport mode trunk

no ip address

!

interface FastEthernet3

description ssm03f02

switchport access vlan 730

switchport mode trunk

no ip address

!

interface FastEthernet4

description ssm03f03

switchport access vlan 730

switchport mode trunk

no ip address

!

interface FastEthernet5

description ssm03r0

switchport mode trunk

no ip address

!

interface FastEthernet6

description ssm06f1

switchport access vlan 730

switchport mode trunk

no ip address

!

interface FastEthernet7

description ssm04f1

switchport access vlan 730

no ip address

!

interface FastEthernet8

switchport trunk native vlan 730

switchport mode trunk

no ip address

!

interface FastEthernet9

switchport access vlan 730

no ip address

no cdp enable

!

interface Vlan1

no ip address

!

interface Vlan702

ip address 10.207.2.1 255.255.255.0

ip access-group trader-dostep out

no ip redirects

no ip unreachables

no ip proxy-arp

!

interface Vlan730

description Inside

ip address 10.207.30.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

!

interface Vlan731

ip address 10.207.31.1 255.255.255.0

ip access-group unix-dostep out

!

interface Vlan780

ip address 10.207.80.1 255.255.255.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.205.30.1

ip route 10.208.20.1 255.255.255.255 10.207.30.181

ip route 10.208.20.2 255.255.255.255 10.207.30.180

!

!        

no ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 600 life 86400 requests 10000

!

ip access-list extended loguj_zlych

permit ip 10.201.6.0 0.0.0.255 any

permit ip 10.201.10.0 0.0.0.255 any

permit ip 10.200.12.0 0.0.0.255 any

permit tcp any any eq telnet log-input

permit tcp any any log-input

permit udp any any log-input

permit ip any any log-input

ip access-list extended trader-dostep

permit ip 172.25.252.0 0.0.0.255 any

permit ip 172.28.252.0 0.0.0.255 any

permit ip 10.202.54.0 0.0.0.255 any

permit ip 10.202.59.0 0.0.0.255 any

permit ip host 10.205.42.112 any

permit ip 10.201.6.0 0.0.0.255 any

permit ip 10.201.10.0 0.0.0.255 any

permit ip 10.202.84.0 0.0.0.255 any

permit ip 172.26.7.0 0.0.0.255 any

ip access-list extended unix-dostep

permit ip 10.201.6.0 0.0.0.255 any

permit ip 10.201.4.0 0.0.0.255 any

ip access-list extended unix-out

ip access-list extended z_outisde

ip access-list extended z_outside

permit tcp host 10.1.1.3 eq smtp any

permit udp host 10.205.45.8 any

permit udp host 10.205.45.6 any

permit udp host 10.121.45.8 any

permit ip host 10.205.41.40 any

permit udp host 10.30.124.1 any

permit udp any host 10.207.30.240

permit udp host 10.1.1.1 eq domain any

permit udp host 10.205.41.130 any

permit udp host 10.205.41.131 any

permit tcp host 10.205.41.131 eq tacacs any

permit tcp host 10.205.41.130 eq tacacs any

permit icmp any any

permit ip host 10.200.3.100 any

permit ip host 10.205.42.70 any

permit ip host 10.205.50.50 any

permit ip host 10.205.50.100 any

permit ip host 10.205.42.112 any

permit ip host 10.205.42.100 any

permit ip host 10.205.42.101 any

permit ip host 10.205.42.71 any

permit ip 10.200.12.0 0.0.0.255 any

permit ip 10.201.6.0 0.0.0.255 any

permit ip host 10.205.73.75 any

permit ip host 10.205.73.76 any

permit ip 172.26.0.0 0.0.255.255 10.207.30.0 0.0.0.255

permit ip 172.25.0.0 0.0.255.255 10.207.30.0 0.0.0.255

permit ip 10.205.62.0 0.0.0.255 10.207.30.0 0.0.0.255

permit ip 10.202.84.0 0.0.0.255 10.207.30.0 0.0.0.255

permit ip 10.205.28.0 0.0.0.255 10.207.30.0 0.0.0.255

permit ip 10.201.10.0 0.0.0.255 10.207.30.0 0.0.0.255

permit ip 10.201.4.0 0.0.0.255 10.207.30.0 0.0.0.255

deny   tcp any any eq telnet log-input

deny   tcp any any

deny   udp any any

!

logging trap debugging

logging 10.205.50.100

access-list 74 permit 193.42.230.15

access-list 74 permit 193.42.230.10

access-list 74 permit 193.42.230.77

access-list 74 permit 193.42.230.78

access-list 74 permit 193.42.230.72

access-list 74 permit 193.42.230.75

access-list 74 permit 193.42.230.68

access-list 74 permit 10.205.42.160

access-list 74 permit 10.205.42.120

access-list 74 permit 10.205.42.112

access-list 74 permit 10.205.3.100

access-list 74 permit 10.200.3.100

access-list 74 permit 10.205.42.70

access-list 74 permit 10.205.73.75

access-list 74 permit 10.205.50.50

access-list 74 deny   any

access-list 75 permit 10.205.42.101

access-list 75 permit 10.205.42.100

access-list 75 permit 10.205.50.100

access-list 75 permit 10.205.42.112

access-list 75 permit 10.200.3.100

access-list 75 permit 10.205.42.70

access-list 75 permit 10.201.10.100

access-list 75 permit 10.205.50.50

access-list 75 permit 10.205.41.50

access-list 75 deny   any log

arp 10.207.30.22 000d.6046.ddcd ARPA

arp 10.207.30.21 000d.6046.dd99 ARPA

!

!

!

tacacs-server host 10.205.42.100

tacacs-server host 10.205.42.101

!

control-plane

!

line con 0

password 7 xx

line aux 0

password 7xx

transport input all

line vty 0 4

privilege level 15

password 7 xx

transport input telnet ssh

line vty 5 15

privilege level 15

password 7 xx

transport input telnet ssh

!

no scheduler allocate

ntp clock-period 17180244

ntp server 10.1.0.6

Cisco Employee

Re: mac-address table: none

Hello,

Perhaps we should focus on the flapping issue itself. Is it possible for you to post an exhibit of your network and indicate the position of the station with the MAC address that is reported as flapping?

Flapping MAC is usually caused by a switching loop.

Best regards,

Peter

New Member

Re: mac-address table: none

Yes, but to have a switching loop i need to have at least 3 switches (or 2 switches with more than single link)

I have just two switches connected by one link and

1. sometimes both of them says that specified mac address is on that link pointing to each other

2. sometimes one of them says it's on that link and the other one says it's "none".

3. sometimes it's ok and i can ping station.

STP is stable, trunk is ok, native vlans ok.

Loop is not possible because there is only a single path for the specified mac -address.

My switch is 3524XL with  12.0(5)WC5 - maybe there are some bugs....

mac-address table: none

Hi,

I see 6 trunks plus 2 access ports configured on your router.

How are they connected to your switches?

And your switches are not connected each to the other?

HTH,

Milan

New Member

Re: mac-address table: none

SwitchA---Router-------Several other switches

The problem is between SwitchA and Router (which is also switch).

There are several other switches connected to that router - and that trunks even have the same vlans but - there is no loop in physical topology - so for STP all links are always in forwarding state ("Several other switches" are connected by a single link to Router)

mac-address table: none

Hmm, only one idea coming to my mind:

Some VLAN mismatch.

I see native VLAN 730 on one port while default left on other trunks.

Is that correct?

BR,

Milan

New Member

Re: mac-address table: none

Yes, that's correct, only on one link native vlan is different.

Native vlans are consistent and stable.

Another strange thing on SwitchA, 0011.2233.4455 should be seen on fa0/4:

SwitchA#sh mac-address-table | i 0011.22

0011.2233.4455       Dynamic        813  FastEthernet0/24

SwitchA#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

SwitchA(config)#mac-address-table static 0011.2233.4455 fastEthernet 0/4 vlan 813

SwitchA(config)#exit

SwitchA#sh mac-address-table | i 0011.22

0011.2233.4455         813  Fa0/1      

Why after adding static mac-address to correct interface "sh mac-addr" show fa0/1 ?

Thanx

Cisco Employee

Re: mac-address table: none

Hi,

This is completely strange. Can you please also post the config of your switch? It is indeed possible that the IOS is buggy and/or the switch needs reloading.

Oh, and another question: are there any wireless access points in your network? Is it possible that some clients are connected to your network both via wireless and wired connection? Alternatively, is it possible that any of your computers is connected to your network using two or more network cards?

Milan, I've sent you a private message - just want to make sure you don't miss it

Best regards,

Peter

New Member

Re: mac-address table: none

i am pretty sure SwitchA is faulty (hardware or very old 12.0 software).

Mac address/L2 subsystem seems to behave uncorrectly.

I'll try to replace this switch and check it.

Thanx

1099
Views
0
Helpful
12
Replies
CreatePlease to create content