Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Maintaining list of allowed vlans on etherchannel

Hi,

Looks like a typical trivial task, but I still can't find solution in docs.

At the beginning, I had just one link to uplink switch, then added the second one and built etherchannel. I do not undrestand how to modify list of allowed vlans so that to avoid errors. Should i have "switchport" commands on Port-Channel level or Gigabit ethernet level? Where should I apply "spanning-tree" commands?

interface Port-channel1

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,6,21

switchport mode trunk

switchport nonegotiate

!

interface GigabitEthernet3/1

description link1

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,6,21

switchport mode trunk

switchport nonegotiate

channel-group 1 mode on

!

interface GigabitEthernet4/1

description link2

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,6,21

switchport mode trunk

switchport nonegotiate

channel-group 1 mode on

!

Thank you in advance!

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Maintaining list of allowed vlans on etherchannel

Hi

You need to apply any configuration changes to your Port-Channel interface, this will update the config on all members within that port channel.

Applying config to a single physical interface could cause it to drop out of the etherchannel.

Hope that helps.

3 REPLIES

Re: Maintaining list of allowed vlans on etherchannel

Hi

You need to apply any configuration changes to your Port-Channel interface, this will update the config on all members within that port channel.

Applying config to a single physical interface could cause it to drop out of the etherchannel.

Hope that helps.

Purple

Re: Maintaining list of allowed vlans on etherchannel

It goes on the " interface port channel" . To add vlans use "switchport trunk allowed vlan add " .

Hall of Fame Super Silver

Re: Maintaining list of allowed vlans on etherchannel

Hello Mihails,

once the etherchannel is up and running do changes only on the port-channel interface.

We had very bad experiences two times for someone trying to add a vlan on a member link: both times a bridging loop formed with extended out of service

The involved devices were C6500 with Sup 720 3B.

So I strongly recommend once the etherchannel is up to makes changes only on the port-channel interface

use the command suggested by Glen:

switchport trunk allowed vlan add x

Hope to help

Giuseppe

192
Views
13
Helpful
3
Replies
CreatePlease to create content