Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Merging VLANs from Wired and Wireless LANs

Hi Cisco,

Our network consists of a gateway router CISCO ISR 3825 with Integrated Service Engine WLAN Controller NME-AIR-WLC6-K9 and AP Air-LAP1142N that is connected to our switch CISCO WS-C3560.

Router:
ip dhcp pool Wireless@Clients
   network 192.168.10.0 255.255.255.0
   default-router 192.168.10.1
   dns-server 202.130.97.65 202.130.97.66 203.2.75.2 203.2.75.12 4.2.2.2
   lease 7
!
ip dhcp pool Cisco_LWAP
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   option 43 hex f104.0a28.290a
   lease 7
!

interface GigabitEthernet0/0
description INTERNET LINK
bandwidth 10240
ip address X.X.X.X 255.255.255.252
ip nat outside
!
interface GigabitEthernet0/1
description LINK TO SWITCH STACK - 3560

no ip address

duplex full
speed 1000
!
interface GigabitEthernet0/1.100

description CLIENT LINK
encapsulation dot1Q 100
ip address 192.168.100.1 255.255.255.0
ip nat inside

!

interface GigabitEthernet0/1.990
description CISCO_LWAP
encapsulation dot1Q 990
ip address 192.168.1.1 255.255.255.0

!

interface GigabitEthernet0/1.999
description SWITCH MANAGEMENT VLAN
encapsulation dot1Q 999
ip address Y.Y.Y.Y 255.255.255.0

!

interface Integrated-Service-Engine1/0
description Cisco Wireless LAN Controller Module
ip address Z.Z.Z.Z 255.255.255.240
!
interface Integrated-Service-Engine1/0.995
description WIRELESS CLIENTS
encapsulation dot1Q 995
ip address 192.168.10.1 255.255.255.0
ip nat inside

Switch:

interface FastEthernet0/1
description WIRELESS AP
switchport access vlan 990
switchport mode access
speed 100
duplex full
storm-control broadcast level 20.00
spanning-tree portfast

!

interface FastEthernet0/2

description CLIENT WIRED CONNECTION
switchport access vlan 100
switchport mode access
spanning-tree portfast

!

interface GigabitEthernet0/1

description TRUNK LINK TO ROUTER
switchport trunk encapsulation dot1q
switchport mode trunk
storm-control broadcast level 50.00

!

interface Vlan999

description SWITCH MANAGEMENT
ip address Y.Y.Y.Y 255.255.255.0

AP connects to our 3560 switch and assign VLAN 990.

Switch is manage using interface Vlan999 with ip address Y.Y.Y.Y 255.255.255.0

Our 3825 router has 2 GigEthernet Interfaces, LAN (Switch connection) and WAN (Internet Connection).

VLANs are separated on the router LAN interfaces using sub-interface and assigning dot1q VLAN ID.

Our wireless network is currently live but is only using one network 192.168.10.1 255.255.255.0 on VLAN 995.

We want to bridge our client VLAN 100 (wired) with wireless connection by creating a sub-interface under Integrated-Service-Engine interface.

Is this possible with my setup? I read this can be done using Bridge-group (Bridge irb, Interface bvi) but will not work on my setup because of the separate router and switch device.

Thanks

  • LAN Switching and Routing
2 REPLIES
VIP Super Bronze

Re: Merging VLANs from Wired and Wireless LANs

Hi,

I don't why you would want to do that.  You have 2 separate subnets with separate vlans connecting to the router.  The design is fine the way it is and I would not merge the subnets/vlans together.

HTH

Reza

New Member

Re: Merging VLANs from Wired and Wireless LANs

Hi,

I dont not want to merge the two networks together, our aim is to have VLAN 100 on wired Ethernet expand to wireless. This means that VLAN 100 will have to be bridge on the switch as well as the WLC. Existing wireless clients on VLAN 995 under interface Integrated-Service-Engine1/0.995 will remain untouch and active. This means that there will be 2 sub-interface / 2 networks under the ISE which are VLAN 995 and VLAN 100 wireless.

I hope this makes sense. See attached diagram of what we are trying to achieved.

Thanks

909
Views
0
Helpful
2
Replies