Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Metro ethernet and routing between remote sites

Question regarding Metro Ethernet setup and routing between sites.

Your are getting Metro Ethernet service from your ISP (AT&T). The ISP is providing "non-q-in-q" ME service. You have the "hub" main headquarters site and several remote sites. The connectivity between the sites will appear as one broadcast domain (I am assuming).

Each site is subnetted with it's own ip addressing scheme. The hub site will be the aggregate and have a router. The remote sites will have routers.

At the main site will I be able to create sub-interfaces (for each site) and associate them with a dot1q tag in the same L3 subnet for point to point connectivity as the remote site routers? The main site and remotes would be attached to the same native vlan, but then have sub-interfaces for the point to point or hub to remote site connectivity. Will this work? Or do I create one L3 address at the hub and then for each remote router assign a L3 address from the same L3 subnet as the hub?

Thanks

12 REPLIES
Hall of Fame Super Bronze

Re: Metro ethernet and routing between remote sites

The ISP is providing "non-q-in-q" ME service.

Can you explain what kind of connection is that?

Is it a Layer2 or Layer3 connection to the provider?

At the main site will I be able to create sub-interfaces (for each site) and associate them with a dot1q tag in the same L3 subnet for point to point connectivity as the remote site routers?

Yes.

The main site and remotes would be attached to the same native vlan, but then have sub-interfaces for the point to point or hub to remote site connectivity. Will this work?

The main site will have subinterfaces (each tag with a vlan for the remote site), do the same for the remote(s).

main site:

interface gx/x.100

encapsulation dot1q 100

ip address 100.x.x.x

interface gx/x.200

encapsulation dot1q 200

ip address 200.x.x.x

remote site A:

interface gx/x.100

encapsulation dot1q 100

ip address 100.x.x.x

remote site B:

interface gx/x.200

encapsulation dot1q 200

ip address 200.x.x.x

Regards

Edison

New Member

Re: Metro ethernet and routing between remote sites

Hi Ed,

It's a layer 2 conenction. I'm am a bit confused myself about the term non-q-in-q. I know what q-in-q is, but not sure what they meant by the "non" part.

I actually tried labbing up the type of configuration you have here using a 3550 as the (provider) switch between the routers, but the conenction wouldn't come up (over the same L2 vlan) until the switch had vlan 100, and vlan 200. This may be a limitation with the switch and not the way the ISP does it. The ISP said they didn't have to provide us with any kind of vlan number.

Thanks

Hall of Fame Super Bronze

Re: Metro ethernet and routing between remote sites

It's a layer 2 conenction. I'm am a bit confused myself about the term non-q-in-q. I know what q-in-q is, but not sure what they meant by the "non" part.

Perhaps they are using ATOM or L2TPv3 - IOW, there aren't using a switched network for L2 extension. To the customer, the main difference is that you don't need to match the Service Provider customer assigned vlan, they are providing a pseudowire for you.

I actually tried labbing up the type of configuration you have here using a 3550 as the (provider) switch between the routers, but the conenction wouldn't come up (over the same L2 vlan) until the switch had vlan 100, and vlan 200

You can't do my sample config on a 3550, not supported. You said routers in the initial post so I assumed real IOS routers.

On the 3550, this will work.

Hub:

interface gx/x

switchport trunk en do

switchport mode trunk

switchport trunk all vlan 100,200

interface vlan 100

ip address 100.x.x.x

interface vlan 200

ip address 200.x.x.x

remote site B:

interface gx/x

switchport trunk en do

switchport mode trunk

switchport trunk all vlan 100

interface vlan 100

ip add 100.x.x.x

remote site B:

interface gx/x

switchport trunk en do

switchport mode trunk

switchport trunk all vlan 200

interface vlan 200

ip address 200.x.x.x

Regards

Edison.

New Member

Re: Metro ethernet and routing between remote sites

Thanks Ed,

You're correct the 3550 I was using was to simulate the ISP, but I guess like you say that's not possible. The hub site and the remotes will be real IOS 38xx routers (latest IOS).

So I guess I don't need to bother with any "native vlan xxxx" statement for the main interfaces huh for hub and remotes routers?

Just leave the main interfaces (hub and remotes) no shut and for the sub-interfaces assign L3 addressing with coresponding dot1q for each site. Does this sound correct.

This will be sort of like Frame Relay point-to-point in a way with the remote sites each pointing to the hub. Atleast this is the way I envision it.

Thanks

Thanks

Hall of Fame Super Bronze

Re: Metro ethernet and routing between remote sites

So I guess I don't need to bother with any "native vlan xxxx" statement for the main interfaces huh for hub and remotes routers?

Correct. You only need that on Q-in-Q type of design.

Just leave the main interfaces (hub and remotes) no shut and for the sub-interfaces assign L3 addressing with coresponding dot1q for each site. Does this sound correct.

Yes.

This will be sort of like Frame Relay point-to-point in a way with the remote sites each pointing to the hub. Atleast this is the way I envision it.

Sort of.

Please rate helpful posts

New Member

Re: Metro ethernet and routing between remote sites

Hi Ed,

One more question...for now. As far as duplex and speed on the ME facing interfaces. Just let it auto?

Thanks

Hall of Fame Super Bronze

Re: Metro ethernet and routing between remote sites

You need to match with the provider's.

Ask them what's their setting.

New Member

Re: Metro ethernet and routing between remote sites

Hi Ed,

The duplex settings will be full duplex.

If you're hub site is say 50MB and the remotes are say like 8MB then how would you set the speed when typically you only have the option of 10,100, or 1000?

Would you just set duplex to full and set the speed to 100 for the hub and remotes?

Thanks

Hall of Fame Super Bronze

Re: Metro ethernet and routing between remote sites

You need to deploy QoS for subrate services.

New Member

Re: Metro ethernet and routing between remote sites

Do you have a doc for that?

Thanks

Hall of Fame Super Bronze

Re: Metro ethernet and routing between remote sites

New Member

Re: Metro ethernet and routing between remote sites

Hi Ed,

Then since you can only set full duplex (on the physical interfaces) for either 10, 100, or 1000 would you setup the ME facing interfaces for both the HUB site and remote site to 100/FULL?

Then on the hub would you configure Class based shaping for each remote site and set the service policy for each site under their coresponding subinterfaces (on the hub router)?

Thanks

284
Views
5
Helpful
12
Replies
CreatePlease to create content