Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Migrate Port Channel - Nexus 7K

So, I need to migrate a port channel to a new set of ports in the Nexus 7K. Below is the current config on the Nexus:

interface port-channel33

  switchport

  switchport mode trunk

  switchport trunk allowed vlan 10,50

  spanning-tree port type edge trunk

!

interface Ethernet6/33

  switchport

  switchport mode trunk

  switchport trunk allowed vlan 10,50

  spanning-tree port type edge trunk

  channel-group 33 mode active

  no shutdown

!

interface Ethernet7/33

  switchport

  switchport mode trunk

  switchport trunk allowed vlan 10,50

  spanning-tree port type edge trunk

  channel-group 33 mode active

  no shutdown

Ports 6/33 and 7/33 are 10G uplinks to a pair of 2960S in a flexstack. The 2960S has the following config:

interface Port-channel5

description --==## Uplink to Nexus 7000 ##==--

switchport trunk allowed vlan 10,50

switchport mode trunk

spanning-tree portfast trunk

!

interface TenGigabitEthernet1/0/1

switchport trunk allowed vlan 10,50

switchport mode trunk

spanning-tree portfast trunk

channel-group 5 mode active

!

interface TenGigabitEthernet2/0/1

switchport trunk allowed vlan 10,50

switchport mode trunk

spanning-tree portfast trunk

channel-group 5 mode active

I need to move the uplinks from ports 6/33 and 7/33 to 6/35 and 7/35. I would also like to change the port channel ID from 33 to 35 for naming reasons. Is there a way to accomplish this without dropping any packets? Thanks.

Dave

  • LAN Switching and Routing
3 REPLIES
New Member

Migrate Port Channel - Nexus 7K

I know your point,but I never did it,so I just guess:

1.you are using PAGP in portchannel,it's great

2.creat an new PC name 35,and add 7/35 to PC-35

3.break 7/33,and connect 7/35,this time PAGP will suspend 7/35

4.shutdown 6/33,this time PAGP will use 7/35,the PortChannel takeover more faster, so it's some packet will droped really, but very few

5.connect 6/35, the PC-35 get full connection.

At step 3, if 7/35 not be suspended,you can go back, it's save, no packet droped.

I suggest you do a lab-test first,and migrate at low-traffic time window.

Whether you success,please let me know,Thank you.

New Member

Migrate Port Channel - Nexus 7K

I performed the cutover the other night. I created a new port channel 35 and added both ports 6/35 and 7/35. I then unplugged 6/33 and moved the SFP into 6/35. I then quickly just unplugged 7/33 and plugged in 6/35. I only droped 1-2 packets.

Dave

New Member

Migrate Port Channel - Nexus 7K

nice

257
Views
0
Helpful
3
Replies
This widget could not be displayed.