Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Misconfigured switch?

Hello everyone

I was suggested to go here from the MS technet forums, as my problem originally was related to TFTP, PXE and ConfigMgr, but it seems the problem can be a cisco router. 

I copied the thread i made:

m having a rather peculiar issue with horrendously slow downloading of the boot.wim filer over TFTP. This is for a customer, who has an old ConfiMgr environment and  new one which I have recently implemented.

The old environment is configured almost identical to the new environment 

-RamDiskTFTPBlockSize is set to 16384 in both cases
-RamDiskTFTPWindowSize is set to the default 4 in both cases
-Send Receive Buffers is identical at 2mb on both

Difference: The new environment has 2 Cisco 3750x  switches 

Switches are configured as follows:

 

Switch1:

interface TenGigabitEthernet1/1/1

switchport access vlan 122

switchport mode access

flowcontrol receive on

spanning-tree portfast

!

interface TenGigabitEthernet1/1/2

switchport access vlan 122

switchport mode access

flowcontrol receive on

spanning-tree portfast

Switch2:

interface TenGigabitEthernet1/1/1

switchport access vlan 122

switchport mode access

flowcontrol receive on

spanning-tree portfast

!

interface TenGigabitEthernet1/1/2

switchport access vlan 122

switchport mode access

flowcontrol receive on

spanning-tree portfast

The difference is immense. 15 minutes on the new environment, compared to 30 seconds on the old. The only difference as far as I can tell is the fact the there is a switch connected to the new one, so as far as I can see this is only obstacle that could provide such a drastic stop.

Am I right in assuming this, or is there anything else that could account for this difference?

Everyone's tags (1)
4 REPLIES
New Member

How is your network topology?

How is your network topology? I just find it odd you're using a L3-switch in the access layer and ten gigabit-interfaces in access mode when usually they're used for trunking.

I frankly don't know. Im

I frankly don't know. Im purely a client management specialist, and am unfortunately nowhere close to being as good with networks as I would like. Adding to this, this is for a client of mine, where I have little to no control over anything but servers I'm hired to work with.

New Member

Please check the port status#

Please check the port status

# show interface TenGigabitEthernet1/1/x on both the switches, and make sure that you are seeing correct speed/duplex.

Please check the counters for any errors.

#show interfaces counters errors 

I'd try turning off flow

I'd try turning off flow control (no flowcontrol receive on)

http://www.cisco.com/c/en/us/td/docs/switches/datacenter/sw/5_x/nx-os/interfaces/configuration/guide/if_cli/if_basic.html

 

Please rate if helpful.

122
Views
0
Helpful
4
Replies
CreatePlease login to create content