Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Mixing Vlan-based QoS with auto qos on Cat 3750

Hello:

I'm currently running "auto qos voip cisco-phone" on access ports to trust markings from Cisco phones. I also want do some marking on the data Vlan for those ports, and was wondering if I can do VLAN-based QoS for the data traffic, while running "auto qos voip cisco-phone" to honor markings for voice traffic? Can I run these at the same time? Here's an example of what I want to do:

class-map match-any MISSION-CRITICAL

match access-group name ACL1

class-map match-any NETWORK-CTL

match access-group name ACL2

policy-map MARK-EDGE-POLICY1

class NETWORK-CTL

set dscp cs2

class MISSION-CRITICAL

set dscp af21

interface FastEthernet1/0/1

switchport access vlan 22

switchport voice vlan 122

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust device cisco-phone

mls qos vlan-based

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

!

!

<snip>

!

interface Vlan22

ip address 10.1.2.1 255.255.255.0

ip helper-address 10.1.0.3

service-policy input MARK-EDGE-POLICY1

!

interface Vlan122

ip address 10.1.122.1 255.255.255.0

ip helper-address 10.1.0.3

!

Would this be an acceptable marking method for both the voice and data traffic?

Thanks in advance for any input.

2 REPLIES
Bronze

Re: Mixing Vlan-based QoS with auto qos on Cat 3750

Hi,

The configuration you have on fa1/0/1 is all related to COS which is in the layer 2 header (makes sense as this is a layer 2 switchport).

The service-policy applied to the Vlan interface is setting the DSCP/QoS values in the Layer 3 header.

On your switch you should also have some configuration relating to cos to dscp mappings and vice versa, however I'm not exactly sure what happens in your scenario. Maybe there is a QoS guru online who will know??

Regards

New Member

Re: Mixing Vlan-based QoS with auto qos on Cat 3750

Sorry, I probably should've specified this, but I'm doing the cos-to-dscp mappings that auto-qos automatically sets up, so assume that DSCP marking for voice would be mapped appropriately.

247
Views
0
Helpful
2
Replies
CreatePlease to create content