Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Modify priority of a packet (TCP) for a given ip

How do I modify the priority of a TCP packet for a given source ip?

I mean how do I modify the priority of a TCP packet transmitted from a given ip address say 192.168.10.3?

7 REPLIES
New Member

Re: Modify priority of a packet (TCP) for a given ip

You need to use qos, and in your class map us an access-list that match this particular source/port

Sent from Cisco Technical Support iPhone App

New Member

Re: Modify priority of a packet (TCP) for a given ip

I am already defining access list for various ips in the same vlan

So assigning priority for an access-list makes it applied to all the ips.

I cannot use an access-list for just 1 ip.

So I have given many ips for a given access-list.

However, I want to modify the priority for the packet coming from only one pc in that access-list, not all pcs in that access-list.

How do I modify the priority for that given ip's packets alone?

New Member

Re: Modify priority of a packet (TCP) for a given ip

Can u post your configuration

Amjad Abdelhalim

New Member

Re: Modify priority of a packet (TCP) for a given ip

Current configuration : 1550 bytes

!

version 15.0

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname sap

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip source-route

!

!

!

!

ip cef

multilink bundle-name authenticated

!

!

license udi pid CISCO1841 sn FHK144570UZ

!

!

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 192.168.10.1 255.255.255.0

ip access-group 101 in

ip access-group 102 out

ip summary-address eigrp 1 192.168.10.0 255.255.255.0

!

interface FastEthernet0/0.2

encapsulation dot1Q 2

ip address 192.168.15.1 255.255.255.0

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

ip address 192.168.4.10 255.255.255.252

clock rate 64000

!

interface Serial0/0/1

no ip address

clock rate 64000

!

!

router eigrp 1

network 192.168.10.0

network 192.168.15.0

neighbor 192.168.10.3 FastEthernet0/0.1

neighbor 192.168.10.4 FastEthernet0/0.1

neighbor 192.168.15.3 FastEthernet0/0.2

!

router rip

network 192.168.4.0

network 192.168.5.0

!

ip forward-protocol nd

!

!

no ip http server

!

access-list 101 permit tcp host 192.168.10.3 host 192.168.15.3

access-list 101 permit tcp host 192.168.10.4 host 192.168.15.3

access-list 102 permit tcp host 192.168.15.3 host 192.168.10.3

access-list 102 permit tcp host 192.168.15.3 host 192.168.10.4

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

login

length 0

!

scheduler allocate 20000 1000

end

Super Bronze

Re: Modify priority of a packet (TCP) for a given ip

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

You could use a CBWFQ policy-map to tag on input.

e.g. something like

access-list 100 permit tcp host 192.168.10.3 any

access-list 100 permit tcp host 192.168.10.30 any

class-map match-any tagCS3

match access-group 100

policy-map tag

class tagCS3

set ip dscp cs3

interface x

service-policy in tag

New Member

Re: Modify priority of a packet (TCP) for a given ip

Hi Joseph,

I have more than one pc connected in the same interface.

I do no want all pc to have the sqame priority.

I want to specify the priority for a given ip in an interface.

Pls help me asap.

Super Bronze

Re: Modify priority of a packet (TCP) for a given ip

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

You can extend the sample policy I posted with multiple classes.  Could be one, or more, host match per tagging.  You should run out of tags before you run out of classes.

1047
Views
0
Helpful
7
Replies