Cisco Support Community
Community Member

modular ios on 6509

How do you downgrade from modular ios to a binary image

Cisco Employee

Re: modular ios on 6509

If you are running Modular IOS in installed mode, then you need to give this command to uninstall it:

install clear :/sys


install clear disk0:/sys

Flash System is the location where we have the search root directory created.

You can verify whether the system is running in installed mode or Uninstalled mode, by exceuting a sh version or sh install running. The latter command might not work or give output if you are uninstalled mode.

If you could provide these two outputs, then I could provide you exact details. You may also refer to this document:


Deepak Yadav

Community Member

Re: modular ios on 6509

Depak I get this message:

cp1-sw78#install clear disk0:/sys

There is currently a node running software installed at disk0:/sys.

You cannot remove software that is currently running.


Cisco Employee

Re: modular ios on 6509

The best course of action would be:

conf t

no install bind

boot system flash disk0:


wr mem


Once the system is up with Binary IOS then Modular IOS is no longer in picture, however the installation files exist on Disk0:/Sys directory. Simply delete it.

Hope this helps.


Re: modular ios on 6509


Just out of curiosity: Why whould you want to go from modular to binary? Did you have bad experiences with modular?

As it is Cisco's stated direction for IOS for Cat6500 / Cisco7600 to go modular and modular only I'm interested in knowing why you'd want to go away from modular?

TIA, Ingolf

Community Member

Re: modular ios on 6509

In the past I ran the modular IOS on our 6509's and I ran into a problem where the CPU on the switch would gradually increase on a daily basis, until finally the switch would crash and the supervisor would reload. The problem seemed to be aggravated by regular SNMP polling of the switch.

My experience was over a year ago, and I don't recall what version I was running, but I've switched back to non-modular images and haven't had any problems since. I could probably find the thread here on Netpro if you need when I experienced this problem. I believe others had witnessed the same.


CreatePlease to create content