Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

MRTG for INTL & DMESTIC traffic

Dear All,

below is the config for segragating the traffic for Internal & domestic AS no.

I got below config from customer & they suggested that with below config we can create

Segragte International & domestic traffic.

Please suggest below config in details since i am not able to undertand the config.

========================================================================

IDC router:

ip community-list INTL permit X:Z

!this should contain communities for international traffic

route-map INTERNATIONAL permit INTL

match community INTL

set ip qos-group INTL

!

router bgp 18101

table-map INTERNATIONAL

!

POLICY-MAP

class-map match-all UPLNIK

match qos-group INTL

!

class-map match-all TEST

class-map match-any TEST-TEST

match ip precedence 3

!

policy-map UPLINK

class UPLNIK

police cir 125000000 bc 2343750 be 2343750 conform-action transmit

exceed-action transmit

class class-default

police cir 125000000 bc 2343750 be 2343750 conform-action transmit

exceed-action transmit

!

policy-map TEST-TEST

class TEST-TEST

police cir 125000000 bc 1250000 be 1250000 conform-action transmit

exceed-action transmit

class class-default

police cir 125000000 bc 1250000 be 1250000 conform-action transmit

exceed-action transmit

!

policy-map ALL

class class-default

shape average percent 100

service-policy TEST-TEST

!

interface ethernetX

description #TEST #

ip address x.y.z.a 255.255.255.252

bgp-policy destination ip-qos-map

load-interval 30

service-policy input UPLINK

service-policy output ALL

========================================================================

Regards,

1 REPLY
Hall of Fame Super Silver

Re: MRTG for INTL & DMESTIC traffic

Hello Moorthy,

this is an example of BGP QoS policy propagation using BGP communities

see the following feature description

http://www.cisco.com/en/US/docs/ios/11_1/feature/guide/bgpprop.html#wp4465

BGP is used to apply an internal QoS label (qos group) that is based on the fact that the source address is in one route that has a BGP community of type international

The domestic traffic ends in the default class.

the command

bgp-policy destination ip-qos-map

under interface config is part of this solution.

Hope to help

Giuseppe

173
Views
0
Helpful
1
Replies