Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

MS DHCP server and multi VLAN

Hello,

i have strange problem with MS DHCP server which i am unable to understand. One server hosts 3 DHCP scopes (data1, voice, data50). I also have 3 VLANs   1 (defualt) for data, 10 voice, 50 data. IP helper address is configured for VLAN 50 and 10.

DHCP scope for data 1 : 10.0.0.10-250

DHCP scope for data 50 : 172.16.0.10-172.16.1.250

I have HP 2910al-48G configured as default gateway, every VLAN has it's IP. That HP is connected to Cisco 3550, and 6 more Cisco 3500XL are connected to Cisco 3550. Now the problem

On some cisco 3500XL i configured port to be access port for vlan50. When i plug computer there i get the IP from data50 range and everything is great. Now when i plug the cable to some other port that has default configuration (so part of VLAN 1) i get the IP AGAIN from the DHCP range of VLAN50 (

172.16.0.10-172.16.1.250) . This is what is confusing me a lot and i don't know the explanation or how to fix it. When i disable data50 DHCP scope on the server and do ipconfing /release /renew i get the DHCP lease from data1 DHCP scope like i am supposed to.

Anyone have explanation for this? Thanks!

Everyone's tags (4)
4 REPLIES
New Member

Re: MS DHCP server and multi VLAN

It will be helpful if you can give some diagram of the scenario.

Check out for any Native Vlan mismatch and also your helper address on the vlan interface.

Also paste switch port and trunk port configuration.

H2H

Bhargav

New Member

Re: MS DHCP server and multi VLAN

Hi,

here is the diagram.

http://img9.imageshack.us/img9/112/dhcpdiagram.jpg

HP

Port 48 i used as a trunk port.

vlan 1

   name "Data"

   untagged 5-14,16-48

   ip address 10.0.0.254 255.255.255.0

   no untagged 1-4,15

   exit

vlan 10

   name "Voice"

   untagged 1-4

   qos priority 6

   ip helper-address 10.0.0.11

   ip address 10.0.1.254 255.255.255.0

   tagged 5-46,48

   exit

vlan 300

   name "WiFi"

   no ip address

   exit

vlan 40

   name "BellSystem"

   no ip address

   exit

vlan 50

   name "New_LAN_Subnet"

   untagged 15

   ip helper-address 10.0.0.11

   ip address 172.16.0.254 255.255.254.0

   tagged 48

   exit

Cisco 3550

interface GigabitEthernet0/6

description link to HP2910al

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

interface Vlan1

ip address 10.0.0.253 255.255.255.0

!

interface Vlan10

no ip address

ip helper-address 10.0.0.11

!

interface Vlan20

no ip address

!

interface Vlan50

no ip address

!

interface Vlan100

no ip address

!

interface Vlan200

no ip address

!

ip default-gateway 10.0.0.254

ip classless

ip route 0.0.0.0 0.0.0.0 10.0.0.254

ip http server

Cisco 3500XL

interface FastEthernet0/40

!

interface FastEthernet0/41

!

interface FastEthernet0/42

!

interface FastEthernet0/43

!

interface FastEthernet0/45

description New_LAN

switchport access vlan 50

spanning-tree portfast

!

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet0/2

!

interface VLAN1

ip address 10.0.0.250 255.255.255.0

no ip directed-broadcast

no ip route-cache

!

ip default-gateway 10.0.0.254

Message was edited by: Damir Reic

New Member

Re: MS DHCP server and multi VLAN

1 thing i nocited on DHCP server:

Superscope is configured with 10.0.0.10-250 and 10.0.1.10-250, i added 172.16.0.10-172.16.1.250 to that superscope and probably that could be the problem. I now created new scope for VLAN50 and soon i'll head out to location.

This might be the solution to my problem.

New Member

Re:MS DHCP server and multi VLAN

Always beware of native vlan issues when mixing vendors, if necessary create an unused vlan on the Cisco and mark it native.

Sent from Cisco Technical Support Android App

1851
Views
0
Helpful
4
Replies
CreatePlease login to create content