Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

MST issue between cisco2950 and cisco4006

hi,

i configured mst among 2 cisco2950 and 1 cisco4006. i believed i typed in all required setting on them, but the mst seems works only on 2 2950, not 4006.

config on all 3 switch:

4006:

#MST (IEEE 802.1s)

set spantree priority 24576 mst 3

set spantree priority 24576 mst 5

#MST Configuration

set spantree mst config rollback force

set spantree mst config name abc revision 10

set spantree mst 0 vlan 1-102,107-4094

set spantree mst 3 vlan 103-104

set spantree mst 5 vlan 105-106

set spantree mst config commit

2950:

j2950#sh spanning-tree mst configuration

Name [abc]

Revision 10

Instance Vlans mapped

-------- ---------------------------------------------------------------------

0 1-102,107-4094

3 103-104

5 105-106

-------------------------------------------------------------------------------

based on the config, 4006 is supposed to be the root for instance 3 and 5. but somehow one 2950 worked as root for instance 3 and 5. even worse, 4006 is totally invisible for both 2950.

after enable the debug on 2950, some output looks like below: (fa0/1 connected to my 4006 and fa0/24 is to another 2950)

17:33:11: MST[0]: Fa0/1 ( designatedportid, fromMyregion 1)

17:33:11: MST(0): Fa0/1 rcvd info remaining 6

17:33:11: MST:BPDU DUMP [rcvd_bpdu Fa0/1 Repeated]

17:33:11: MST: Proto:0 Version:3 Type:2 Role: DesgFlags[ F ]

17:33:11: MST: Port_id:8414 cost:200000

17:33:11: MST: root_id :0001.4252.3549 Prio:32768

17:33:11: MST: br_id :0003.e316.e200 Prio:32768

17:33:11: MST: age:1 max_age:20 hello:2 fwdelay:15

17:33:11: MST: V3_len:116 PathCost:0 region:eds rev:10

17:33:11: MST: ist_m_id :0003.e316.e200 Prio:32768 Hops:20 Num Mrec: 2

17:33:11: MST[0]: Fa0/24 ( designatedportid, fromMyregion 1)

17:33:11: MST(0): Fa0/24 rcvd info remaining 6

17:33:11: MST:BPDU DUMP [rcvd_bpdu Fa0/24 Repeated]

17:33:11: MST: Proto:0 Version:3 Type:2 Role: DesgFlags[ FL ]

17:33:11: MST: Port_id:32770 cost:200000

17:33:11: MST: root_id :0001.4252.3549 Prio:32768

17:33:11: MST: br_id :000c.8582.3800 Prio:32768

17:33:11: MST: age:1 max_age:20 hello:2 fwdelay:15

17:33:11: MST: V3_len:116 PathCost:200000 region:eds rev:10

17:33:11: MST: ist_m_id :0003.e316.e200 Prio:32768 Hops:19 Num Mrec: 2

17:33:11: MST: stci=3 Flags[ FL ] Hop:20 Role:Desg [Repeated]

17:33:11: MST: br_id:000c.8582.3800 Prio:32771 Port_id:32770 Cost:0

17:33:11: MST: stci=5 Flags[ FL ] Hop:20 Role:Desg [Repeated]

17:33:11: MST: br_id:000c.8582.3800 Prio:32773 Port_id:32770 Cost:0

17:33:12: MST[0] Tree timer expired (code 1)

17:33:12: MST[0]: Fa0/1 (hello=1 mport_count=0 tx_count=0

17:33:12: MST[0]: Fa0/24 (hello=1 mport_count=2 tx_count=0

17:33:12: MST[0] (re)starting transmit timer

17:33:13: MST[0] Tree timer expired (code 1)

17:33:13: MST[0]: Fa0/1 (hello=0 mport_count=0 tx_count=1

17:33:13: MST[0]: Fa0/24 (hello=0 mport_count=2 tx_count=1

17:33:13: MST[0] (re)starting transmit timer

so pls shed a light.

thanks

5 REPLIES

Re: MST issue between cisco2950 and cisco4006

Hi,

I am not expert in MST, the problem I missed MST show yesterday in Cisco tv due to some internet problem.

Anyways, From what I recognized, You missed to configure the Region.

In order for Bridges to have the same spanning-tree MST overview , they should be in the same region.

I would like also to have Francois's valuable comment on this, as he could give us excellent picture.

HTH

Mohamed

Community Member

Re: MST issue between cisco2950 and cisco4006

Mohamed,

thanks for ur reply. But it is not my story.

i had set the region name and revision number on all these 3 switches.

name=abc

revision=10

instant 3:vlan103, 104

instant 5:vlan105, 106

but anyway, thanks for ur comment.

Re: MST issue between cisco2950 and cisco4006

Hi,

Could you forward a "show span mst detail" for the relevant interfaces on the IOS boxes, and the equivalent on the catos box (probably some form of show spantree mst, can remember the exact command, but you must know;-)

I don't remember all the subtlety of the MST debug in the pre-standard release, but it seems indeed that the mrecords received on f0/1 are not displayed, while they are for f0/24.

Did you allow any vlan mapped to instance 3 and 5 on f0/1? We only create the MSTI information on this condition.

Regards,

Francois

Community Member

Re: MST issue between cisco2950 and cisco4006

thanks, Francois

i had figured out the reason.

some trunking setting is inconsistent on my 4006 and 2950. after correct the setting, everything looks fine so far.

==

sh spanning-tree mst 3

###### MST03 vlans mapped: 103-104

Bridge address 000d.bd01.ac00 priority 32771 (32768 sysid 3)

Root address 0003.e316.e200 priority 24579 (24576 sysid 3)

port Fa0/1 cost 180000 rem hops 19

Interface Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Fa0/1 Root FWD 180000 128.1 P2p

Fa0/24 Desg FWD 200000 128.24 P2p

j2950#sh spanning-tree mst 5

###### MST05 vlans mapped: 105-106

Bridge address 000d.bd01.ac00 priority 32773 (32768 sysid 5)

Root address 0003.e316.e200 priority 24581 (24576 sysid 5)

port Fa0/1 cost 200000 rem hops 19

Interface Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Fa0/1 Root FWD 200000 128.1 P2p

Fa0/24 Altn BLK 200000 128.24 P2p

thanks again.

Re: MST issue between cisco2950 and cisco4006

The vlans were not allowed or the port was not trunking, right?

F.

446
Views
0
Helpful
5
Replies
CreatePlease to create content