Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

MSTP Help!

Hi all

I thought I understood MSTP but clearly not. I was wondering if I can pick your brains? Not literally of course.

I have a topology as such:

3560-1 <----> 3560-2

    |                        |    

    |                        |

6509-1 <----> 6509-2

-Two 6509s Etherchanneled together

- 6509-1 the root for MST0

- 6509-2 the root for MST1

- Above this we have 2 x 3560 switches that are connected via Gi0/2 to each other. Only VLANs 2 and 3 allowed to these switches.

- All links 802.1Q

Ok, with any other site where we have a handful of VLANs that exist on all switches and no pruning takes on the trunks place I would ordinarily put identical MSTP config across all switches. Then I'd use the 'priority' command to dictate who is the root and who is secondary root. However, for this site in question we have many a VLAN (and switch, but not shown here) and have the need to manually prune VLANs from the trunks.

Now, if we're manually pruning VLANs from the trunks I therefore don't have the need to create all the VLANs on the network on each switch, however, from an MSTP configuration point of view will I still need to define an identical VLAN to MST instance mapping across all access/core switches even though the VLANs don't need to exist on every device?

This is my current config

Core-1:

vlan 2

vlan 3

vlan 4

vlan 5

vlan 6

vlan 7

!

spanning-tree mode mst

spanning-tree mst configuration

name test

instance 1 vlan 3, 5, 7

!

Spanning-tree instance 0 priority 0

Spanning-tree instance 1 priority 4096

!

interface g1/26

Description To 3560-1 Gi0/1

switchport trunk allowed vlan 2,3

Core-2:

vlan 2

vlan 3

vlan 4

vlan 5

vlan 6

!

spanning-tree mode mst

spanning-tree mst configuration

name test

instance 1 vlan 3, 5, 7

!

spanning-tree instance 0 priority 4096

spanning-tree instance 1 priority 0

!

interface g1/26

description To 3560-2 Gi0/1

switchport trunk allowed vlan 2,3

!

3560-1:

vlan 2

vlan 3

!

spanning-tree mode mst

spanning-tree mst configuration

name test

instance 1 vlan 3

!

spanning-tree instance 0-1 priority 16384

!

!

interface g0/1

description To Core-1 Gi1/26

switchport trunk allowed vlan 2,3

!

3560-2:

vlan 2

vlan 3

!

spanning-tree mode mst

spanning-tree mst configuration

name test

instance 1 vlan 2

!

spanning-tree instance 0-1 priority 16384

!

!

interface g0/1

Description To Core-1 Gi1/26

switchport trunk allowed vlan 2,3

What I'm finding is that I appear to get two different regions as a result of my config. When I do a show spanning-tree (don't have the output here, writing from memory), I get the following on my 3560 interfaces that connect to the core: P2p Bound(RSTP) with 3560-1 showing as the root bridge for MST1?!?

So, to clarify, would I need to actually make the MSTP config the same on the two 3560s as the cores in order to satisfy the MSTP requirement of creating an homogenous region? which would therefore turn my 3560 configs into:

3560-1:

vlan 2

vlan 3

vlan 4

vlan 5

vlan 6

vlan 7

!

spanning-tree mode mst

spanning-tree mst configuration

name test

instance 1 vlan 3, 5, 7

!

spanning-tree instance 0-1 priority 16384

!

interface g0/1

description To Core-1 Gi1/26

switchport trunk allowed vlan 2,3

3560-2:

vlan 2

vlan 3

vlan 4

vlan 5

vlan 6

vlan 7

!

spanning-tree mode mst

spanning-tree mst configuration

name test

instance 1 vlan 3, 5, 7

!

spanning-tree instance 0-1 priority 16384

!

interface g0/1

description To Core-1 Gi1/26

switchport trunk allowed vlan 2,3

I think I'm getting the wrong end of the stick and confusing myself. I would appreciate you assistance in this (hopefully) trivial matter.

Many thanks to all.

Everyone's tags (1)
2 REPLIES

MSTP Help!

Devlin,

Your configurations have to match between switches or MST thinks they're in different regions. I don't think there will be an issue mapping the non-existent vlans to your instances even though you're pruning them on the trunks.

HTH,

John

HTH, John *** Please rate all useful posts ***

MSTP Help!

Hi John

First off thank you for your reply and secondly apologies for my late one. Having a consitent configuration throughout the LAN did the trick.

Many thanks.

527
Views
0
Helpful
2
Replies
CreatePlease login to create content