Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Multicast Data Drop on 3750X


We are currently experiencing random multicast data dropouts on ports that are connected to a 3750X in VLAN ports.


A test PC was connected to a routed port and we do not have any dropouts of the multicast data.
We also took a 2960G and plugged it into VLAN ports on the 3750X.  Any test PC that is on the 2960G does not lose traffic.

The traffic only drops on PCs that are connected to a port on the 3750X that is in a VLAN.  The data drops are random and last approximatly 55-59 seconds
before we start receiving multicast traffic again.

I do not see any input/output errors on the interfaces
sh platform port-asic stat drop also show no drops

CPU runs at about 50% on the 3750X

Below is the configuration of the 3750X

Building configuration...

Current configuration : 8454
!
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname XXXXX
!
boot-start-marker
boot-end-marker
!
!
enable password 1 XXXXXXX
!
no aaa new-model
clock timezone CST -6 0
clock summer-time CST recurring
switch 1 provision ws-3750x-12s
switch 2 provision ws-c3750x-48
system mtu routing 1500
ip routing
!
!
!
no ip domain-lookup
ip multicast-routing distributed
!
!
spanning-tree mode pvst
spanning-tree extended system-id
!
!
vlan internal allocation policy ascending
!
!
interface Loopback0
ip address 192.168.x.x 255.255.255.255
ip pim sparse-mode
ip igmp join-group 233.2.x.x
!
interface GigabitEthernet1/0/1
description Primary Route
no switchport
ip address 192.168.x.x 255.255.255.252
ip pim sparse-mode
ip igmp join-group 233.2.x.x
ip igmp join-group 233.2.x.x
ip igmp join-group 233.2.x.x
ip ospf cost 2
!
interface GigabitEthernet1/0/2
description Secondary Route
no switchport
ip address 192.168.x.x 255.255.255.252
ip pim sparse-mode
ip igmp join-group 233.2.x.x
ip igmp join-group 233.2.x.x
ip igmp join-group 233.2.x.x
ip ospf cost 100
!
interface GigabitEthernet1/0/3
description Test PC1
no switchport
ip address 192.168.x.x 255.255.255.128
ip pim sparse-mode
ip igmp join-group 233.2.x.x
ip igmp join-group 233.2.x.x
ip igmp join-group 233.2.x.x
!
interface GigabitEthernet1/0/4
description Test PC2
no switchport
ip address 192.168.x.x 255.255.255.128
ip pim sparse-mode
ip igmp join-group 233.2.x.x
ip igmp join-group 233.2.x.x
ip igmp join-group 233.2.x.x
!
interface GigabitEthernet 2/0/1
description Test PC3
switchport access vlan 3
!
!
interface GigabitEthernet 2/0/2
description Catalyst 2960G
switchport access vlan 3
!
!
interface GigabitEthernet 2/0/3
description Test PC4
switchport access vlan 4
!
!
interface GigabitEthernet 2/0/4
description Catalyst 2960G
switchport access vlan 4
!
interface Vlan3
ip address 192.168.x.x 255.255.255.128
ip pim sparse-mode
ip igmp join-group 233.2.x.x
ip igmp join-group 233.2.x.x
ip igmp join-group 233.2.x.x
!
interface Vlan4
ip address 192.168.x.x 255.255.255.128
ip pim sparse-mode
ip igmp join-group 233.2.x.x
ip igmp join-group 233.2.x.x
ip igmp join-group 233.2.x.x
!
router ospf 10
redistribute connected subnets
network 192.168.0.0 0.0.255.255 area 0
!
!
ip http server
ip http secure-server
!
!
ip sla enable reaction-alerts
logging esm config
logging 192.168.x.x
!
!
line con 0
login local
speed 115200
line vty 0 4
login local
length 0
line vty 5 15
login local
!
ntp server 192.168.x.x
end

Everyone's tags (1)
3 REPLIES
VIP Super Bronze

Multicast Data Drop on 3750X

Do you have the same issue if you are using different ports on the same 3750 or is it just one port that is causing problems?

New Member

Multicast Data Drop on 3750X

We have tried multiple ports and still have the same problem.

vpr
New Member

Multicast Data Drop on 3750X

Did you solve the problem?

We are currently experiencing multicast dropouts on 3750X in stack with 3750G (with multicast source). No dropouts between two 3750Gs in stack though. Mirroring a 3750G port with multicast trraffic to 3750X once again gives us no dropouts.

1005
Views
0
Helpful
3
Replies
CreatePlease to create content