Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
JF
Community Member

Multicast flooding with IGMP Snooping

Hello,

I have a VSS with 2x 4500x (Release 3.4.0SG ED) and 3750x (Release 12.2.58.SE2) access switches.

Two multicast streamers are connected to core switches and boxes are connected to access switches.

IGMP Querrier is configured on Core and fast-leave on access. All equipment are in the same VLAN so i didn't configure multicast routing on the SVI.

On the core switch, i see all the groups (90x) who are diffused by the streamers on the interface of the streamer.

But when i do a wireshark capture on the etherchannel who is going to my access switches, i see all groups diffused!

I don't understand why multicast traffic are diffused on link who not belong to the IGMP group.

Do you have an idea ?

Some commands of the core switchs :

RSW01-MDF1#show ip igmp snooping groups vlan 300

Vlan      Group                    Version     Port List

---------------------------------------------------------

300       239.1.1.12               v2          Te1/2/4

300       239.1.1.21               v2          Te2/2/2

300       239.1.1.23               v2          Te2/2/2

300       239.1.1.27               v2          Te2/2/2

... (x90)

RSW01-MDF1#show int | i Des|bits

  Description: To_SW01-05_1:Po24

  5 minute input rate 5094000 bits/sec, 868 packets/sec

  5 minute output rate 43043000 bits/sec, 4422 packets/sec

...

RSW01-MDF1#sh ip igmp snooping vlan 300

Global IGMP Snooping configuration:

-------------------------------------------

IGMP snooping                : Enabled

IGMPv3 snooping              : Enabled

Report suppression           : Enabled

TCN solicit query            : Disabled

TCN flood query count        : 2

Last member query interval   : 1000

Vlan 300:

--------

IGMP snooping                       : Enabled

CAPWAP enabled                      : Disabled

IGMPv2 immediate leave              : Disabled

Explicit host tracking              : Enabled

Multicast router learning mode      : pim-dvmrp

CGMP interoperability mode          : IGMP_ONLY

Last member query interval          : 1000

RSW01-MDF1#show run

(...)

ip igmp snooping querier

!

interface Port-channel24

switchport

switchport trunk allowed vlan 5,10,100,120,200,210,300,410,430,450,580,600,610

switchport mode trunk

load-interval 30

ip dhcp snooping trust

!

interface TenGigabitEthernet1/1/15

switchport trunk allowed vlan 5,10,100,120,200,210,300,410,430,450,580,600,610

switchport mode trunk

udld port aggressive

channel-group 24 mode active

service-policy output EGRESS-QUEUING

ip dhcp snooping trust

!

interface TenGigabitEthernet2/1/15

switchport trunk allowed vlan 5,10,100,120,200,210,300,410,430,450,580,600,610

switchport mode trunk

udld port aggressive

channel-group 24 mode active

service-policy output EGRESS-QUEUING

ip dhcp snooping trust

!

interface Vlan300

description IPTV

ip vrf forwarding IPSERVICES

ip address 10.3.3.254 255.255.252.0

no ip redirects

no ip unreachables

no ip proxy-arp

!

(...)

Thanks.

3 REPLIES
Community Member

Hi Bob,

Hi Bob,

Did you ever find out the cause and/or resolution to this issue?

We seem to be experiencing the same thing...

Thanks,

JF
Community Member

Hello,

Hello,

It was an instability of the spanning-tree (a trunk interface in the network was flapping and generate TCN every minutes). An IGMP snooping-enabled switch floods multicast traffic to all ports in a VLAN when a spanning-tree Topology Change Notification (TCN) is received.

Usefull CLI to check stp stability :

Router#sh spanning-tree vlan 300 det | in ieee|from|occur|exec

VLAN0300 is executing the rstp compatible Spanning Tree protocol

  Number of topology changes 208 last change occurred 00:00:13 ago

          from Port-channel36

Hope this help

Community Member

Re: Hello,

HELLO JF ,

 

we have mulicast streamers ( video wall ) , for that we have enable the IGMP snooping and querier on the switch ( cisco 4506 E ) not on the VLAN .

We have one vlan only , when this multicast streamer is connected to the switch it make all other device very slow and even loss of packets .

we need to kniow what can be done to solve this issue .

 

i have attached the wireshark output and the snapshot for the ping 

https://drive.google.com/open?id=14jX9PcxwzmdC2upydX-9v5rKtgh_jS1x

 

 

1368
Views
5
Helpful
3
Replies
CreatePlease to create content