Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Multicast Issue on One Site

Hi -

trying to resolve an issue with multicasting. We have a site that is working fine and we have a site that is not working. We are not sure if the issue is with the router or the host device trying to receive multicast traffic. The configurations are identical on both sites but, the only difference is that the site that isn't working has layer 2, 3750s hanging off the 3750 Core. The other working site only has a core switch.

Must I add any multicast config on the layer 2 switch?

Thank you

Everyone's tags (1)
4 REPLIES
Hall of Fame Super Blue

Multicast Issue on One Site

Patrick

You shouldn't need to add anything to the L2 switches (3750) as IGMP snooping is enabled by default. However you will need something to make the IGMP queries but i am assuming you have at least one L3 vlan interface in the site that isn't working with PIM enabled ?

Perhaps you could give us some more detail ie. what isn't working, what are your multicast configs etc.

Jon

New Member

Multicast Issue on One Site

Jon,

I've actually have ip pim passive configured on the VLAN interfaces of the Core switches. It seems to work on the one site though.

I've configured on switches:

ip multicast-routing distributed

interface GigabitEthernet1/0/47

description WN-1002X G0/0/1

no switchport

ip address 172.20.1.217 255.255.255.248

ip pim sparse-dense-mode

srr-queue bandwidth share 1 30 35 5

priority-queue out

mls qos trust dscp

auto qos trust

spanning-tree portfast

spanning-tree bpduguard enable

end

!

On the routers:

Configured mroutes as it is going across an MPLS carrier

WN-1002-WAN1#sh run | i mroute

ip mroute 172.20.8.0 255.255.252.0 Tunnel105

ip mroute 10.255.255.1 255.255.255.255 Tunnel105

ip mroute 172.20.28.0 255.255.252.0 Tunnel105

ip mroute 172.30.60.0 255.255.252.0 Tunnel105

ip mroute 172.20.32.0 255.255.252.0 Tunnel105

!

ip pim rp-address 10.255.255.1

!

Thanks

Hall of Fame Super Blue

Multicast Issue on One Site

Patrick

Do you know whether the stream is actually making it into the site or is it not getting out of the first site ?

Have you ensured the TTL is set high enough for all the L3 hops.

Where is the RP in relation to the site that is not working ?

Jon

New Member

Re: Multicast Issue on One Site

Don't have access to the equipment. Tuesday was my last day PC Connection. Starting new job Monday. Thanks for your help.

Pat

Sent from Cisco Technical Support iPad App

114
Views
10
Helpful
4
Replies