Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Multicast Issues

So I'm working on a project at work with Multicasting. This is the first time I've experienced multicasting so bear with me.

A friend at a different company said that it's a pretty simple process and you just turn on ip-multicasting on the main switch, put pim on the vlan you want enabled and make sure IGMP is on the edge switches. I've done all that and the latency goes to crap at my remote sites. I get huge delay, dropped packets, etc. I'm not seeing high processor usage and I'm just trying to find a way to find out what's going on. We have some weird setups so, maybe it's hard to do what we're doing?

Our Setup:

3 Main sites - 500MB Embarq Metro Ethernet that connect to each other through Cisco 6509s with encryption on the line.

Over 10 remote sites connected to our main site with 10MB Metro Ethernet also. These sites have Cisco 2821 routers.

So right now I'm only focusing on the three large sites (where the cameras will be) and turning pim on those vlans.

Site 1

--------

VLAN 1

ip pim sparse-dense

VLAN 100 (vlan that connects to the main site)

ip pim sparse-dense

Site 2

--------

VLAN 1

ip pim sparse-dense

VLAN 110

ip pim sparse-dense

Site 3

-------

VLAN 100

ip pim sparse-dense

VLAN 110

ip pim sparse-dense

VLAN 4 (my pc lan I'm testing on)

ip pim sparse-dense

That's pretty much a very reduced look at our network, but hopefully it will help. Also, I forgot to mention that we're running EIGRP at all sites.

1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Re: Multicast Issues

In sparse-dense mode, the ACL is used to prevent routers from advertising auto-rp message to the mcast groups 224.0.1.39 and 224.0.1.40.

Thanks,

p.s. please rate if helpful.

19 REPLIES
Cisco Employee

Re: Multicast Issues

Hi Adam,

My first question for you is how big (Kbps/Mbps) is the multicast stream?

I see you are using "ip pim sparse-dense" mode, the router will try to look for a RP (via static RP, AutoRP, etc.) on your network. If there isn't any RP configured, the router will use dense mode as its last resort. With dense mode, the multicast traffic will push to all the links with PIM enabled eventhough there isn't any multicast request.

HTH,

jerry

New Member

Re: Multicast Issues

Jerry,

The cameras from our vendor are setup to stream at a target rate of 1500 kbps. I am testing this with 10 or so cameras at one location and it starts to lag just on that one location. I could never figure out how to get the RP syntax correct so used sparse-dense instead.

What worries me is that right now I'm just testing with these 10 cameras and have lag issues, but the end goal here is my boss wants to put 'all' our cameras on ip, which is over 100 cameras.

Thanks.

Cisco Employee

Re: Multicast Issues

Hi Adam,

I will suggest you should test the multicast traffic 1 hop at a time. Test it on the same VLAN as the multicast source (the camera IP interface) to see is there any lag. If there is lag, make sure the interface is not taking any error with "show ip interface x/x" for both source and client. Also, you can use "show ip mroute count" to see is there any problem on the L3 interface.

HTH,

jerry

New Member

Re: Multicast Issues

Jerry,

As far as I can see everything works at each site properly. The cameras are up and running at each location and I do not see latency issues when the multicast packets stay within their site. Once I try and route the packets to other sites that is when the whole network seems to lag bad.

I was researching using the sparese PIM and creating a loopback interface for the RP. Would this work?

I'm in charge of this stuff, but I'm very new to networking and Cisco in general. This month I'm going to a week class for my CCENT so maybe that will help.

Thanks.

Cisco Employee

Re: Multicast Issues

I see, then the problem is the WAN, and you see use "show ip interface x/x" to see is there any problem.

Training is always good, but I am not sure the CCENT class cover any multicast.

Regards,

jerry

New Member

Re: Multicast Issues

It seems like the WAN is causing issues. I have it turned off currently, but will start looking at it when I'm back in the office.

However, why would this cause issues at my main site for all of the 10MB WAN connections? There are pretty much two or three large sites where all of the multicast video will be originating from and some viewers will be at my location which is where all of the 10MB wan sites connect. I don't (at least now) want the 10MB sites to see the multicast traffic and currently they don't have ip pim on their vlan interface.

I'll look at the interfaces later today, thanks for the prompt replies!

Adam

Bronze

Re: Multicast Issues

I am not usre if this will help but you can try to limit the mcast group across your WAN using ip multicast boundary.

New Member

Re: Multicast Issues

And that is where the confusion begins... all of the different commands/types of multicast things begins to confuse me. I've read up on multicast boundary and seen a few code examples, but to implement it seems to be a monumental task.

I'm still trying to figure out multicasting and all of it's properties let alone the small little details you can do with it.

Bronze

Re: Multicast Issues

I will at least setup a RP. Hope the attachments help...

Hall of Fame Super Silver

Re: Multicast Issues

Hello Etienne,

you are right

sparse mode requires the setting of RP to work.

Best Regards

Giuseppe

New Member

Re: Multicast Issues

Thanks for the attachments earlier Etienne! I'm up and running with Anycast RP. The latency does seem to be improved, but there is still a little overall lag (sitewide went from around 3ms to 7-8ms).

I tried setting up access-lists for which multicast streams could go through, but it didn't seem to work.

Our cameras have a subnet of 239.24.0.0/16 so from reading I thought this would work, no?

access-list 10 permit 239.24.0.0

ip pim rp-address 172.29.50.1 10

However, that stopped all multicast traffic.

Here is an example of one of the RP:

-------------------------------------

ip pim rp-address 172.29.50.1

router eigrp 500

network 172.29.50.0

int loopback 1

desc Interface for Anycast RP

ip add 172.29.50.1 255.255.255.255

ip pim sparse-mode

int loopback 2

desc Interface for MSDP

ip add 172.29.51.1 255.255.255.255

ip pim sparse-mode

ip msdp peer 172.29.51.2 connect-source loopback 2

ip msdp originator-id loopback 2

int vlan 4

ip pim sparse-mode

int vlan 11

ip pim sparse-mode

Thanks!

Bronze

Re: Multicast Issues

Here is what I have currently working:

Core_CHI_1

ip pim rp-address 10.33.63.1 core-multicast-rp override

ip pim autorp listener

ip pim spt-threshold infinity

ip pim send-rp-announce Loopback1000 scope 255 group-list core-multicast-rp interval 10

ip pim send-rp-discovery scope 255

ip msdp peer 10.33.63.101 connect-source Loopback1001

ip msdp cache-sa-state

ip msdp originator-id Loopback1001

ip access-list standard core-multicast-rp

deny 224.0.1.39

deny 224.0.1.40

permit 224.0.0.0 15.255.255.255

interface Loopback0

ip address 10.33.95.4 255.255.255.255

!

interface Loopback1000

description Anycast RP Interface

ip address 10.33.63.1 255.255.255.255

ip pim sparse-mode

!

interface Loopback1001

description MSDP Peer Source Network Interface

ip address 10.33.63.102 255.255.255.255

ip pim sparse-mode

router eigrp 20

network 10.33.63.1 0.0.0.0

network 10.33.63.102 0.0.0.0

Core_CHI_2

ip pim rp-address 10.33.63.1 core-multicast-rp override

ip pim autorp listener

ip pim spt-threshold infinity

ip pim send-rp-announce Loopback1000 scope 255 group-list core-multicast-rp interval 10

ip pim send-rp-discovery Loopback0 scope 255

ip msdp peer 10.33.63.102 connect-source Loopback1001

ip msdp cache-sa-state

ip msdp originator-id Loopback1001

ip access-list standard core-multicast-rp

deny 224.0.1.39

deny 224.0.1.40

permit 224.0.0.0 15.255.255.255

interface Loopback1000

description Anycast RP Interface

ip address 10.33.63.1 255.255.255.255

ip pim sparse-mode

!

interface Loopback1001

description MSDP Peer Source Network Interface

ip address 10.33.63.101 255.255.255.255

ip pim sparse-mode

router eigrp 20

network 10.33.63.1 0.0.0.0

network 10.33.63.101 0.0.0.0

I also use "ip pim sparse-dense-mode" on all VLANs participating in mcast.

p.s. please rate posting that helps you!

New Member

Re: Multicast Issues

Cool, that helps. I have all those commands except:

ip pim autorp listener

ip pim spt-threshold infinity

ip msdp cache-sa-state

access-lists

Few questions now that I see yours:

1. Why would you use sparse-dense? Isn't the less bandwidth busy way to go sparse mode?

2. Is there a difference from using the ip access list and just a regular access list?

3. How would a remote router setup look like? Just the rp-address line? Do I need to put access-list on those routers or just the RP?

Thanks!

Bronze

Re: Multicast Issues

1. I use sparse-dense mode because we connect to some networks that use spare mode. Having sparse-dense mode allows us to use both methods when needed.

2. No that I know of. I just like to use ip access-list standard and ip access-list extended.

3. Other than ip multicast-routing distributed, I have ip pim rp-address x.x.x.x

New Member

Re: Multicast Issues

Awesome! You've been a great help in my multicast journey.

So only having the access-list on your RP router permits or denies multicast traffic from routing between the routers?

Bronze

Re: Multicast Issues

No, for that I use ip multicast boundary "ACL NAME OR NUMBER"

Here is what mine looks like:

access-list 99 permit 239.255.46.14

access-list 99 permit 239.255.46.15

access-list 99 permit 239.255.46.12

access-list 99 permit 239.255.46.13

access-list 99 permit 239.255.46.11

access-list 99 permit 239.255.46.1

access-list 99 permit 224.0.0.10

access-list 99 deny any

nterface GigabitEthernet1/12

ip address 10.33.94.105 255.255.255.252

ip pim sparse-dense-mode

ip multicast boundary 99

New Member

Re: Multicast Issues

Sorry for the continuous questions, but what would the access list associated to the RP be used for? Thanks!

Bronze

Re: Multicast Issues

In sparse-dense mode, the ACL is used to prevent routers from advertising auto-rp message to the mcast groups 224.0.1.39 and 224.0.1.40.

Thanks,

p.s. please rate if helpful.

New Member

Re: Multicast Issues

Great! Thanks for all the great help everyone. This was a great learning opportunity.

585
Views
19
Helpful
19
Replies
CreatePlease to create content