Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Multicast not working L2 Nexus 5500

I have a pair of Nexus 5596s set up as a HA core running vpcs to several fabric extenders in my datacenter. I have a simple L2 VLAN I allocated for my Linux team to use as a "heartbeat/cluster" segment, their servers have a single interface to use to communicate on this VLAN via multicast but it does not seem to be working. I checked IGMP snooping and the swtiches are snooping on all the ports in this particular VLAN.....I'm not sure what else to look at...not sure why it wouldn't work while on the same VLAN.

Any help would be greatly appreciated.

Jeff

4 REPLIES
Hall of Fame Super Blue

JeffThis may or may not be

Jeff

This may or may not be the issue but have you enabled the IGMP snooping querier function ?

If you are only running multicast within that vlan and have not enabled PIM on the L3 SVI because you don't need to route the multcast, then you need something within the vlan to make IGMP queries so the switch can build the forwarding table. 

This is what the querier function does.

Like i say, it may not be the issue but worth a check.

Jon

New Member

Thanks Jon....I had found

Thanks Jon....I had found that since I posted this, but the command "ip igmp snooping querier <ip address>" is not a valid command.....I'm not sure why though, the 5500 doc says it is valid. I may build a L3 interface for this VLAN and put PIM on it and just not have it participate in EIGRP.....not sure what else to try.

Hall of Fame Super Blue

JeffJust out of interest did

Jeff

Just out of interest did you try applying the command in vlan mode ie. you have to change to the vlan and then you should be able to enable it.

Apologies if you have already tried this.

Jon

New Member

I was able to apply the

I was able to apply the command by using the "vlan configuration" command below on both 5596s.

vlan configuration <Vlan ID>

ip igmp snooping querier <IP Address>

 

That still didn't do it though. I ended up building a VLAN interface for this VLAN and left it out of EIGRP, then added "ip pim sparse-mode" to the VLAN interfaces and everything worked fine.....not sure why the L2 querier didn't work, when I get time I may come back to this and do some testing but for now we are going to leave it as is.

 

Thanks for your help.

 

Jeff

 

105
Views
0
Helpful
4
Replies
CreatePlease to create content