Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Multicast on Cisco 3560

Hello, I am looking for help with multicasts on Cisco 3560  - connected directly to streamer and to two L2 switches (2950, 2960), steamer on its own is linux debian and I am using VLC. So multicast is directly streamed into local Vlan 60 and I can clearly see that it arrives on interface of vlan 60 by ACL I have for this reason applied, but there everything ends it is not switched into other vlans. Before I used physical port with no switchport configuration on for streaming and other one for telnet access I could clearly see that multicast traffic goes thourgh, But it doesn't work out with vlans and whole IGMP, PIM infrastructure i builded for it. Is anyone who tried to sort out similar problem willing to share his (her) experience? I am starting to be desperate

Here is shortage of my conf on main 3560

  version 15.2

ip routing
!
ip multicast-routing distributed
ip sap cache-timeout 60
ip device tracking
ip igmp snooping querier
ip igmp snooping vlan 40 last-member-query-interval 120
ip igmp snooping vlan 50 last-member-query-interval 120
!
interface GigabitEthernet0/1
switchport access vlan 60
switchport mode access
!
interface GigabitEthernet0/20
switchport access vlan 60
switchport mode access
!
interface GigabitEthernet0/21
no switchport
ip address 192.168.10.200 255.255.255.0
ip access-group zakaz-multi-na-port out
!
interface GigabitEthernet0/22
no switchport
no ip address
!
interface GigabitEthernet0/23
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/24
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan1
ip address 192.168.20.1 255.255.255.0
ip pim sparse-dense-mode
ip sap listen
!
interface Vlan40
ip address 40.0.0.1 255.255.255.0
ip igmp join-group 239.0.0.1
ip sap listen
!
interface Vlan50
ip address 50.0.0.1 255.255.255.0
ip igmp join-group 239.0.0.1
ip sap listen
!
interface Vlan60
ip address 60.0.0.1 255.255.255.0
ip igmp join-group 239.0.0.1

!
ip pim rp-address 192.168.20.1 acl-rp-multi
!
ip access-list standard acl-rp-multi
permit 224.0.0.0 15.255.255.255
deny   any
!
ip access-list extended ipmc-source
permit ip 60.0.0.0 0.0.0.255 224.0.0.0 15.255.255.255
deny   ip any 224.0.0.0 15.255.255.255 log
permit ip any any
ip access-list extended zakaz-multi-na-port
deny   ip 224.0.0.0 15.255.255.255 any
permit ip any any
!
monitor session 1 source vlan 60
monitor session 1 destination interface Gi0/22

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Multicast on Cisco 3560

Hi,

You need to enable pim on all L3 interfaces; make sure have config TTL higher than 1 on VLC; no need for static mroute; do not use 239.0.0.1 group.

HTH,

Lei Tian

4 REPLIES
Silver

Multicast on Cisco 3560

You haven't enabled PIM on SVI for VLAN 60. It could also be related to mrouter port. Does it work if you have receiver in the Cat 3560? See this document for additional troubleshooting:

http://www.cisco.com/en/US/products/hw/switches/ps708/products_tech_note09186a008059a9df.shtml

Daniel Dib CCIE #37149 Please rate helpful posts.
New Member

Multicast on Cisco 3560

Hello, thank you for your reply. As you adviced me I have added

ip pim sparse-dense-mode

on inr vlan 60 (meanwhile erased ip igmp join-group 239.0.0.1) 

and

ip mroute 60.0.0.0 255.255.255.0 60.0.0.2

and trying to receive stream on main L3 switch, in vlan 50, but still nothing, still IGMP for some reason can not find source, these are my logs and thank you in advance.

L3Streamer#debug ip igmp

IGMP(0): Received v2 Report on Vlan50 from 50.0.0.11 for 239.0.0.1

IGMP(0): Received Group record for group 239.0.0.1, mode 2 from 50.0.0.11 for 0 sources

L3Streamer#sh ip igmp snooping mrouter

Vlan    ports

----    -----

   1    Router

  40    Switch

  50    Switch

  60    Router

L3Streamer#sh ip igmp snooping querier detail

Vlan      IP Address               IGMP Version   Port            

-------------------------------------------------------------

1         192.168.20.1                  v2            Router                  

40        60.0.0.1                        v2            Switch                  

50        60.0.0.1                        v2            Switch                  

60        60.0.0.1                        v2            Router                  

Global IGMP switch querier status

--------------------------------------------------------

admin state                    : Enabled

admin version                  : 2

source IP address              : 60.0.0.1      

query-interval (sec)           : 60

max-response-time (sec)        : 10

querier-timeout (sec)          : 120

tcn query count                : 2

tcn query interval (sec)       : 10

Vlan 1:   IGMP switch querier status

--------------------------------------------------------

admin state                    : Enabled (state inherited)

admin version                  : 2

source IP address              : 60.0.0.1      

query-interval (sec)           : 60

max-response-time (sec)        : 10

querier-timeout (sec)          : 120

tcn query count                : 2

tcn query interval (sec)       : 10

operational state              : Disabled

operational version            : 2

tcn query pending count        : 0

Vlan 40:   IGMP switch querier status

--------------------------------------------------------

elected querier is 60.0.0.1        (this switch querier)

--------------------------------------------------------

admin state                    : Enabled (state inherited)

admin version                  : 2

source IP address              : 60.0.0.1      

query-interval (sec)           : 60

max-response-time (sec)        : 10

querier-timeout (sec)          : 120

tcn query count                : 2

tcn query interval (sec)       : 10

operational state              : Querier

operational version            : 2

tcn query pending count        : 0

Vlan 50:   IGMP switch querier status

--------------------------------------------------------

elected querier is 60.0.0.1        (this switch querier)

--------------------------------------------------------

admin state                    : Enabled (state inherited)

admin version                  : 2

source IP address              : 60.0.0.1      

query-interval (sec)           : 60

max-response-time (sec)        : 10

querier-timeout (sec)          : 120

tcn query count                : 2

tcn query interval (sec)       : 10

operational state              : Querier

operational version            : 2

tcn query pending count        : 0

Vlan 60:   IGMP switch querier status

--------------------------------------------------------

admin state                    : Enabled (state inherited)

admin version                  : 2

source IP address              : 60.0.0.1      

query-interval (sec)           : 60

max-response-time (sec)        : 10

querier-timeout (sec)          : 120

tcn query count                : 2

tcn query interval (sec)       : 10

operational state              : Disabled

operational version            : 2

tcn query pending count        : 0

L3Streamer#sh ip pim int

Address          Interface           Ver/      Nbr       Query  DR     DR

                                             Mode   Count     Intvl    Prior

192.168.20.1     Vlan1              v2/SD    0          30      1       192.168.20.1

60.0.0.1           Vlan60             v2/SD    0          30      1         60.0.0.1

Cisco Employee

Multicast on Cisco 3560

Hi,

You need to enable pim on all L3 interfaces; make sure have config TTL higher than 1 on VLC; no need for static mroute; do not use 239.0.0.1 group.

HTH,

Lei Tian

New Member

Multicast on Cisco 3560

Thank you that was it, you saved me, now is it working even through other devices

397
Views
0
Helpful
4
Replies