Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Cisco Employee

Multicast packets are always flooded to trunked vlan ports

Hi,

I've some problems with configuring a catalyst 6506.

The setup is as follows:

On two ports from the switch (1/3 and 1/4) the same vlan 12 tagged multicast stream 230.0.0.12 is received; but the source address differs: on trunked port 1/3 the stream has src ip 10.10.10.10 and on trunked port 1/4 the stream has src 10.10.10.11.

On trunked port 1/7 there is a host that sends vlan 12 tagged IGMPv3 source specific reports to receive stream 230.0.0.12 but only from source 10.10.10.10.

The stream is always received 2 times by the host regardless of the host sends out IGMPv3 reports to receive the MC or not.

When an IGMPv3 report is send by the host this is tracked by the igmp snooper as follows:

test#show ip igmp snooping explicit-tracking vlan 12

Source/Group                    Interface       Reporter        Filter_mode

---------------------------------------------------------------------------

10.10.10.10/230.0.0.12          Vl12:Gi1/7      10.10.11.10     INCLUDE

test#

Is it possible to configure the switch in a way that when on trunked port 1/7 a vlan 12 tagged IGMPv3 report is received for mc 230.0.0.12 src 10.10.10.10 only that stream is forwarded?

Now the switch configuration is as follows:

test#show running-config

Building configuration...

Current configuration : 11811 bytes

!

upgrade fpd auto

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

service counters max age 5

!

hostname test

!

enable secret 5 $1$AJVM$k3HazdPdSPiebS/14O7qM.

!

no aaa new-model

ip subnet-zero

!

!

ipv6 mfib hardware-switching replication-mode ingress

mls ip multicast flow-stat-timer 9

no mls flow ip

no mls flow ipv6

no mls acl tcam share-global

mls cef error action freeze

!

!

redundancy

mode sso

main-cpu

  auto-sync running-config

spanning-tree mode pvst

diagnostic cns publish cisco.cns.device.diag_results

diagnostic cns subscribe cisco.cns.device.diag_commands

!

vlan internal allocation policy ascending

vlan access-log ratelimit 2000

!

interface GigabitEthernet1/3

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10-20

switchport mode trunk

no ip address

!

interface GigabitEthernet1/4

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10-20

switchport mode trunk

no ip address

!

interface GigabitEthernet1/7

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10-20

switchport mode trunk

no ip address

!

interface GigabitEthernet1/48

switchport

switchport access vlan 200

switchport mode access

no ip address

!

interface Vlan1

no ip address

shutdown

!

interface Vlan12

ip address 12.12.12.12 255.255.255.0

ip igmp version 3

ip igmp snooping querier

!

interface Vlan200

ip address 10.50.201.185 255.255.252.0

!

ip default-gateway 10.50.200.1

ip classless

ip route 0.0.0.0 0.0.0.0 10.50.200.1

!

no ip http server

!

!

control-plane

!

dial-peer cor custom

!

line con 0

line vty 0 4

password Switch

no login

!

!

monitor session 1 source interface Gi1/15 , Gi1/17 , Gi1/27

monitor session 1 destination interface Gi1/35

no cns aaa enable

end

test#

Thanks

Everyone's tags (2)
2 REPLIES
Hall of Fame Super Silver

Re: Multicast packets are always flooded to trunked vlan ports

Hello Tom,

what IOS image is running on the C6500?

on 12.2SXF  the igmp querier is limited to IGMP version 2

see

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SXF/native/configuration/guide/snooigmp.html#wp1069655

on 12.2SXH and later releases IGMP querier runs in IGMP version 3

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SX/configuration/guide/snooigmp.html#wp1069655

so IOS image counts

Hope to help

Giuseppe

Cisco Employee

Re: Multicast packets are always flooded to trunked vlan ports

Hello Giuseppe,

On the C6500 indeed IOS 12.2SXF was running.

I've upgraded the C6500 to IOS 12.2.SXH but the result is the same as with the 12.2SXF software.

I did a capture on the outgoing port and on that port every querier from a vlan sends out an IGMPv3 general query. When a device receives this query, it reply's with an IGMPv3 report. So I think IGMPv3 is supported.

I don't understand why the igmp snooper doesn't stop the flooding of all the MC packets when an IGMPv3 report is received.

Do you have clue?

Thanks,

Tom

724
Views
0
Helpful
2
Replies
CreatePlease to create content