Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Multicast Problem

I have recently enabled multicast on my access core 6509 rotuer for two subnet, I see multicast routes on my router with 224.0.1.22 or 229.38.76.218 etc but I don't see anything with 230.0.0.1. My application guys are using this address in their java application: My scenario is like

4006--vlan 21----6509-1---4006--vlan22

6509-1

ip multicast routing

interface Vlan21

ip address 10.1.21.254 255.255.255.0

ip pim sparse-dense-mode

interface Vlan22

ip address 10.1.22.254 255.255.255.0

ip pim sparse-dense-mode

On 4006 I have

set cgmp enable

I'm seeing (S,G) entries for other multicast addresses in that subnet but not for 230.0.0.1

Am I missing anything?

4 REPLIES
Cisco Employee

Re: Multicast Problem

Nawaz,

The first thing to check would be the TTL that the application uses by default. The TTL should be greater than 1 for it to work in the current context. This is a very common issue with multicast applications.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: Multicast Problem

HI,

May we know where is your source of this multicast stream? also need to know where are your receiver located?

To do initial investigation we might need the output of the following command:

sh ip pim inter

show ip pim neig

show ip mroute

* are you able to receive multicast stream on same subnet /vlan?

It would be help full if you could post your topology in more detail.

Thanks and Regards

New Member

Re: Multicast Problem

TTL value is set to 10

The application is a pure java app that uses a multicastSocket to send a datagram to the selected IP Address and port.

The other portion of the application subscribes to an IP Address and port and listens for packets. Once a packet is found it terminates and I restart the listener.

Show ip mroute, and show ip pim neighbor shows the correct neighbors and ip

Below is the outoput

(*, 224.0.1.60), 2d19h/00:02:21, RP 0.0.0.0, flags: DC

Incoming interface: Null, RPF nbr 0.0.0.0

Outgoing interface list:

Vlan322, Forward/Sparse-Dense, 2d19h/00:00:00

Vlan321, Forward/Sparse-Dense, 2d19h/00:00:00

(*, 224.0.1.22), 2d19h/stopped, RP 0.0.0.0, flags: DC

Incoming interface: Null, RPF nbr 0.0.0.0

Outgoing interface list:

Vlan322, Forward/Sparse-Dense, 2d19h/00:00:00

Vlan321, Forward/Sparse-Dense, 2d19h/00:00:00

(10.3.22.43, 224.0.1.22), 00:01:57/00:01:49, flags: T

Incoming interface: Vlan322, RPF nbr 0.0.0.0, RPF-MFD

Outgoing interface list:

Vlan321, Forward/Sparse-Dense, 00:01:57/00:00:00, H, A

(10.3.22.145, 224.0.1.22), 00:02:30/00:01:29, flags: T

Incoming interface: Vlan322, RPF nbr 0.0.0.0, RPF-MFD

Outgoing interface list:

Vlan321, Forward/Sparse-Dense, 00:02:31/00:00:00, H, A

sh ip pim interface

Address Interface Ver/ Nbr Query DR DR

Mode Count Intvl Prior

10.3.21.253 Vlan321 v2/SD 1 30 1 10.3.21.253

10.3.22.253 Vlan322 v2/SD 1 30 1 10.3.22.253

#sh ip pim neighbor

PIM Neighbor Table

Neighbor Interface Uptime/Expires Ver DR

Address Prio/Mode

10.3.21.252 Vlan321 1w2d/00:01:20 v2 1 / S

10.3.22.252 Vlan322 1w2d/00:01:30 v2 1 / S

Hall of Fame Super Silver

Re: Multicast Problem

Hello Nawaz,

I see that you have enabled CGMP on the L2 switches catos 4006.

to have CGMP to work the L3 switch needs to sends them CGMP frames

in CGMP the routers speaks and the L2 switches listen to on the CGMP L2 multicast address.

I think you need to enable cgmp on vlan21 and vlan22.

use

int vlan x

ip cgmp proxy

Hope to help

Giuseppe

617
Views
0
Helpful
4
Replies