Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Multicast Routing problem

Hi,

  I have a Cisco 877W which is configured to have two seperate WLANs one in the IP Range 192.168.0.x and the other in IP Range 192.168.1.0.  The issue have is that I have a DLNA server in the 192.168.0.x network and I am trying to get one of the machines on the 192.168.1.x network to be able to see it.

I have been trying various things to make it work but so far no success.  The interface config currently looks like this:

ip multicast routing

interface Dot11Radio0.1
description Main Wireless
encapsulation dot1Q 1 native
ip nat inside
ip virtual-reassembly
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio0.2
description Dan Home
encapsulation dot1Q 2
ip nat inside
ip virtual-reassembly
bridge-group 2
bridge-group 2 subscriber-loop-control
bridge-group 2 spanning-disabled
bridge-group 2 block-unknown-source
no bridge-group 2 source-learning
no bridge-group 2 unicast-flooding
!

interface BVI1
description Bridge for VLAN 1
ip address 192.168.0.1 255.255.255.0
ip pim dense-mode
ip nat inside
ip virtual-reassembly
ip igmp version 3
!
interface BVI2
description Bridge for VLAN 2
ip address 192.168.1.1 255.255.255.0
ip pim dense-mode
ip nat inside
ip virtual-reassembly
ip igmp version 3
!

Before this I also tried using

ip forward-protocol udp 1900

int BVI2

ip helper-address 192.168.0.2 (DLNA Server)

which didn't work either.

I can provide the outputs of any show commands you need but if someone could give me an idea where I am going wrong that would be great.

Thanks

Dan

Everyone's tags (3)
2 REPLIES
Hall of Fame Super Silver

Re: Multicast Routing problem

Hello Dan,

I would suggest to capture traffic on vlan where the server is connected: check if TTL is greater then 1 or the traffic cannot be multicast routed

you can use wireshark on a Pc receiving the stream for this.

Hope to help

Giuseppe

New Member

Re: Multicast Routing problem

Hi Giuseppe,

  Thanks for coming back to me.  This was originally a problem however I have since built my own test application that sends the packets with a TTL of 5 whilst I work out how to make the change on the DLNA server and they still don't seem to get through when I monitor both sides with wireshark.

Dan

1191
Views
0
Helpful
2
Replies
CreatePlease to create content