Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Multicasting between VRF on same switch

Hello Everyone,

I am working on Multicast scenario, There is one 6513E switch one 2960 switch. Two VRF's are configured in core switch (6513) IPTV-SRV and Villa-VRF

IPTV-SRV vrf has IPTV server and Villa-VRF has IPTV i.e. client.

VLAN 30 is mapped to IPTV-SRV vrf with subnet address 192.168.30.0/24

VLAN 12 is mapped to Villa-VRF with subnet address 192.168.12.0/24

I did the following configuration for VRF but its not working . i am not an expert in multicast design but seems i did most of the configs.

Need help in this regards,

ip vrf IPTV-SRV

rd 30:1

mdt default 232.1.1.1

route-target export 30:1

route-target import 10:1

route-target import 11:1

route-target import 40:1

!

ip vrf Villa-VRF

rd 10:1

mdt default 232.1.1.2

route-target export 10:1

route-target import 200:1

route-target import 30:1

route-target import 40:1

route-target import 100:1

route-target import 70:1

ip multicast-routing

ip multicast-routing vrf Villa-VRF

ip multicast-routing vrf IPTV-SRV

interface Vlan12

description Villa-IPTV-VLAN

ip vrf forwarding Villa-VRF

ip address 192.168.12.1 255.255.255.0

ip helper-address 192.168.30.10

ip pim sparse-dense-mode

interface Vlan30

description IPTV-SRV-VLAN

ip vrf forwarding IPTV-SRV

ip address 192.168.30.1 255.255.255.0

ip pim sparse-dense-mode

router bgp 65000

bgp router-id 1.1.1.1

bgp log-neighbor-changes

  !

address-family ipv4 vrf IPTV-SRV

  redistribute connected

exit-address-family

address-family ipv4 vrf Villa-VRF

  redistribute connected

exit-address-family

ip pim snooping

ip pim vrf Villa-VRF rp-address 192.168.30.10

ip pim vrf IPTV-SRV rp-address 192.168.30.10 override

Everyone's tags (2)
3 REPLIES

Multicasting between VRF on same switch

Need some suggestions from multicast experts on the above configuration.

Thanks in Advance.

Hall of Fame Super Gold

Multicasting between VRF on same switch

Duplicate post #2.

VIP Super Bronze

Re: Multicasting between VRF on same switch

Hi,

I am not sure why you have so many import statments in each vrf while you only have 2 vrfs.

Can you try leaking the vrfs together and test:

ip vrf IPTV-SRV

rd 10:1

mdt default 232.1.1.1

route-target export 10:100

route-target import 10:100

route-target import 3:100

!

ip vrf Villa-VRF

rd 30:1

mdt default 232.1.1.2

route-target export 30:100

route-target import 30:100

route-target import 10:100

HTH

361
Views
0
Helpful
3
Replies
CreatePlease login to create content