Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Multilink with load balancing Question

Hello, i have the following configuration to load balance my 2 dsl connections, the first question is, will this load balance the outgoing & incomming traffic?

the second question, each line is 4Mbps, i would like to create a Multilink group so that i can utilize the full bandwidth (total 8Mbps), can someone suggest a configuration that work both with load balancing, redundency & giving you the maximum bandwith ?

thanks for any suggestions.

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname MANS-3660

!

boot-start-marker

boot-end-marker

!

no logging buffered

enable secret xxx

!

no aaa new-model

!

!

ip cef

ip name-server xxx.xx.xx.x

!

username xxx password 0 xxxx

!

!

interface FastEthernet0/0

ip address 10.10.10.3 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 10.10.100.5 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface ATM1/0

no ip address

no ip route-cache cef

no ip route-cache

no atm ilmi-keepalive

dsl operating-mode auto

pvc 0/35

dialer pool-member 1

protocol ppp dialer

!

!

interface ATM1/1

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

pvc 0/35

dialer pool-member 2

protocol ppp dialer

!

!

interface Dialer1

description SPS_DSL_01

mtu 1492

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp chap refuse

ppp pap sent-username xxx password 0 xxx

ppp multilink

!

interface Dialer2

description SPS_DSL_02

mtu 1492

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 2

dialer-group 2

ppp authentication pap callin

ppp chap refuse

ppp pap sent-username xxx password 0 xxx

ppp multilink

!

ip http server

!

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 0.0.0.0 0.0.0.0 Dialer2

!

ip nat inside source route-map SPS_DSL_01 interface Dialer1 overload

ip nat inside source route-map SPS_DSL_02 interface Dialer2 overload

!

access-list 1 permit 10.10.10.0 0.0.0.255

dialer-list 1 protocol ip permit

!

route-map SPS_DSL_02 permit 10

match ip address 1

match interface Dialer2

!

route-map SPS_DSL_01 permit 10

match ip address 1

match interface Dialer1

!

5 REPLIES
New Member

Re: Multilink with load balancing Question

Dear sir

r these DSL connection are from same ISP or different ISP.

Regards

Ajay

New Member

Re: Multilink with load balancing Question

Both DSLs are from the same ISP.

why cant i load balance the incoming with DSL???

Re: Multilink with load balancing Question

How could you possible control routing with dynamically assigned IP's? BGP is the only routing protocol (on the public domain) that can even think about providing that. You can try Round Robin DNS, but that's a crapshoot at best.

Re: Multilink with load balancing Question

This will not load balance in, you will never get that with DSL. You can make it load balance out, but I *think* your route-maps are preventing it. The rest of it looks good.

New Member

Re: Multilink with load balancing Question

will it share the load (load sharing per destination enabled) ?

the question is using NAT, will all packets of a session flow through the same dialer interface?

170
Views
0
Helpful
5
Replies
CreatePlease to create content