Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

multiple VLAN interfaces on an 1801

Hi guys,

Is it possible to have multiple active VLAN interfaces on my 1801? I think I must be missing something here so if someone could point this out that would be great but I have int vlan1, int vlan 10 and in vlan 20 (default, wired and wireless respectively) At the moment everything is on VLAN 1 but I'm looking to move wired clients onto VLAN 10 and wireless onto VLAN 20 but at the moment I cant ping my VLAN interfaces so i dont want to move any clients.

Am I missing something? The integrated switch on this confuses me!

Cheers all

Tom

2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Silver

Re: multiple VLAN interfaces on an 1801

Hello Tom,

it is possible.

Just create the L2 Vlan objects before:

conf t

vlan 10

name wired

vlan 20

name wireless

then you associate switchports to the vlans as needed

int f1/5

switchport

switchport mode access

switchport access vlan 10

ports that you don't configure are in vlan1

Hope to help

Giuseppe

Hall of Fame Super Silver

Re: multiple VLAN interfaces on an 1801

Hello Tom,

you need to explictly unshut the SVI interfaces

int vlan 10

no shut

int vlan 20

no shut

Hope to help

Giuseppe

6 REPLIES
Hall of Fame Super Silver

Re: multiple VLAN interfaces on an 1801

Hello Tom,

it is possible.

Just create the L2 Vlan objects before:

conf t

vlan 10

name wired

vlan 20

name wireless

then you associate switchports to the vlans as needed

int f1/5

switchport

switchport mode access

switchport access vlan 10

ports that you don't configure are in vlan1

Hope to help

Giuseppe

Re: multiple VLAN interfaces on an 1801

Your config would look something like this:

int f0/0

no ip address

int fa0/0.1

encapsulation dot1q 1 native

ip address 192.168.1.1 255.255.255.0

int fa0/0.10

encapsulation dot1q 10

ip address 192.168.10.1 255.255.255.0

int fa0/0.20

encaps dot1q 20

ip address 192.168.20.1 255.255.255.0

If you have a switch, you'll need to add the ports that you want as access ports, and then you'll trunk the port that leads to your router.

For instance, if port 1 connects to the router and port 2 is on vlan 10, and port 3 is on vlan 20:

int fa0/1

switchport mode trunk

switch trunk allowed add vlan 1 , 10 , 20

int fa0/2

switch mode access

switc access vlan 10

int fa0/3

switch mode access

switch access vlan 20

The syntax may not be right, but that should work. :-)

John

HTH, John *** Please rate all useful posts ***
Hall of Fame Super Silver

Re: multiple VLAN interfaces on an 1801

Hello John,

Tom has an etherswitch module he has attached its config in another thread

Hope to help

Giuseppe

Re: multiple VLAN interfaces on an 1801

Ah, thanks Giuseppe

John

HTH, John *** Please rate all useful posts ***
New Member

Re: multiple VLAN interfaces on an 1801

Hi Guys,

Thanks for the advise above. I have put this in and that is all fine. Is it correct that I cannot ping the vlan interface? I created the interface vlan 10 and 20.

At the moment it seems to be acting just like a switch, is that correct?

Thanks,

Tom

Hall of Fame Super Silver

Re: multiple VLAN interfaces on an 1801

Hello Tom,

you need to explictly unshut the SVI interfaces

int vlan 10

no shut

int vlan 20

no shut

Hope to help

Giuseppe

533
Views
0
Helpful
6
Replies
CreatePlease to create content