Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Multiple VLAN's on a single Switchport

We are just in the process of rolling out Nortel IP phones but are a little confused on the VLAN apsect and Nortel aren't helping much.

Basically the IP phone needs to go into vlan 2 but the switchport is already in vlan 10 for data, how do I configure the switchport to allow both VLAN's and I assume that the Nortel phone will automatically put the PC into the non Phone VLAN and not the native VLAN 1?

Any help would be much appreciated.

Thanks

Jon

9 REPLIES

Re: Multiple VLAN's on a single Switchport

configure voice vlan for IP phones

interface

switchport access vlan 10

switchport mode trunk

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport voice vlan 2

http://www.cisco.com/en/US/docs/switches/lan/catalyst3550/software/release/12.1_13_ea1/configuration/guide/swvoip.html

HTH

Narayan

Hall of Fame Super Bronze

Re: Multiple VLAN's on a single Switchport

Narayan,

Your switchport configuration will use a trunk, not an access port nor voice vlan.

You have 2 options:

1) access vlan and auxiliary vlan (voice vlan)

2) trunk switchport and make sure the data vlan is the native vlan.

I believe Nortel supports option 1 (Cisco phones definitely do). If option 1 does not work, option 2 definitely works.

__

Edison.

Re: Multiple VLAN's on a single Switchport

I agree using a trunk but the voice vlan will be used once the phone gets the parameters from the data vlan initially (eg option 176 in avaya)

However i agree that the recent nortel phones need not require trunk configurations and option one would work. I tested it just now but i have some old phone models which do not unless trunk is configured

Narayan

New Member

Re: Multiple VLAN's on a single Switchport

Thanks everyone, our Nortel phones require a trunk as I've tried it with a voice vlan and and configuring the native VLAN for data works great. I was just missing the native VLAN and how to configure it.

New Member

Re: Multiple VLAN's on a single Switchport

Jonhill,

I have a very similar issue in trying to get Nortel IP phones to work correctly with a C3560 switch. Can you send me a quick excerpt of your IOS config for the VLAn section? You mention it works by configuring the native vlan, so i'd be curious to see how configured.

New Member

Re: Multiple VLAN's on a single Switchport

Cluteken

Originally we changed the native VLAN on each switch port but had to look for a different solution as Windows DHCP and XP clients wouldn't work properly with this solution, what we ended up with is below which works great.

interface FastEthernet0/1

switchport mode access vlan 6

switchport voice vlan 2

mls qos trust cos

auto qos voip trust

spanning-tree portfast

spanning-tree bpduguard enable

New Member

Re: Multiple VLAN's on a single Switchport

Narayan

Just an afterthought why do you need to configure access to VLAN 10 if your making it the default native VLAN surely everything that isn't tagged will go to the default VLAN?

Thanks

Jon

Re: Multiple VLAN's on a single Switchport

You do not need that...

I had just pasted a configuration from one of our switches

Narayan

Re: Multiple VLAN's on a single Switchport

hi,

This command is used for a back-up purpose.Note there is no "MODE" keyword here.This command is used when trunking between switches fail.Then you can still access the vlan 10 on this interface.

HTH,

regards,

shri :)

348
Views
19
Helpful
9
Replies
CreatePlease to create content