Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

my first switch conf

Hi All,

I prepare the CCNA and got recently a couple of 2950 and 3550 switches to use as a lab. I have never been in a cisco switch before. I have problems getting a telnet connection working.

Here is what i have done so far:

hostname switch1

line vty 0 15

login authentication default

ip default-gateway 10.2.255.254

interface Vlan1

ip address 10.2.10.200 255.255.0.0

no shut

interface fastEthernet 0/1

switchport mode access

I still cant ping the switch or access it via telnet. I have plugged a crossover cable from fa0/1 to the wall.

show ip interfaces switchport:

Name: Fa0/1

Switchport: Enabled

Administrative Mode: static access

Operational Mode: down

Administrative Trunking Encapsulation: dot1q

Negotiation of Trunking: Off

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

.

...

What am i missing?

16 REPLIES
Hall of Fame Super Silver

Re: my first switch conf

Alan

Right now the biggest issue looks like this line:

Operational Mode: down

If the interface is down then there is no connectivity. My first guess would be a cable issue. Depending on what you are connecting to, I would suggest trying a straight through cable and see if that works better. When you say that you connected to the wall, what does that mean? What is connected to the wall?

There might be some other things that cause this, but lets examine the basic connectivity issues first.

HTH

Rick

New Member

Re: my first switch conf

Also check to see that the device you are using to connect is in the network 10.2.0.0 255.255.0.0

New Member

Re: my first switch conf

I have plugged my switch to the Ethernet outlet in the wall, that outlet is then connected to the server room on another switch (via a panel)to the last router.

I just tried a straight-through cable but the result is the same.

Hall of Fame Super Silver

Re: my first switch conf

Alan

Thanks for trying the other cable. If the connection is going to be switch to switch then crossover is probably the right choice.

At this point I would like to try to narrow down where the problem is happening. If you plug a laptop or PC into the Ethernet outlet in the wall (with a straight cable) do you get link on the PC? This will help tell whether the problem is on our side of the wall outlet or the other side of the wall outlet.

HTH

Rick

New Member

Re: my first switch conf

You should also assign the interface to the vlan you created if it isn't already.

A swith-to-switch link should be a trunk and the cable should a be a cross-over.

int fa0/1

description Trunk to other switch

switcport trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan <>

the other switch should be setup with this config as well.

Cisco Employee

Re: my first switch conf

Bryan,

A little clarification on your point, its really not neccssary to configure the switch ports as trunk ports.The port output shows that it is a static access port on Vlan1 and I think the original poster has to make sure that he uses a cross-over cable and it is connected to vlan1 on the other switch as well.

-amit singh

New Member

Re: my first switch conf

Thanks for the clarification Amit.

New Member

Re: my first switch conf

Well, even if your answers help to clarify, i have to abandon the idea of plugging my switch to the LAN

I will now use my lab as a dedicated test LAN, so my previous question is no longer relevant.

Though i am now trying to connect my switch to a PC via a straight-through cable:

I have setup the ethernet port on the switch in mode access.

The administrator IP (on vlan 1) is 10.2.10.200/16 (no default gateway) and the PC has an IP 10.2.10.199/16

Ping doesnt succeed...The firewall is disabled on the PC and PC and switch are connected with a straight-through cable.

Let me know if you need any other info.

Thanks again

Silver

Re: my first switch conf

Hi ,

Have you configured the default gateway on your pc.

Thanks,

Satish

New Member

Re: my first switch conf

No i havent, which IP should the default-gateway be?

Hall of Fame Super Silver

Re: my first switch conf

Alan

Since your previous post indicates that both the PC and the switch management address are in the same VLAN:

The administrator IP (on vlan 1) is 10.2.10.200/16 (no default gateway) and the PC has an IP 10.2.10.199/16

the default gateway does not matter. When you get a layer 3 device into your test environment (either layer 3 switch or router) you would use the address of that device as the default gateway for the PC. As long as you are connected to a layer 2 switch and there is no layer 3 device, the default gateway is immaterial.

If the PC can not ping the switch there is some issue other than the default gateway. It would be a good start if you would post the output of show interface from the switch. Also is the PC showing link on the Ethernet connection?

HTH

Rick

Cisco Employee

Re: my first switch conf

Is you PC link up ? What does " show interface vlan 1 " tells you. The Vlan interface should be up/up for the same. Have you connected the PC on a port which belongs to Vlan1.

HTH,

-amit singh

New Member

Re: my first switch conf

show interface vlan 1

Vlan1 is up, line protocol is up

Hardware is CPU Interface, address is 000d.659f.7600 (bia 000d.659f.7600)

Internet address is 10.2.10.200/16

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:04, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue :0/40 (size/max)

5 minute input rate 2000 bits/sec, 2 packets/sec

5 minute ouxtput rate 0 bits/sec, 0 packets/sec

3909 packets input, 661395 bytes, 0 no buffer

Received 722 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 8 ignored

2704 packets output, 154908 bytes, 0 underruns

0 output errors, 2 interface resets

0 output buffer failures, 0 output buffers swapped out

The PC link is up and is connected to a port on VLAN 1

New Member

Re: my first switch conf

So here is the config on the first switch

show run

Building configuration...

Current configuration : 1194 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname switch1

!

enable secret xxx

!

username thomas privilege 15 password xxxx

ip subnet-zero

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

interface FastEthernet0/1

no ip address

interface FastEthernet0/2

no ip address

!

interface FastEthernet0/3

no ip address

!

interface FastEthernet0/4

no ip address

!

interface FastEthernet0/5

no ip address

!

interface FastEthernet0/6

no ip address

!

interface FastEthernet0/7

no ip address

!

interface FastEthernet0/8

no ip address

!

interface FastEthernet0/9

!

interface FastEthernet0/10

no ip address

!

interface FastEthernet0/11

no ip address

!

interface FastEthernet0/12

no ip address

!

interface Vlan1

ip address 10.2.10.200 255.255.0.0

no ip route-cache

!

ip http server

ip http authentication local

!

!

line con 0

password xxx

login

line vty 0 4

password xxx

logging synchronous

login

line vty 5 15

password xxx

logging synchronous

login

!

end

Cisco Employee

Re: my first switch conf

What do you mean by " config from the first switch " is it the only switch in question or any other switch is also there in the topology.

Everything seems to OK as far as the config configs. You have you rinterface Vlan1 up/up, all the ports are configured for Vlan1. You should be able to ping the switch interface.

I dont know if its a good idea but try reloading the switch and see what happens.Then try pinging the switch again.

-amit singh

Hall of Fame Super Silver

Re: my first switch conf

Alan

I notice that you refer to this as the config of the first switch. Is there more than one switch involved here? If so could you provide some detail about the topology (what is connected to what on which port)?

I have looked at the config and do not see any obvious issues. There is no other VLAN defined and nothing appears to be shutdown. So if your PC is plugged into one of these interfaces the interface should be up. And if at least one interface is up then the VLAN 1 should be up.

It would be helpful if you post the output of show interface vlan 1 and show interface for the interface into which the PC is connected.

HTH

Rick

175
Views
0
Helpful
16
Replies
CreatePlease to create content