Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

N5k and N7k

Not to familiar with the N5k. So here is my issue, I trying to connect n5k via two 10 gig ports to N7k 10 gig ports on a portchannel with truncking as well.

this is only for traffic to pass thru just a uplink. I have two different port channels on both sides. I do not have any ip's attach to the interfaces since I'm doing any routing thru there. But I cannot bring up any of the portchannels or interfaces to become members of the portchannels. This is only a test enviroment. I have included a text config of how it is setup. If anyone see's something wrong or can correct let me know. Any help would be greatful.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: N5k and N7k

OK - I think 2 things:-

1) I would change the portchannel numbers to be the same on both sides (I saw this issue with a pair of 6500's once) so remove all the config and start again using the same port-channel numbers on both sides.

If that does not work - back to basics.

2) Just have 1 cable between the 7k and 5k and just make that a trunk.  If you get the trunk up - then turn it into a port-channel.

Also - have you enabled the LACP feature????

HTH>

7 REPLIES

N5k and N7k

You have a native vlan mis-match - check your 5k config.

Community Member

N5k and N7k

Thanks for the reply

Sorry I sent the wrong config please disregard the one above. This is the one that is active now.

N7k Configuration:

interface port-channel102

  description Uplink-N5K-TestSwitch

  switchport

  switchport mode trunk

  switchport trunk native vlan 999

  switchport trunk allowed vlan 102

  spanning-tree port type network

interface Ethernet4/15

  description Uplink-N5k-TestSwitch

  switchport

  switchport mode trunk

  switchport trunk native vlan 999

  switchport trunk allowed vlan 102

  channel-group 102 mode active

interface Ethernet4/16

  description Uplink-N5k-TestSwitch

  switchport

  switchport mode trunk

  switchport trunk allowed vlan 999

  channel-group 102 mode active

N5K Configuration:

interface port-channel103

  description Uplink-N7k

  switchport mode trunk

  switchport trunk native vlan 999

  switchport trunk allowed vlan 100

  spanning-tree port type network

interface Ethernet1/3

  description Uplink-N7k

  switchport mode trunk

  switchport trunk native vlan 999

  switchport trunk allowed vlan 100

  spanning-tree port type network

  channel-group 103 mode active  

interface Ethernet1/4

  description Uplink-N7k

  switchport mode trunk

  switchport trunk native vlan 999

  switchport trunk allowed vlan 100

  spanning-tree port type network

  channel-group 103 mode active

N5k and N7k

post the output of "show port-channel sum"

Community Member

N5k and N7k

Here you go sir. And the portchannel are no shutdown on either side or the interfaces as well. Thanks

N7k

102   Po102(SD)   Eth      LACP      Eth4/15(D)   Eth4/16(D)

N5k

103   Po103(SD)   Eth      LACP      Eth1/3(D)    Eth1/4(D)

Re: N5k and N7k

OK - I think 2 things:-

1) I would change the portchannel numbers to be the same on both sides (I saw this issue with a pair of 6500's once) so remove all the config and start again using the same port-channel numbers on both sides.

If that does not work - back to basics.

2) Just have 1 cable between the 7k and 5k and just make that a trunk.  If you get the trunk up - then turn it into a port-channel.

Also - have you enabled the LACP feature????

HTH>

Community Member

Re: N5k and N7k

Yes the LACP feature is on. I will try this out and get back to you. Thanks for the ideas.

Community Member

Re: N5k and N7k

Thanks for you help found the solution. It was a fiber issue. Everything is up and running.

431
Views
0
Helpful
7
Replies
CreatePlease to create content