Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

NAT between 2 local networks slow

Hello all, I have been testing a NAT configuration on an old 2651XM router, and for some reason file transfers wont go higher than "0.0-10.2 sec 32.7 MBytes 27.0 Mbits/sec" while all involved network interfaces are 100Mb/s at least, does anybody know why is this happening and how can I solve it? here is the router configuration:

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname techno-router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

no network-clock-participate slot 1

no network-clock-participate wic 0

ip cef

!

!

ip name-server 192.168.11.1

interface FastEthernet0/0

ip address 192.168.11.201 255.255.255.0 secondary

ip address 192.168.11.202 255.255.255.0 secondary

ip address 192.168.11.203 255.255.255.0 secondary

ip address 192.168.11.200 255.255.255.0

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.57.1 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

no ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 192.168.11.1

!

ip dns server

!

no ip http server

no ip http secure-server

ip nat pool nat-pool 192.168.11.200 192.168.11.200 netmask 255.255.255.0

ip nat inside source list 10 pool nat-pool overload

ip nat inside source static tcp 192.168.57.171 22 192.168.11.200 22 extendable

ip nat inside source static 192.168.57.172 192.168.11.201

ip nat inside source static 192.168.57.173 192.168.11.202

ip nat inside source static 192.168.57.174 192.168.11.203

!

access-list 10 permit 192.168.57.0 0.0.0.255

2 REPLIES

Re: NAT between 2 local networks slow

Please check whether it is for all systems in the subnet 192.168.57.0 or the problem is only with IP's getting NATted with 192.168.11.200.

Also post the output of "show ip nat statistics"

Re: NAT between 2 local networks slow

Remove secondary IPs, they are not needed for NAT.

interface FastEthernet0/0

no ip address 192.168.11.201 255.255.255.0 secondary

no ip address 192.168.11.202 255.255.255.0 secondary

no ip address 192.168.11.203 255.255.255.0 secondary

and disable "ip virtual-reassembly"

no ip virtual-reassembly

334
Views
0
Helpful
2
Replies
CreatePlease to create content