Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

NAT both directions - Duplicate IP detected

Hi there,

I have a customer with a IP PBX which must stay on a specific IP subnet 10.10.30.0 /24 and a specific Default gateway of the the SIP circuit router .252. Unfortunately this is not the address of their LAN and they would like to have their IP phones be able to see the phone system and browse to the systems gui. The PBX also needs to talk to the Mail server to deliver vmail. The telco is difficult to deal with and the customer doesnt want to ask them to put in a static route to the internal lan 192.168.0.0 /16.

I offered to put in a 851 router between the two networks with the idea of nating in both directions so that to the PBX the phones appear to be on the same subnet and vice versa. However when I tried this I kept on getting duplicate IP addresses for the mail server and for the PBX. At the time I had a very short window to try this out and didnt have a lot of prep time to work out the config.

Here's my config that thought would work: 10.10.33.10 is the PBX 192.168.0.183 is the IP Address allocated for the PBX on the Internal LAN, 192.168.0.128 is the mail server and 10.10.33.128 is what it hould appear as on the VOIP LAN.

interface FastEthernet4
description LAN network
ip address 192.168.0.239 255.255.0.0
ip nat outside
!
interface Vlan1
description VOIP network
ip address 10.10.33.1 255.255.255.0
ip nat inside
!
ip route 0.0.0.0 0.0.0.0 192.168.0.254
!
ip nat pool VOIP 10.10.33.100 10.10.33.200 netmask 255.255.255.0
ip nat outside source list 100 pool VOIP
ip nat inside source static 10.10.33.10 192.168.0.183

ip nat outside source static 192.168.0.128 10.10.33.128
!
access-list 100 remark NAT list
access-list 100 permit ip 192.168.0.0 0.0.255.255 any

Does this make sense? Any suggestions gratefully received.

Daniel

Everyone's tags (3)
1 REPLY
Cisco Employee

Re: NAT both directions - Duplicate IP detected

Hello,

From the configuration you have provided, it seems like the mail server IP

is also part of the VoIP pool you have created.

ip nat pool VOIP 10.10.33.100 10.10.33.200 netmask 255.255.255.0

ip nat outside source static 192.168.0.128 10.10.33.128

Can you change your VOIP pool such that .128 address is excluded and see if

that helps?

Regards,

NT

1134
Views
0
Helpful
1
Replies
CreatePlease to create content