Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

NAT configuration help (867 Router)

Im so close to connecting to the internet, the CD light is solid, the data light is flashing and the router has received an ip from the ISP. I believe I havent configured the NAT correctly so any help would be greatly appreciated. Below is the running config, thanks in advance to any kind souls who are willing to help!

Router#show running-config

Building configuration...

Current configuration : 2065 bytes

!

! Last configuration change at 00:15:39 UTC Mon Mar 1 1993 by admin

!

version 15.0

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 10

!

!

ip source-route

!

!

!

ip dhcp pool LANDHCPPool

   network 192.168.0.0 255.255.255.0

   default-router 192.168.0.1

   dns-server 208.67.222.222

!

!

ip cef

!

!

license udi pid CISCO867-K9 sn FGL15042DPJ

!

!

username XXXX privilege 15 password 0 XXXXXXXX

!

!

ip ssh rsa keypair-name sshkeys

ip ssh version 2

!

!

!

!

!

!

!

interface ATM0

no ip address

ip flow ingress

load-interval 60

no atm ilmi-keepalive

!

interface ATM0.1 point-to-point

description adsl point-to-point connection

bandwidth 512

bandwidth receive 6000

ip flow ingress

pvc 0/100

  encapsulation aal5mux ppp dialer

  dialer pool-member 1

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

description lan

ip address 192.168.0.1 255.255.255.0

!

interface Dialer0

bandwidth 6000

bandwidth receive 512

ip address negotiated

ip access-group internetinbound in

no ip proxy-arp

ip nbar protocol-discovery

ip flow ingress

ip nat outside

ip virtual-reassembly

encapsulation ppp

load-interval 60

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp pap sent-username XXXXXXXX password 0 XXXXXXXXX

ppp ipcp dns accept

no cdp enable

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

ip nat inside source list word interface Dialer0 overload

ip route 0.0.0.0 0.0.0.0 Dialer0

!

ip access-list extended LanInbound

permit ip any any

permit icmp any any

!

access-list 1 permit 192.168.0.0 0.0.0.255

dialer-list 1 protocol ip permit

!

control-plane

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

access-class 1 in

exec-timeout 30 0

privilege level 15

login local

transport preferred ssh

transport input ssh

!

scheduler max-task-time 5000

end

Everyone's tags (3)
3 REPLIES
New Member

NAT configuration help (867 Router)

What access list is (ip nat inside source list word interface Dialer0 overload) pointing to?

New Member

NAT configuration help (867 Router)

run show ip nat ? to get a list of commands to verity that nat is working

NAT configuration help (867 Router)

Add "ip nat inside" to Vlan 1 interface. Must be:

interface Vlan1

description lan

ip address 192.168.0.1 255.255.255.0

ip nat inside

As explained from Peterace1 add an access-list "word" like this:

ip access-list extended word

permit ip 192.168.0.0 0.0.0.255 any

Regards.

756
Views
0
Helpful
3
Replies
CreatePlease to create content