Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

NAT configuration issues on 6509

Got kind of a BIG headache on this one. I know it must be simple, but I am just not seeing it.

I have 2 vlans, vlan1 and vlan3. Vlan 1 is a public vlan that connects to the outside world. Vlan3 is non-routable. I configured a PAT. It looked great in the test lab, but is not working in the shop. I can ping the gateway from the switch, but not past the gateway, in the console. Here is a snipet of the config :

interface Vlan1

ip address xxx.xxx.xxx.xxx 255.255.254.0

ip nat outside

no ip route-cache

!

interface Vlan3

ip address 192.168.32.1 255.255.254.0

ip nat inside

no ip route-cache

!

!

ip default-gateway 137.187.44.1

ip nat pool niscpool 137.187.44.105 137.187.44.106 prefix-length 23

ip nat inside source list 1 pool niscpool overload

!

access-list 1 permit 192.168.32.0 0.0.0.255

access-list 1 permit 192.168.33.0 0.0.0.255

!

Here is the route table

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets

C 1.1.1.1 is directly connected, Loopback0

137.187.0.0/23 is subnetted, 1 subnets

C 137.187.44.0 is directly connected, Vlan1

C 192.168.32.0/23 is directly connected, Vlan3

Any info would be appreciated!!

Poirot

1 ACCEPTED SOLUTION

Accepted Solutions

Re: NAT configuration issues on 6509

Hi,

This is simply that you don't have a default route, the ip default-gateway should only be used when ip routing is disabled, please configure a default route using "ip route 0.0.0.0 0.0.0.0 x.x.x.x" and it should work fine.

HTH, please do rate all helpful replies,

Mohammed Mahmoud.

3 REPLIES

Re: NAT configuration issues on 6509

Hi,

This is simply that you don't have a default route, the ip default-gateway should only be used when ip routing is disabled, please configure a default route using "ip route 0.0.0.0 0.0.0.0 x.x.x.x" and it should work fine.

HTH, please do rate all helpful replies,

Mohammed Mahmoud.

New Member

Re: NAT configuration issues on 6509

That was it! I knew it had to be something simple that I was just not seeing.

Thank You Very MUCH!!!

Poirot

Re: NAT configuration issues on 6509

Hi Poirot,

You are very welcomed, i am very glade that we have helped you, and thanks for using the rating system, and please do come back if you have further questions.

BR,

Mohammed Mahmoud.

169
Views
0
Helpful
3
Replies
CreatePlease to create content