Cisco Support Community
Community Member

NAT on 2600?

Folks I am brand new at this.

I have a 2600 (with a T1, 1 Fast ethernet,1 serial interface)connecting to the internet port on my RR modem. First, how do configure NAT and DHCP server on the router. Second, how do I connect 2924 switch on it for my network.


Re: NAT on 2600?

Hi Zek,

find the DHCP & NAT configuration below for ur Cisco 2600 Router.

ip dhcp pool TEST





ip dhcp-server

interface Serial0

description "Connected to Internet"

ip address x.x.x.x

ip nat outside


interface FastEthernet0

description "Connected to LAN"

ip address

ip nat inside


ip nat translation timeout 3600

ip nat pool TEST netmask

ip nat inside source list 1 pool TEST overload

ip classless

ip route Serial0

no ip http server


access-list 1 permit

1.1.1.x is the list of public IP address given by ur ISP.

hope this helps.

rate this post.

Re: NAT on 2600?


From your ISP are u getting any public ip block which you can make use for the NAT pool ?

If not then you need to go on for PAT doing overload onto your serial interface which gets you connected to you SP.


Re: NAT on 2600?

you have to connect switch to fast ethernet interface of router and T1 terminated on serial interface.

I'm assuming that you are having public IP from ISP which will be configured on T1 interface of your router and you have a private subnet which will be used for internal LAN. I'm taking subnet for your LAN.

NAT config on router will look like this:

interface FastEthernet0

description *** Connected to LAN Switch ****

ip address

ip nat inside

interface Serial0

description *** Connected to ISP Router ****

ip address x.x.x.x x.x.x.x

ip nat outside

ip route s0

access-list 7

ip nat inside source list 7 interface serial 0 overload

check this URL to get more information on NAT.

hope to help ... rate if it does ....

Community Member

Re: NAT on 2600?

Thank you all.

The T1 int. connects to another T1 int. on another 2600b in a WAN serial simulation. 2600a has only one fast ethernet int., which is connecting to RR modem. Configuring NAT/DHCP server is my first objective, the other one is connecting a 2924 switch off the router. Possible?

Re: NAT on 2600?

for connecting switch to this router, you should have atleast one free ethernet/ fast ethernet port on this router which I think you don't have, so I don't think it is possible to connect switch to this router.

you can configure NAT/DHCP on this router as mentioned in previous posts, But I'm not sure where you are going to use these services because I guess you will configure NAT/DHCP for the clients which will be connected to your network through switch.

so, your first objective should be to connect a switch to this router and then configure NAT/DHCP on it.

hope to help ... rate if it does ...

CreatePlease to create content