Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

NAT on a Cisco 831

I have a Cisco 831

version 12.4

I setup NAT on my cisco and it is working fine but with one issue.

I can't pull up internal hosted sites by public IP only the Private IP.

Is there a way NAT can be setup so pages can be accessed internal and external on the cisco?

I'm sure it can be done because I don't have that problem on a cheap Linksys router.

Currently NAT Config:

interface Ethernet0

description LAN

ip address 192.168.4.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Ethernet1

description WAN

ip address 74.143.x.x 255.255.255.248 secondary

ip address 74.143.x.x 255.255.255.248 secondary

ip address 74.143.x.x 255.255.255.248 secondary

ip address 74.143.x.x 255.255.255.248 secondary

ip address 74.143.x.x 255.255.255.248

ip nat outside

ip virtual-reassembly

duplex auto

ip nat inside source list 1 interface Ethernet1 overload

ip nat inside source static tcp 192.168.4.100 53 74.143.x.x 53 extendable

ip nat inside source static udp 192.168.4.100 53 74.143.x.x 53 extendable

ip nat inside source static tcp 192.168.4.100 80 74.143.x.x 80 extendable

access-list 1 permit 192.168.4.0 0.0.0.255

5 REPLIES
New Member

Re: NAT on a Cisco 831

Hello ,

the nat is ok :

root@magnum:~# host boydsinternet.com

boydsinternet.com has address 74.143.14.20

boydsinternet.com mail is handled by 0 mail.boydsinternet.com.

root@magnum:~#

root@magnum:~#

root@magnum:~#

root@magnum:~#

root@magnum:~# telnet 74.143.14.20 80

Trying 74.143.14.20...

Connected to 74.143.14.20.

Escape character is '^]'.

GET /

Bad Request (Invalid Hostname)

Connection closed by foreign host.

root@magnum:~#

You got a http daemon problem (probably an IIS ).

New Member

Re: NAT on a Cisco 831

No I am 100% positive it is not the server.

It is running Web/ftp/http/mail/mysql/etc.

Maybe I worded my post wrong

I have no problems at all with someone accessing me from the internet.

Put in boydsinternet.com in your brower it will come right up.

I can get to boydsinternet.com from any network and it will come right up execpt were the server is located

another example

Like if you do the following command "telnet 74.143.14.20 25" (My mailenable server promopt will come right up for anyone but me because I am doing it at the server it'self)

I know it is something with the NAT translations. I think I need 1-1 NAT maybe

New Member

Re: NAT on a Cisco 831

Just saying that the server is ok and is running 'n' services , its not a technical explanation.

I think that the IIS is configured with virtual hosts ( based on domains ) and you have no default site.

You should think, if you are using the domain everything is ok and if you are using the IP you got an error , at least you can check IIS logs and/or search for that error on the internet.

My bottom line is that the NAT is ok. :)

New Member

Re: NAT on a Cisco 831

Thank you

I know NAT is ok and configured correctly

I am mainly looking for another way to setup NAT

I toke off my back-up linux server (74.143.14.21) from the Cisco 831

Put it on a cheap linksys router I had laying around and setup NAT on it.

I can now pull pages by public IP and private IP from the local server.

I put it back on the cisco 831 and now I can only pull the page by private

New Member

Re: NAT on a Cisco 831

Any Idea's

Surely I am not the only one that has seen this issue?

1162
Views
0
Helpful
5
Replies