cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
351
Views
0
Helpful
1
Replies

NAT question

Hi All,

I am having a problem and I'm trying to do a NAT configuration to do a quick-fix (I know this is not the correct solution, but I need it for the moment)....

The problem is the following:

I have an inside computer (192.168.1.80) trying to reach an internal server (192.168.2.175) using the domain name = mycompany.com

The problem is that the computer is using a public DNS server which responds with the publiic IP for the server (201.195.91.50)

So, since the computer is getting that to reach mycompany.com it should use IP 201.195.91.50 (instead than 192.168.2.175 as it should), I'm trying to do the following on my Internet router:

##########################################################################################

interface FastEthernet0/0/0

description ## Inside interface where the computers and servers reside ##
ip address 192.168.1.7 255.255.255.0
ip nat inside
ip policy route-map SERVERS

interface l0
ip add 1.1.1.1 255.255.255.255
ip nat inside

interface l1
ip add 2.2.2.2 255.255.255.255
ip nat outside

access-list 198 permit ip 192.168.1.0 0.0.0.255 host 201.195.91.50

route-map SERVERS permit 10
match ip address 198
set interface l0

route-map Loopback permit 10
set interface l1

ip nat inside source static 201.195.91.50 192.168.2.175 route-map Loopback

##########################################################################################

I'm going to explain what I'm trying to accomplish with the above configuration:

When the inside machine (192.168.1.80) tries to reach the server (201.195.91.50), the traffic will get to the FastEthernet interface, from the Route-Map Servers it will be send to Loopback 0 (where it gets NATed from 201.195.91.50 to 192.168.2.175) and through Loopback1 (so that it get NATed), and then from normal routing it will get out the FastEthernet interface again to the internal server.

Is this going  to work?

Thank you!

Federico.

1 Reply 1

alaiza
Cisco Employee
Cisco Employee
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card