Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

NAT - SIP problem

Hi,

We are facing an issue with SIP calls.We are not able to make calls.

The problem is related to NAT that is setuped on Cisco router 1821.

Below you can see debug output.

Nov 13 11:04:03.027: NAT: SIP: [0] processing INVITE message

*Nov 13 11:04:03.027: NAT: SIP: [0] register:0 door_created:0

*Nov 13 11:04:03.027: NAT: SIP: [0] translated embedded address 192.168.129.147->publicIP

*Nov 13 11:04:03.027: NAT: SIP: [0] No port present. Use new port 5060->1032

*Nov 13 11:04:03.027: NAT: SIP: [0] register:0 door_created:1

*Nov 13 11:04:03.027: NAT: SIP: [0] register:0 door_created:0

*Nov 13 11:04:03.027: NAT: SIP: [0] register:0 door_created:0

*Nov 13 11:04:03.027: NAT: SIP: [0] register:0 door_created:0

*Nov 13 11:04:03.027: NAT: SIP: Contact header found

*Nov 13 11:04:03.027: NAT: SIP: Trying to find expires parameter

*Nov 13 11:04:03.027: NAT: SIP: [0] translated embedded address 192.168.129.147->publicIP

*Nov 13 11:04:03.027: NAT: SIP: [0] translate embedded port 5060->1032

*Nov 13 11:04:03.027: NAT: SIP: [0] register:0 door_created:1

*Nov 13 11:04:03.027: NAT: SIP: [0] message body found

*Nov 13 11:04:03.027: NAT: SIP: Media Lines present:1

*Nov 13 11:04:03.027: NAT: SIP: old_sdp_len:238 new_sdp_len :236

*Nov 13 11:04:03.075: NAT: SIP: [1] processing SIP/2.0 100 Trying message

*Nov 13 11:04:03.075: NAT: SIP: [1] register:0 door_created:0

*Nov 13 11:04:03.075: NAT: SIP: [1] register:0 door_created:0

*Nov 13 11:04:03.075: NAT: SIP: [1] register:0 door_created:0

*Nov 13 11:04:03.879: NAT: SIP: [1] processing SIP/2.0 480 Temporarily not available message

*Nov 13 11:04:03.879: NAT: SIP: [1] register:0 door_created:0

*Nov 13 11:04:03.879: NAT: SIP: [1] register:0 door_created:0

*Nov 13 11:04:03.879: NAT: SIP: [1] register:0 door_created:0

*Nov 13 11:04:03.895: NAT: SIP: [0] processing ACK message

*Nov 13 11:04:03.899: NAT: SIP: [0] register:0 door_created:0

*Nov 13 11:04:03.899: NAT: SIP: [0] translated embedded address 192.168.129.147->publicIP

*Nov 13 11:04:03.899: NAT: SIP: [0] No port present. Use new port 5060->1033

*Nov 13 11:04:03.899: NAT: SIP: [0] register:0 door_created:1

*Nov 13 11:04:03.899: NAT: SIP: [0] register:0 door_created:0

*Nov 13 11:04:03.899: NAT: SIP: [0] register:0 door_created:0

*Nov 13 11:04:03.899: NAT: SIP: [0] register:0 door_created:0

*Nov 13 11:04:09.671: NAT: SIP: [0] processing  message

*Nov 13 11:04:09.743: NAT: SIP: [1] processing ^A^A message

*Nov 13 11:04:09.927: NAT: SIP: [0] processing SUBSCRIBE message

*Nov 13 11:04:09.927: NAT: SIP: [0] register:0 door_created:0

*Nov 13 11:04:09.927: NAT: SIP: [0] register:0 door_created:0

*Nov 13 11:04:09.927: NAT: SIP: [0] register:0 door_created:0

*Nov 13 11:04:09.927: NAT: SIP: [0] register:0 door_created:0

Can someoane help me to understant where can be the problem?

Dima.

  • LAN Switching and Routing
Everyone's tags (3)
6 REPLIES
VIP Super Bronze

NAT - SIP problem

Hi,

Can you post the configs?

Purple

NAT - SIP problem

Hi,

Try this:

no ip nat service sip tcp port 5060

no ip nat service sip udp port 5060

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

NAT - SIP problem

Dear Alain ,

I already tried, unfortunately doesn't help.

Thanks

Silver

NAT - SIP problem

Hi Dima,

We will need more details like

  • from what device (pc, hard phone) are you calling from
  • are you calling from private address to public address or private-private
  • do you use a server (asterisk, freeswitch, kamailio) or do you use call manager or you are calling directly from device to device
  • what NAT traversal solution (if any) do you use

That should be something we can start with. Thanks.

Btw. if you think that everything should work and your Router shoudn't be involved in any SIP processing, try turning off SIP NAT service on the Router:

Router(config)#no ip nat service sip udp port 5060

Router(config)#no ip nat service sip tcp port 5060

Best regards,

Jan

New Member

NAT - SIP problem

Hi Jan,

Thanks for reply.

  • softphone and hardphone
  • private -> public
  • Sonus switch.

I already tried to turn off SIP NAT service and nothing changed.

Btw I collected packet capture behind NAT and I see inside only INVITE send by my phone(no message from softswitch), but in packet capture before router I see also reply (TRYING, 183 messages) from softswitch.

Seems that Cisco router drop these packets.

Silver

NAT - SIP problem

Hi,

Unfortunately I haven't worked with Sonus but I will try to look into it. Can you post the captures in .pcap format making a call from some pc (softphone) to the public ip? Maybe we will find something helpful in them. Can you also post some diagram of your topology, maybe even some logs from Sonus? We need to know details, like if the Sonus is on the same subnet like the phone or if it's in another private or public subnet. May I ask if you use any special NAT traversal solutions, like STUN/TURN/ICE or RTP Proxy? Maybe the SIP signalling will go through and the problem is in RTP media stream. It is crucial that we have as many information as we can - SIP troubleshooting can be quite tricky and painful. Especially with NAT as there are many possible scenarios.

Best regards,

Jan

430
Views
0
Helpful
6
Replies
This widget could not be displayed.