Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

NAT Traslation in vlan interface

Hello,

I have a cisco router 3845 with Etherswitch modules and one Vlan configured "172.16.6/24", many switch ports are assigned to this vlan. i would like to translate one IP address 172.16.6.200 to a new one "172.25.42.10" but need to keep the other IPs from "172.16.6/24" without changes. below is the configuration of vlan interface and switch port, could someone help.

Best Regards,

Mustapha Bensalah.

interface Vlan100
description L3 Vlan interface for core_vlan
ip address 172.16.6.2 255.255.255.0
no ip redirects
no ip route-cache cef
no ip route-cache
standby 1 ip 172.16.6.1
standby 1 priority 250
standby 1 preempt
standby 1 authentication md5 key-string 7 052A32226E03012D3A2B1F01191C
end

interface FastEthernet4/35
description to RSG
switchport access vlan 100
no cdp enable
spanning-tree portfast
end

8 REPLIES

NAT Traslation in vlan interface

Hello,

    Where is 172.25.42.10?  Please give us a bit more about your question.

Toshi

NAT Traslation in vlan interface

Hi Mustapha,

If you are sure that the network "172.25.42.10" (172.25.42.0/24) is reachable and have a route then you can do a NAT like below.

ip nat inside source static 172.16.6.200 172.25.42.10 extendable


As said above make sure that the network 172.25.42.0/24 is reachable.


Please rate the helpfull posts.
Regards,
Naidu.

New Member

NAT Traslation in vlan interface

Hi,

i would like to translate the source IP 172.16.6.200 to 172.25.42.10 only when i have to reach some specific IPs otherwise i don't want to translate the source IP, i want to keep it as it is. something like :

if destination IP is X.X.X.X then translate 172.16.6.200 to 172.25.42.10

else "do not make translation"

Best Regards,

Mustapha.

NAT Traslation in vlan interface

Hi Hi Mustapha,

Try like below and see...

ip nat inside source static 172.16.6.200 172.25.42.10 extendable

Please rate the helpfull posts.
Regards,
Naidu.

NAT Traslation in vlan interface

Hello,

       You can try this for testing.

!

access-list 101 permit ip host 172.16.6.200 host x.x.x.x

!

ip nat pool MYPOOL 172.25.42.10 172.25.42.10 mask 255.255.255.0

!

ip nat inside source list 101 pool MYPOOL

!

HTH,

Toshi

New Member

Re: NAT Traslation in vlan interface

Hello,

 

and what should be configured on ingoing and outgoing interfaces ?

 

BR,

mustapha.

De : thotsaphon

À : tdanetsco

Envoyé le : Mardi 22 Novembre 2011 9h27

Objet : - Re: NAT Traslation in vlan interface

Home

Re: NAT Traslation in vlan interface created by thotsaphon in LAN, Switching and Routing - View the full discussion

Hello,

       You can try this for testing.

 

!

access-list 101 permit ip host 172.16.6.200 host x.x.x.x

!

ip nat pool MYPOOL 172.25.42.10 172.25.42.10 mask 255.255.255.0

!

ip nat inside source list 101 pool MYPOOL

!

 

 

 

HTH,

Toshi

Reply to this message by going to Home

Start a new discussion in LAN, Switching and Routing at Home

NAT Traslation in vlan interface

Hi,

and what should be configured on ingoing and outgoing interfaces ?


On the incoming interface configure like below.
interface inside (fa0/1)
ip nat inside


On the outgoing interface configure like below.
interface outside (fa0/0)
ip nat outside

Please rate the helpfull posts.
Regards,
Naidu.

NAT Traslation in vlan interface

Hi,

   Please provide a brief diagram. You need to route 172.25.42.10 back to that router.

Toshi

689
Views
0
Helpful
8
Replies