Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

NAT U-Turn does not work on 2911 router

NAT U-Turn does not work on 2911 router

Hello,

Consider this scenario:

  • 1. Both Host A 192.168.1.70 and Host B 192.168.1.70 have Router A 192.168.1.1 as the default gateway
  • 2. The network 192.168.1.0 /24 is NAT ‘d to the address 10.10.10.10
  • 3. There is a static NAT (port forwarding) for port 80 on IP 10.10.10.10 to 192.168.1.30

  • 4. Host A 192.168.1.70 ties to access web-server Host B by going to port 80 on 10.10.10.10

The connection fails. Is there any method to make this work?

Regards,

AA

==============

The config on the router is:

!

interface GigabitEthernet0/0

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

no ip route-cache cef

no ip route-cache

!

!

interface GigabitEthernet0/1

ip address 10.10.10.10 255.255.255.0

ip nat outside

ip virtual-reassembly

!

ip nat inside source route-map nonat interface GigabitEthernet0/1 overload

route-map nonat permit 10

match ip address 110

!

!

access-list 10 permit 0.0.0.0 255.255.255.0

access-list 110 permit ip 192.168.1.0 0.0.0.255 any

!

!

ip nat inside source static tcp 192.168.1.30 80 10.10.10.10 80 extendable

Everyone's tags (1)
588
Views
0
Helpful
0
Replies
CreatePlease to create content