Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

NAT with HSRP Enabled

Hi all,

I am trying to configure few static NATs which HSRP enabled between two 7600's. However, when I do this, I start seeing the following messages on the console:

1d19h: %IP-4-DUPADDR: Duplicate address 129.192.160.167 on Vlan392, sourced by 000a.f331.9fc0wr me

This message appears for every NATTed address.

My NAT config is:

ip nat inside source static 192.168.4.253 129.192.160.167

ip nat inside source static 192.168.4.71 129.192.160.183

ip nat inside source static 192.168.4.73 129.192.160.184

ip nat inside source static 192.168.4.75 129.192.160.185

ip nat inside source static 192.168.4.101 129.192.160.168

ip nat inside source static 192.168.4.150 129.192.160.170

ip nat inside source static 192.168.4.151 129.192.160.171

ip nat inside source static 192.168.4.10 129.192.160.172

ip nat inside source static 192.168.4.56 129.192.160.173

ip nat inside source static 192.168.4.57 129.192.160.174

ip nat inside source static 192.168.4.58 129.192.160.175

ip nat inside source static 192.168.4.81 129.192.160.186

ip nat inside source static 192.168.4.82 129.192.160.187

ip nat inside source static 192.168.4.60 129.192.160.180

ip nat inside source static 192.168.4.62 129.192.160.181

ip nat inside source static 192.168.4.66 129.192.160.182

ip nat inside source static 192.168.4.102 129.192.160.169

ip nat inside source static 192.168.4.91 129.192.160.176

ip nat inside source static 192.168.4.92 129.192.160.177

ip nat inside source static 192.168.4.95 129.192.160.178

ip nat inside source static 192.168.4.96 129.192.160.179

On looking up the CCO, I found out that that this can be done, by using the following command:

ip nat inside source static <local_inside> <global> redundancy HSRP1

But I don't see option available to me. My image is the following:

C7606-2#sh ver | inc image

System image file is "bootdisk:s72033-advipservicesk9_wan-mz.122-18.SXE6b.bin"

C7606-2#

Any help would be really appreciated.

2 REPLIES
Blue

Re: NAT with HSRP Enabled

Why dont you post the entire router configs?

New Member

Re: NAT with HSRP Enabled

The whole MSFC config is too big due to 4 ethernet linecards. Mostly it is the assignment of the following VLANs.

Following config would give you the idea what I'm doing.

I read that SNAT is the option, but I don't see the option in the current image.

=================================

interface Vlan391

description ----O&M----

ip address 192.168.4.2 255.255.254.0

no ip redirects

no ip proxy-arp

ip nat inside

arp timeout 200

standby 1 ip 192.168.4.1

standby 1 timers 1 3

standby 1 priority 110

standby 1 preempt delay minimum 60

!

interface Vlan392

description ----O&M Traffic for Servers in BETE Network----

ip address 129.192.160.163 255.255.255.224

ip nat outside

standby 1 ip 129.192.160.162

standby 1 timers 1 3

standby 1 priority 110

standby 1 preempt delay minimum 60

!

interface Vlan491

description ----www_external----

ip address 10.10.0.2 255.255.0.0

no ip redirects

no ip proxy-arp

arp timeout 200

standby 1 ip 10.10.0.1

standby 1 timers 1 3

standby 1 priority 110

standby 1 preempt delay minimum 60

!

interface Vlan492

description ----www_internal----

ip address 192.168.124.2 255.255.254.0

no ip redirects

no ip proxy-arp

arp timeout 200

standby 92 ip 192.168.124.1

standby 92 timers 1 3

standby 92 priority 110

standby 92 preempt delay minimum 60

!

interface Vlan493

description ----radio_external----

ip address 172.0.0.2 255.0.0.0

no ip redirects

no ip proxy-arp

arp timeout 200

standby 1 ip 172.0.0.1

standby 1 timers 1 3

standby 1 priority 110

standby 1 preempt delay minimum 60

!

interface Vlan495

description ----radius_external----

ip address 10.20.0.2 255.255.0.0

no ip redirects

no ip proxy-arp

arp timeout 200

standby 1 ip 10.20.0.1

standby 1 timers 1 3

standby 1 priority 110

standby 1 preempt delay minimum 60

!

interface Vlan496

description ----radius_internal----

ip address 192.168.128.2 255.255.254.0

no ip redirects

no ip proxy-arp

arp timeout 200

standby 1 ip 192.168.128.1

standby 1 timers 1 3

standby 1 priority 110

standby 1 preempt delay minimum 60

!

interface Vlan497

description ----Traffic from GGSN in via BETE Network----

ip address 129.192.160.131 255.255.255.240

!

interface Vlan499

description ----Traffic to WWW via BETE Network----

ip address 129.192.160.147 255.255.255.240

!

ip nat inside source static 192.168.4.253 129.192.160.167

ip nat inside source static 192.168.4.71 129.192.160.183

ip nat inside source static 192.168.4.73 129.192.160.184

ip nat inside source static 192.168.4.75 129.192.160.185

ip nat inside source static 192.168.4.101 129.192.160.168

ip nat inside source static 192.168.4.150 129.192.160.170

ip nat inside source static 192.168.4.151 129.192.160.171

ip nat inside source static 192.168.4.10 129.192.160.172

ip nat inside source static 192.168.4.56 129.192.160.173

ip nat inside source static 192.168.4.57 129.192.160.174

ip nat inside source static 192.168.4.58 129.192.160.175

ip nat inside source static 192.168.4.60 129.192.160.180

ip nat inside source static 192.168.4.62 129.192.160.181

ip nat inside source static 192.168.4.66 129.192.160.182

ip nat inside source static 192.168.4.81 129.192.160.186

ip nat inside source static 192.168.4.82 129.192.160.187

ip nat inside source static 192.168.4.102 129.192.160.169

ip nat inside source static 192.168.4.91 129.192.160.176

ip nat inside source static 192.168.4.92 129.192.160.177

ip nat inside source static 192.168.4.95 129.192.160.178

ip nat inside source static 192.168.4.96 129.192.160.179

622
Views
0
Helpful
2
Replies
CreatePlease to create content