Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Native Vlan and DHCP Server

Hi,

I’ve got a couple 2060 and a 3750 to L3. Unfortunately I had to take with a wireless solution from HP.

Hi have two Vlans for the wireless solution, and I configured my switch port like this:

interface fa0/20
description Connect to HP AP
switchport trunk native vlan 20
switchport trunk allowed vlan 20,30
switchport mode trunk

I want to make the 3750 the DHCP server for both VLANs. In vlan 30, the tag vlan I don’t have any problem, but with vlan 20, the requests to the dhcp server arrive to the 3750 but the response don’t arrive to the clients. I know that the problem is because the vlan 20 is a untagged vlan.

Is there a workaround to this problem, can anyone help me.

thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Native Vlan and DHCP Server

May I ask why do you have clients on native vlan 20? Usualy native vlan is the management vlan for the switches and no clients should be part of this vlan. Since you have HP in the mix I will leave vlan 1 as native vlan for the network. How many vlans does your HP supports?

13 REPLIES
New Member

Re: Native Vlan and DHCP Server

Does a " sh int trunk" on the 3750 reveal that you have a properly configured inter switch trunk and that it is a passing vlan 20?

Can you post the vlan 20 dhcp scope?

New Member

Re: Native Vlan and DHCP Server

The dhcp pool is configured like this:


ip dhcp pool Vlan20
network 192.168.20.0 255.255.255.0
default-router 192.168.20.1
dns-server 192.168.1.1

I only have vlan 20 as native in the trunks that connects to the hp AP’s. Is the problem in the trunks that connects the 2960’s to the 3750? If I put in this trunks the native vlan 20, I resolve my problem?

Thanks

Purple

Re: Native Vlan and DHCP Server

  Maybe you can explain your setup a little more , is the ap trunked to a 2960 which in turn is trunked to a 3750 which is doing  the dhcp function ?    If so make sure   L2 vlans are created on the 2960 , the vlans are allowed in the trunk between the 2960 and the 3750 .your trunk setup should be exactly the same between switches.   Make sure your native vlans match on the trunk between the switches and the setup between the ap and the switch .  Check the hp ap trunk setup.    Native vlans only have to match on each side of a given trunk link.  If the native vlan is vlan 20 on the switch then it has to be native vlan 20 on the ap . Or make the native a unused matching vlan on  each side and just make vlan 20 part of the tagged vlans . 

New Member

Re: Native Vlan and DHCP Server

Hi Glen

The scenario is like this:

The trunk between the 2960 and the 3750 is the same:

2960:

interface Gi0/1
description Connect to 3750
switchport trunk allowed vlan 10,20,30
switchport mode trunk

switchport nonegotiate

3750:

Interface Gi1/25

Description Connect to 2960

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,20,30

switchport mode trunk

switchport nonegotiate

I know that the request arrive at the 3750 with the vlan id=0, because I configured the debug of the DHCP events, and when I do the sh ip dhcp binding, I see the mac address of the client, and the IP given by the server, but the client don’t receive the IP.

Thanks

New Member

Re: Native Vlan and DHCP Server

What's the output of "sh int trunk" and "sh vlan" on both switches?

Are both switches learning the Mac address of the vlan 20 clients on the correct interfaces?

New Member

Re: Native Vlan and DHCP Server

Hi Tod,

Everything is fine with vlans and in the trunks, and the mac appears in the correct interface. For example if I put in the same 2960, a interface in the access mode with vlan 20, the pc receive a IP with no problem.

The problem is the fact of the vlan 20, in the trunk to the hp AP need to be native, for the communication of the ap with the controller.

This problem is not from the DHCP server?

Thanks

Cisco Employee

Re: Native Vlan and DHCP Server

Hi ,

looking at the interface configuration connecting these two switches, I dont see the native vlan specified on that trunk link? do you have them configured globally. if not by default cisco switches have native vlan as 1. so i guess if you have clients in VLan 20, then they should be tagged across the trunk link

-Vijay

New Member

Re: Native Vlan and DHCP Server

Hi Vijay

No, I dont have the vlan 20 configured as native in the trunk between the 2960 and the 3750. I already question myself and in a previous post if this was not the problem.

Tomorrow I'm going to test it, and I will post here the feedback.

Thanks for the help

New Member

Re: Native Vlan and DHCP Server

Vijay,

I'm going with a new approach, and I create a new managemt vlan that is the native in all trunk links.

Regards

Bronze

Native Vlan and DHCP Server

May I ask why do you have clients on native vlan 20? Usualy native vlan is the management vlan for the switches and no clients should be part of this vlan. Since you have HP in the mix I will leave vlan 1 as native vlan for the network. How many vlans does your HP supports?

New Member

Re: Native Vlan and DHCP Server

Hi Eugen,

You're right, I could create another vlan and everything would be solved, but I didn´t want to create it for only half a dozen access points. The switch's management VLAN is already full because it is shared by other buildings

Thanks

Bronze

Re: Native Vlan and DHCP Server

Thats ok. You may have to log in to AP and tagg vlans on the port that connects AP to switch

Example:

with port 2 on AP connecting to switch

int vlan 20

tagged 2

int vlan 10

tagged 2

int vlan 30

tagged 2

Hope this helps

Eugen

New Member

Re: Native Vlan and DHCP Server

Hi Eugen,

The HP support guy told to me that my only option is not to tag the management Vlan. I’m going to your first post, I create a new management Vlan, that is not tagged.

Regards and thanks for the help

4455
Views
0
Helpful
13
Replies