Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Native VLAN Mismatch

Hi,

I have configured the port channel for two ports in Cisco 3750 switch. While connecting the cable in that port i am getting the native VLAN mismatching error. Below i have attached the configuration and error details. Please help me on this.

Error:

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet1/0/33 (5), with Core1 GigabitEthernet1/0/17 (1).

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet1/0/33 (5), with Core1 GigabitEthernet1/0/17 (1).

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet1/0/33 (5), with Core1 GigabitEthernet1/0/17 (1).

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/34, changed state to up

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet1/0/33 (5), with Core1 GigabitEthernet1/0/34 (1).

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet1/0/33 (5), with Core1 GigabitEthernet1/0/34 (1).

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet1/0/33 (5), with Core1 GigabitEthernet1/0/34 (1).

Configuration:

interface Port-channel3

description *****Connected to Dell Blade Server Switch****

switchport trunk encapsulation dot1q

switchport mode trunk

interface GigabitEthernet1/0/17

description *****Connected to Blade*****

switchport trunk encapsulation dot1q

switchport mode trunk

speed 1000

duplex full

channel-protocol lacp

channel-group 3 mode active

!

interface GigabitEthernet1/0/33

description *****Spare*****

switchport access vlan 5

!

interface GigabitEthernet1/0/34

description *****Connected to Blade*****

switchport trunk encapsulation dot1q

switchport mode trunk

speed 1000

duplex full

channel-protocol lacp

channel-group 3 mode active

!

Thanks,

Karthik

Everyone's tags (4)
2 REPLIES

Re: Native VLAN Mismatch

en

conf t

int g1/0/33

sw mo acc

sw acc vlan 1

end

wr

!

Alessio

      

PS: eagle eye !! thanks Peter

Cisco Employee

Native VLAN Mismatch

Hi Alessio,

sw acc nat vlan 1

You probably meant switchport access vlan 1 (i.e. remove the "nat" shorthand).

Your suggestion would surely remove the native VLAN mismatch issue. However, I also suggest verifying whether the Gi1/0/17 on Core1 is configured as an access port or if it is a trunk. If it is a trunk then clearly, the 3750 should also be configured as a trunk.

Best regards,

Peter

2885
Views
0
Helpful
2
Replies
CreatePlease login to create content