Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Native Vlan Mismatch

hi NetPro,

i am doing cascade from Access switch, one of the port which vlan 288 connect to another cisco switch (act like hub), i got the error from the both switch . Native Vlan mismatch.

Switch A (Access Switch).

interface FastEthernet4/38

switchport access vlan 288

switchport mode access

switchport voice vlan 274

end

Switch B (cascade)

interface FastEthernet0/47

switchport trunk encapsulation dot1q

switchport trunk native vlan 288

so, if i put both site encapsulation dot1q and native vlan .. i wont get the native vlan mismatch. but, i am unable to get the ip address.

regards,

Jackal

17 REPLIES

Re: Native Vlan Mismatch

Hi,

Both switches must have dot1Q on the trunk interface between them with the same Native VLAN on both sides, you have to configure both switches this way.

HTH, please rate all helpful posts,

Mohammed Mahmoud.

New Member

Re: Native Vlan Mismatch

Hi Bro,

yes, i have tried both site put dot1q and trunk. but after that i am unable to get ip address.

Re: Native Vlan Mismatch

Hi,

Have you configured both trunks with the same Native VLAN on both sides, what does the show cdp says.

HTH, please rate all helpful posts,

Mohammed Mahmoud.

New Member

Re: Native Vlan Mismatch

Hi,

"switch trunk mode" is missing on Switch b @ fa0/47.

Check if vlan 288 is also allowed to pass

New Member

Re: Native Vlan Mismatch

Hi,

at first, i configured both switch like this.

switch A:

int fa 4/38

switchport mode trunk

switchport trunk encapsulation dot1q

switchport trunk native vlan 288

Switch B:

int fa 0/47

switchport mode trunk

switchport trunk encapsulation dot1q

switchport trunk native vlan 288

when i used this config i am totally unable to get any ip address.

Cisco Employee

Re: Native Vlan Mismatch

Hi Ney,

Are you connecting Switch A fa4/38 to switch B fa0/47? If yes WHY have you configured voice vlan on switch A interface 4/38?

With this configuration you will get native Vlan mismatch but it will not hamper your data traffic so you can get let the config like this and to get rid of Native vlan mismatch message you can disable cdp on these interfaces.

Regards,

Ankur

New Member

Re: Native Vlan Mismatch

hi Ankur,

because, my LAN connection was from ip phone.

Cisco Employee

Re: Native Vlan Mismatch

Hi Ney,

Switch A int fa0/48 is connected to IP Phone or switch B int fa0/47? If it is connected to other switch B on fa0/47 there is no need to have voice vlan config.

Voice vlan config should be done only on interfaces which are connected to IP Phone.

So fa0/48 on switch A and fa0/47 on switch B should work as normal trunk ports with same native vlan. As you mentioned you are not able to get an ip address we need to troubleshoot different areas like which vlan is not able to get an ip address, is it only one machine or all machines in that vlan, where is your dhcp server, who is doing routing between vlan and other stuff.

Regards,

Ankur

New Member

Re: Native Vlan Mismatch

Hi Ankur,

basically my Edge switch is fa4/38 (so called switch A) whereby the voice vlan also within this port.

so, now i cascade the additional switch act as hub (unmanaged / no ip address --> so called switch B )

so, switch A

------------

int fa 4/38

switchport mode trunk

switchport trunk encapsulation dot1q

switchport trunk native vlan 288

switchport voice vlan 292

switch B

--------

int fa 0/47

switchport mode trunk

switchport trunk encapsulation dot1q

switchport trunk native vlan 288

this is my initially configuration .

but, with this i cant get ip address ...

Re: Native Vlan Mismatch

Hi,

I agree with Ankur, the "switchport voice vlan 292" is for an access port connected to an IP phone not for a trunk port connected to another switch, please do remove it.

HTH, please rate all helpful replies,

Mohammed Mahmoud.

New Member

Re: Native Vlan Mismatch

Hi bro,

yes, i do agree with you but this case slightly different because, this is use in the meeting room whereby that's limited LAN port over there. there's why my Lan connection was from ip phone. (Lan port connect to IP phone connect to Laptop ). so, now multiple users wanna use internet so i have to cascade a switch / hub connect from the ip phone to my switch / hub.

Cisco Employee

Re: Native Vlan Mismatch

Hi Ney,

I understood your setup and requirement now. So your setup is something like this switch A interface fa0/48 connected to IP Phone and IP Phone computer interface is connected to your switch B int fa0/47 and on that switch users are connected for vlan 288? Correct me if I am wrong?

If this is the scenario you can configure on switch B fa0/47 interface without a trunk port and just a normal access port with vlan 288 so it will be considered like an end station connected like a computer to an ip phone.

Switch A

int fa0/48

switchport access vlan 288

switchport voice vlan 292

switch B

int fa0/47

switchport mode access

switchport access vlan 288

and confirm if this works for you. This should work if you have only one vlan users which is vlan 288 on your hub switch connected to ip phone.

Regards,

Ankur

Cisco Employee

Re: Native Vlan Mismatch

Hi Ney,

Again if fa0/48 so called switch A is connected to switch B then on fa0/48 remove voice vlan configuration line and leave rest of the lines as it is and then see if your clients get an ip address or not? Also as you mentioned switch B is a unmanaged switch but you can configured its interface as trunk port? Can you confirm looking at "sh vlan" if vlan 288 and vlan 292 is present in vlan database?

Regards,

Ankur

New Member

Re: Native Vlan Mismatch

Hi Ankur,

yes, i agree with you.

i will remove the voice vlan and get back to you.

thanks All.

Regards,

Jackal

Cisco Employee

Re: Native Vlan Mismatch

Hi Ney,

I understood your setup and requirement now. So your setup is something like this switch A interface fa0/48 connected to IP Phone and IP Phone computer interface is connected to your switch B int fa0/47 and on that switch users are connected for vlan 288? Correct me if I am wrong?

If this is the scenario you can configure on switch B fa0/47 interface without a trunk port and just a normal access port with vlan 288 so it will be considered like an end station connected like a computer to an ip phone.

Switch A

int fa0/48

switchport access vlan 288

switchport voice vlan 292

switch B

int fa0/47

switchport mode access

switchport access vlan 288

and confirm if this works for you. This should work if you have only one vlan users which is vlan 288 on your hub switch connected to ip phone.

Regards,

Ankur

New Member

Re: Native Vlan Mismatch

Hi Ankur,

initially, i configured

Switch A

inf fa 4/38

switchport access vlan 288

switchport voice 292

switch B

switchport access vlan 288

switchport mode access

but, but it prompted " please use native vlan " msg in the log file.

so, i configured native vlan to switch A and B

after configured both switches i am unable to get ip address.

p/s : actually i got the feeling is due to voice vlan.

Cisco Employee

Re: Native Vlan Mismatch

Hi Ney,

With your initial configuration if you configure "switchport mode access" on fa4/38 I believe you will not get "please use native vlan" message.

Yes when you configure voice vlan it internally forms a trunk.

Regards,

Ankur

*Pls rate all helpfull post

226
Views
0
Helpful
17
Replies
CreatePlease to create content