Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Native VLAN ????

Hello,

I am desperately looking for Information on Native VLAN. But what i have read on net i am not clear.

So far what i understood, is Native VLAN packets are not tagged. For Eg, if you have VoIP, then IP-Phone and switch port will have Voice packets tagged as Voice VLAN, but the data from your PC will not get tagged due to Native vlan BECAUSE IP PHONE CANNOT HANDLE TAGGING FOR DATA...Am i Correct ???..

Also why would you need Management VLAN as Native in Layer-2 switch or Layer-3 switch...Any information will be very much appreciated. I am so confuse.

Best Regards,

Hassan..

2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Bronze

Re: Native VLAN ????

When a VoIP phone boots up, it actually comes up in the native Vlan, once it gets its information from DHCP, it switches to the designated voice vlan.

Standard NICs for PCs do not have this intelligent built into the hardware so that's the reason you use 'native' Vlans for PCs. However, there are NICs that support trunking so you can actually configure trunking between a switch and an end station.

As for using the 'Management' Vlan as 'native, that's just Best Practice in case the switch loses its trunk status and you still are able to connect by using its 'native' Vlan and manage it.

HTH,

__

Edison.

Re: Native VLAN ????

Hi Hassan,

As an addition to Edison's post.

It seems to me that you are confused on the "native vlan" term.

It has 2 meanings:

1. On traditional 802.1q trunks it is the vlan that is untagged.

Example:

interface fastethernet 1/0

switchport

switchport trunk native vlan 2

switchport mode trunk

In this case vlan 2 is the native vlan of the 802.1q trunk, and it is untagged.

2. On access ports with voice vlans: the native vlan is the vlan where the port is configured with the "switchport access vlan x" command.

Example:

interface fastethernet 1/0

switchport

switchport mode access

switchport voice vlan 5

switchport access vlan 3

In this case the voice vlan is vlan 5 (tagged).

The native vlan is vlan 3 (this is also untagged).

Cheers:

Istvan

3 REPLIES
Hall of Fame Super Bronze

Re: Native VLAN ????

When a VoIP phone boots up, it actually comes up in the native Vlan, once it gets its information from DHCP, it switches to the designated voice vlan.

Standard NICs for PCs do not have this intelligent built into the hardware so that's the reason you use 'native' Vlans for PCs. However, there are NICs that support trunking so you can actually configure trunking between a switch and an end station.

As for using the 'Management' Vlan as 'native, that's just Best Practice in case the switch loses its trunk status and you still are able to connect by using its 'native' Vlan and manage it.

HTH,

__

Edison.

New Member

Re: Native VLAN ????

Thanks to both of you...appreciate it...got it clear now..

Re: Native VLAN ????

Hi Hassan,

As an addition to Edison's post.

It seems to me that you are confused on the "native vlan" term.

It has 2 meanings:

1. On traditional 802.1q trunks it is the vlan that is untagged.

Example:

interface fastethernet 1/0

switchport

switchport trunk native vlan 2

switchport mode trunk

In this case vlan 2 is the native vlan of the 802.1q trunk, and it is untagged.

2. On access ports with voice vlans: the native vlan is the vlan where the port is configured with the "switchport access vlan x" command.

Example:

interface fastethernet 1/0

switchport

switchport mode access

switchport voice vlan 5

switchport access vlan 3

In this case the voice vlan is vlan 5 (tagged).

The native vlan is vlan 3 (this is also untagged).

Cheers:

Istvan

118
Views
0
Helpful
3
Replies