Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Native vlan

Hi,

I require the information about Native Vlan for trunk port, What is the native Vlan how can we change that.

Thanks in advance

JD

3 REPLIES
Hall of Fame Super Blue

Re: Native vlan

JD

The native vlan on a trunk port is the vlan that does not have an 802.1q tag. So multiple vlans can go across an 802.1q trunk port and the switch distinguishes between the vlans by the 802.1q vlan tag attached to the frames. The native vlan, vlan 1 by default, does not have an 802.1q tag.

The native vlan is there for backward compatability with switches that do not understand 802.1q tags. Cisco recommend either

1) tag all vlans including the native vlan

OR

2) change the native vlan to something other than vlan 1. The vlan you choose does not have to any ports allocated to it and does not need to have a L3 SVI. The command to change the native vlan on a trunk port is

switchport trunk native vlan

Jon

New Member

Re: Native vlan

Hi Jon,

Thanks for your help, if i have 2 vlans vlan 10 and 20 and one of them is using for IP Phone (vlan 10) and other is for PCs (vlan 20),

1) I want to connect a IP phone on a switch which i have configured as Trunk port as IP phones can strip the Vlan information from the frames

2) Further from that IP phone i want to give the connection to the PC in Vlan 20

for this I want to make the Vlan 20 as the native vlan for the Switch port.

3)is it possible ? and if i have more vlan than these two will the 802.1q tag will help to communicate with the other switches over the trunkports

regards

JD

Hall of Fame Super Gold

Re: Native vlan

Try this:

interface

switchport mode access

switchport access vlan 20

switchport voice vlan 10

interface

switchport trunk native vlan 20

switchport trunk allowed vlan 10,20

switchport trunk encap dot

switchport mode trunk

Hope this works.

144
Views
0
Helpful
3
Replies