Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Natting on router based on destination

Hi ,

            I need to perform dynamic natting based on destination ip address , Similary let me know whether i can have multiple dynamic natting in cisco router .

              In my setup i need to use mutiple dynamic nat  becoz client has given access to  the apllication server based on my  NAT IP address pool  ..

pasting u sample config

interface FastEthernet0/1
ip address 172.16.1.1 255.255.255.0
ip nat inside

!
interface Serial0/0/0
ip address 10.10.10.2 255.255.255.252
ip nat outside
!

!
ip nat pool dev 10.10.10.9 10.10.10.11 netmask 255.255.255.252
ip nat pool prod 10.10.10.12 10.10.10.15 netmask 255.255.255.252
ip nat inside source list 101 pool dev
ip nat inside source list 102 pool prod
ip classless
!
!
access-list 101 permit ip 172.16.1.0 0.0.0.255 host 20.20.20.1
access-list 102 permit ip 172.21.16.0 0.0.0.255 host 30.30.30.1

If am wrong in my commands please write back ..thank you..

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Re: Natting on router based on destination

Yes you can have multiple NAT pools on IOS and your config looks fine. Have you tested it yet ?

Jon

2 REPLIES
Hall of Fame Super Blue

Re: Natting on router based on destination

Yes you can have multiple NAT pools on IOS and your config looks fine. Have you tested it yet ?

Jon

Re: Natting on router based on destination

Thanx Jon much , I havent tested , prepared config from lab router ..once i have tested i ll let you know ..

  I am always impressive with your answer which u used explain with clear concept n fundas , keep rocking !!!!!!!!!!!!!!!!!!!!

163
Views
0
Helpful
2
Replies