Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Bronze

Need advice

Hi all,

I'm having 2 core switches and all the edge switches connecting to these switches with dual links, one goes to core1 and other to core2. STP is used. The 2 core switches are connected thru layer 2 trunk & 3 links. Layer 2 trunk is allowed to only 4 vlans. Layer 3 is used for the EIGRP running on the both core switches. GLBP is used b/w the two core switches. Some times there is a loop coming. Now we r planning to move to HSRP . I need advice is HSRP good for this scenario. The traffic utilization on all links is around 10%. Thanks

4 REPLIES
Hall of Fame Super Blue

Re: Need advice

Hi

if you have a loop you need to work out why you are getting that loop. Is it a layer 2 loop because HSRP will not solve that for you. If you are talking about a layer 2 loop the first thing to do is check how your spanning-tree is setup. Have you explicitly set your core switches to be the primary and secondary for all vlans etc.

HSRP can be used for load-balancing but it is not as flexible as GLBP. With normal HSRP one switch is active and one is standby per vlan unlike GLBP which will use both switches per vlan. You can use MHSRP with will allow you to use both switches per vlan but you still need to actively set the default-gateways on the client unlike GLBP ie. half your clients need one default-gateway and the other half need a different default-gateway.

HTH

Jon

Bronze

Re: Need advice

Core 1 is configured with STP priority for all vlans as 0 and Core 2 as 4096.

Hall of Fame Super Blue

Re: Need advice

So is your loop a layer 2 or layer 3 loop. What are the symptomps, what do you do to fix it ?

Jon

Bronze

Re: Need advice

One switch which was running normal earlier, caused the loop problem with the second link, so as of now we removed the second trunk fiber link to core switch. I'm not sure why this happend

106
Views
0
Helpful
4
Replies