Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Need Help Configuring EtherChannel

Having a really hard time here and hopefully someone on this forum can help me get this EtherChannel working. I have two Cisco 3560G 24 port switches. I am using ports 25-28, with SFP modules, between the switches as an EtherChannel. The problem is, all 8 ports have no link lights. All ports in the EtherChannel are down. This is the config that I have already entered:

Config t
Interface range gi0/25-28
switchport trunk encapsulation dot1q
switchport mode trunk
switchport allowed vlan 1,2
channel-group 1 mode on
End

interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 1,2

When I issue a sh ip int br command, indeed the ports in question are down including the port-channel1. When I issue the show spann blocked ports command, it says Number of blocked ports (segments) in the system: 0

What to do?
Further information: Sorry for the length!!
ISCSI2#show etherchannel detail
                Channel-group listing:
                ----------------------

Group: 1
----------
Group state = L2
Ports: 4   Maxports = 8
Port-channels: 1 Max Port-channels = 1
Protocol:    -
Minimum Links: 0
                Ports in the group:
                -------------------
Port: Gi0/25
------------

Port state    = Down Not-in-Bndl
Channel group = 1           Mode = On              Gcchange = -
Port-channel  = null        GC   =   -             Pseudo port-channel = Po1
Port index    = 0           Load = 0x00            Protocol =    -

Age of the port in the current state: 0d:16h:39m:03s

Port: Gi0/26
------------

Port state    = Down Not-in-Bndl
Channel group = 1           Mode = On              Gcchange = -
Port-channel  = null        GC   =   -             Pseudo port-channel = Po1
Port index    = 0           Load = 0x00            Protocol =    -

Age of the port in the current state: 0d:16h:39m:03s

Port: Gi0/27
------------

Port state    = Down Not-in-Bndl
Channel group = 1           Mode = On              Gcchange = -
Port-channel  = null        GC   =   -             Pseudo port-channel = Po1
Port index    = 0           Load = 0x00            Protocol =    -

Age of the port in the current state: 0d:16h:39m:03s

Port: Gi0/28
------------

Port state    = Down Not-in-Bndl
Channel group = 1           Mode = On              Gcchange = -
Port-channel  = null        GC   =   -             Pseudo port-channel = Po1
Port index    = 0           Load = 0x00            Protocol =    -

Age of the port in the current state: 0d:16h:39m:03s

                Port-channels in the group:
                ---------------------------

Port-channel: Po1
------------

Age of the Port-channel   = 0d:16h:39m:03s
Logical slot/port   = 2/1          Number of ports = 0
GC                  = 0x00000000      HotStandBy port = null
Port state          = Port-channel Ag-Not-Inuse
Protocol            =    -
Port security       = Disabled


ISCSI2#
Finally, these are the configs for the interfaces in question:
ISCSI2#show run int port-channel1
Building configuration...
Current configuration : 127 bytes
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2
switchport mode trunk
end

ISCSI2#show run int gi0/25
Building configuration...
Current configuration : 158 bytes
!
interface GigabitEthernet0/25
switchport trunk encapsulation dot1q
switchport trunnk allowed vlan 1,2
switchport mode trunk
channel-group mode on
end

ISCSI2#

11 REPLIES
New Member

Re: Need Help Configuring EtherChannel

On int g0/25 you are missing channel-group number .

ISCSI2#show run int gi0/25
Building configuration...
Current  configuration : 158 bytes
!
interface GigabitEthernet0/25
switchport trunk encapsulation dot1q
switchport trunnk allowed vlan  1,2
switchport mode trunk
channel-group mode on

New Member

Re: Need Help Configuring EtherChannel

That was a typo. It is actually correct on both switches. Each port in the EtherChannel has the same config.

Re: Need Help Configuring EtherChannel

Could you post the the config for both switches and the output of this command on both switches

show etherchannel 1 sum

Mike

New Member

Re: Need Help Configuring EtherChannel

I may just have found the issue. It seems that the configs are not the same! on switch 1 I have put in a switchport access vlan 2 command but not on switch 2. Now the question is, before I remove it, should that command be in there or no? Vlan 2 is our ISCSI vlan which is what these switches are being used for. Do we need to specify switchport access vlan 2?

Thanks guys.

Re: Need Help Configuring EtherChannel

Looks like you have these configured as a trunk and you are allowing vlan 1 and 2 on the trunk so you should not need that.

Mike

New Member

Re: Need Help Configuring EtherChannel

Well, I got it to work by removing the "switchport access vlan 2" command from switch 1. I then issued a shut and no shut on port-channel1. The interfaces came up. Now, what can I do to verify that this config is working? I basically need to prove that vlan 2 is available on both sides. I can certainly ping, but what other commands can I issue?

Re: Need Help Configuring EtherChannel

Run the command

show etherchannel 1 sum

on both switches.

Mike

New Member

Re: Need Help Configuring EtherChannel

Each switch shows the ports as bring in a "P" state. The Port-channel looks like this: Po1 (SU)

New Member

Re: Need Help Configuring EtherChannel

I am unable to ping across switches.

Re: Need Help Configuring EtherChannel

Then the etherchannel is up. Are the switches in vlan 1 or 2?

Mike

New Member

Re: Need Help Configuring EtherChannel

I figured it out. I had my laptop plugged into the wrong port. It's on vlan 1, not vlan 2. Therefore it is unable to ping across vlans.

Thanks for all your help. Learned alot today!

On a final note, what commands or tools can I use that will "show" that we do indeed have a 4GB trunk across these switches? Any bandwidth commands or tools around?

837
Views
0
Helpful
11
Replies
CreatePlease login to create content