Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Need help getting Core Switch and Router to talk?

I have been working in this issue for about a day and Im stumped. Why cant I ping the router from the core switch?

2600 Router Config:

interface FastEthernet0/1
description To  Core Switch
no ip address
no ip proxy-arp
duplex auto
speed auto
!
interface FastEthernet0/1.20
description Closet K
encapsulation dot1Q 20
ip address 10.16.10.254 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip pim sparse-mode
!
interface FastEthernet0/1.24
description Closet O
encapsulation dot1Q 24
ip address 10.16.14.254 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip pim sparse-mode
!
interface FastEthernet0/1.2583
description Finishing
encapsulation dot1Q 2583
ip address 10.16.239.254 255.255.248.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip pim sparse-mode
!
interface FastEthernet0/1.3090
description Management
encapsulation dot1Q 3090 native
ip address 10.16.254.254 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip pim sparse-mode
!
interface FastEthernet0/1.3098
description Servers
encapsulation dot1Q 3098
ip address 10.16.207.254 255.255.248.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip pim sparse-mode

4506 Core Switch Config:

interface GigabitEthernet6/24
description Uplink to Router
switchport trunk encapsulation dot1q
switchport trunk native vlan 3090
switchport trunk allowed vlan 20,24,2583,3090,3098
switchport mode trunk

sh ip int b shows that the link is up/up and the sh cdp ne d is as follows:

Device ID:

Entry address(es):
  IP address: 192.168.50.7
Platform: cisco 2621XM,  Capabilities: Router
Interface: GigabitEthernet6/24,  Port ID (outgoing port): FastEthernet0/1
Holdtime : 124 sec

Version :
Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-IK9O3S3-M), Version 12.3(26), RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2008 by cisco Systems, Inc.
Compiled Mon 17-Mar-08 15:23 by dchih

advertisement version: 2
Duplex: full

Also both ports are Speed Auto, Duplex Auto. Any suggestions would be a help. Thanks

1 REPLY
Purple

Re: Need help getting Core Switch and Router to talk?

  what are you using for the management address on the 4500  and what is the default gateway for that management vlan ?  Did you create all the layer 2 vlans on the 4500 ?

165
Views
0
Helpful
1
Replies
CreatePlease to create content