Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Need Help...Please

Hi All,

I need the help  of our experts. Its very urgent and important.

We have two buildings, 1 km distance you can say. There is a point to point connectivity with a wireless bridge.Both the buildings has there own Core Switch. And there is routing configured on both switches. B2 staff can access B1 servers

B1 has cisco 6500 switch and B2 has 3560,

B1 Switch has vlans configured from 1-10

B2 switchs has vlans configured from 20-30

Both of them has management has ip's in different subnets

I hope that the above details was informative

Now my question is that, I had some AP in B2 and these will be used by clients and I had DHCP server in B1 and place int vlan 1.

How is it possible that AP clients will get the ip from said dhcp server

I will appreciate any help.

30 REPLIES
New Member

Re: Need Help...Please

You can use the "ip helper-address" command.  This command forwards UDP broadcast packets (like DHCP) to a specific IP address (your DHCP server IP).  Configure it on the L3 ports or SVI's (int vlan ...) of switch B2, and have it forward packets to the IP address of your DHCP server.

Posted from my mobile device.

Re: Need Help...Please

Thanks for your prompt response.

IActually  have an ADSL modem acting as DHCP server. This modem is connected to B1 Switch port and the port is in vlan 5.

VLAN ip address is 10.1.5.1. The DHCP ip's leased by modem is 192.168.1.*

What ip should I configured in "ip helper-address" command ?

Big Thanks

New Member

Re: Need Help...Please

hi there

if the wireless clients are in vlan 1,

then go to your vlan 1 interface

interface vlan 1

then type ip helper-address x.x.x.x  (This will be the ip address of the ADSL modem)

give that a try

cheers

Carl

Re: Need Help...Please

Hi Carl,

For eg.

I have my WAP clients in vlan 10 ( 10.1.10.1)

My DSL modem is connected to B1 Switch port and this port is vlan 20. IP address for this vlan is 10.1.20.1

Modem has default subnet configured (192.168.1.1)

Here my question is that what ip should i give in ip-helper address command.?

New Member

Re: Need Help...Please

Hi Samir,

So, the main question is, what is the IP address of your DSL modem?  If it's in vlan 20, on the 10.1.20.1 subnet, I would assume it would be 10.1.20.1.  Whatever device serves as your DHCP server, you need to find the IP address of that device.  That's the IP you will want to use with the command.

-Alex

Re: Need Help...Please

Hi Alexander,

I would like to let you  know that 10.1.5.1 is not the DHCP server, its a vlan IP. My DHCP server is placed in this vlan. and it has subnet 192.168.1.0.

So what should i do in this case

Thanks for your replies

New Member

Re: Need Help...Please

Hi Samir,

Sorry, but I'm a bit confused now.  You stated your DHCP server is on vlan 5.  You also stated your ADSL modem is on vlan 20, and that it serves as your DHCP server.  Can you clarify?  What is the exact IP address of your DHCP server?  What is the exact IP address of your ADSL modem?

-Alex

Re: Need Help...Please

Ok I'll be very clear. and sory for that.

1. WAP clients in the vlan 20

2. DSL modem connected to a core switch port and that port is in the vlan 5 (10.1.5.0).

3. VLAN 5 has mangaegment ip address 10.1.5.1

4. Linksy DSL modem has a DHCP subnet 192.168.1.0

So my ambition is that

when a wap client associciates to WAP, he should an ip address from DSL modem (dhcp server) and hes Ip should be such like that 192.168.1.2 and so

on.

How can i achieve this.

Please let me know if something not clear.

New Member

Re: Need Help...Please

So, on your SVI for Vlan 20 on B2, you need to configure the ip helper-address command:

interface Vlan 20

     ip helper-address 10.1.5.1

Your WAP clients will send out a DHCP UDP broadcast packet on Vlan 20.  The SVI of the switch will see that it received a UDP broadcast on Vlan 20, and forward that packet directly to 10.1.5.1, the IP address of your DHCP server.  The DHCP server will respond accordingly and send the response back to Vlan 20.  The host should receive the packet, which will give them their assignment of an IP address from the 192.168.1.X subnet, assuming your DHCP server is configured correctly.

-Alex

Re: Need Help...Please

Hi Alexander,

Really big thanks for such a great explanation.

I'll give a try and keep you inform For the time being i'll rate your reply 5 stars.

Re: Need Help...Please

Hi Alexander,

I have tried putting ip helper address but its not getting

interface vlan 20

ip helper-address 10.1.5.1 ( this ip is for vlan 5 not dhcp server)

However dhcp modem is places in vlan 5. Ip leased in the subnet 192.168.1.0

Please need your suggestion

Re: Need Help...Please

I will provide vlan configuration on switches for your info.

B1

interface Vlan 5
ip address 10.1.5.1 255.255.255.0

B2

interface Vlan 20

ip address 10.1.20.1 255.255.255.0

ip helper-address 10.1.5.1 (new command)

Re: Need Help...Please

I am really in need of our experts help.

Please let me know if something not clear.

New Member

Re: Need Help...Please

What is the exact IP address of your DHCP server?

Re: Need Help...Please

hi pai,

I can explain the whole case here.

-I have 2 vlans configured on layer 3  (6500)switch for eg. vlan 10 and vlan 20

- vlan 10 subnet 10.1.10.0/24

-vlan 20 siubnet 10.1.20.0/24

- below is the vlans configuration

interface vlan 10

ip address 10.1.10.1 255.255.255.0

interface vlan 20

ip address 10.1.20.1 255.255.255.0

- further i have adsl modem. dsl has default configuration with dhcp service enabled

modem subnet: 192.168.1.0/ 24, dhcp range: 192.168.1.100-192.168.1.254

- this modem is connected to access switch (3560) on the port and this switchport is configured on vlan 10

- the clients in vlan are sucessfull able to get the dhcp ip from this modem and they browse internet

- client in vlan are getting folowing ip:

IP:    192.168.1.101

SM:  255.255.255.0

GW: 192.168.1.1

DNS: 192.168.1.

- Now i want the guest in vlan 20 can get the dhcp ip from this modem.. How is it possible ?

Thansk for baring with me.

Re: Need Help...Please

FYI..

IP for the modem is 192.168.1.1

New Member

Re: Need Help...Please

If your DHCP clients are in Vlan 20, and your DHCP server IP 192.168.1.1, then you should configure the following:

Interface Vlan 20

     ip helper-address 192.168.1.1

Re: Need Help...Please

Hi Pai,

I will let you know that

interface vlan 10 has a subnet 10.1.10.0

interface vlan 20 has a subnet 10.1.20.0

How the vlan 20 clients will reach to 192.168.1.1 because l3 switch has information about this subnet.

New Member

Re: Need Help...Please

The traffic will be routed there via the L3 device.  Can you ping both ways from each subnet?

Re: Need Help...Please

hi dpatten78,

Yes. i can ping both ways. The workstation in vlan 10 with an ip 10.1.10.2 can ping vlan 20 workstation 10.1.20.2

However one thing to be noted I cannot ping modem ip from the l3 switch 192.168.1.1

Re: Need Help...Please

Can I apply a route map and nat ? If yes, please can you help in configuration.

New Member

Re: Need Help...Please

Your making this more difficult then it needs to be.  Just to clarify your ASDL modem has an IP address of 192.168.1.0/24?  It is plugged into a port that is a member of vlan 20? User workstations are plugged into ports that are members of vlan20 as well?

Try this:

Create another vlan on 6500 call it vlan 192 but do not give it a default gateway.  Put 1 port in the vlan 192 and connect your ASDL modem to that port, then on the 6500 add 'ip helper-address 192.168.1.1' to vlan interfaces 10 and 20.


See if that works.

Re: Need Help...Please

Hi dpatten78

It seems to be diffiult, sory for that. But i am trying to be very clear

I tried as you said but no luck.

Hall of Fame Super Blue

Re: Need Help...Please

samirshaikh52 wrote:

Hi dpatten78

It seems to be diffiult, sory for that. But i am trying to be very clear

I tried as you said but no luck.

You are not being clear and you are not listening to anything people are saying to you. In fact it honestly sounds like this thread is actually a wind up. Apologies for being so blunt, which i'm normally not, but if you want help then -

a) provide the information people ask for - eg. you were repeatedly asked for the modem IP and provided everything but. One minute the modem is in vlan 5 then it is in vlan 20

b) listen to what people are telling you

eg from one of your posts -

This modem is connected to B1 Switch port and the port is in vlan 5.

VLAN ip address is 10.1.5.1.

you then go on to say the modem has an IP address of 192.168.1.1 which it cannot have if it is connected to a vlan using a 10.1.5.x subnet.

So  -

1) what is the IP address of the modem

2) what vlan is the modem in.

3) note the vlan that the modem is in will have an IP subnet. If the modem port on the switch is configured in this vlan then the modem must have an IP address out of that subnet so it cannot be the addressing you have already said.

Jon

Re: Need Help...Please

Hi Jon,

Thanks for your notes.

But let me tell you something that I have been already cleared everything and in one my previous post.


-I have 2 vlans configured on layer 3  (6500)switch for eg. vlan 10 and vlan 20

- vlan 10 subnet 10.1.10.0/24

-vlan 20 siubnet 10.1.20.0/24

- below is the vlans configuration

interface vlan 10

ip address 10.1.10.1 255.255.255.0


interface vlan 20

ip address 10.1.20.1 255.255.255.0


- further i have adsl modem. dsl has default configuration with dhcp service enabled

modem subnet: 192.168.1.0/ 24, dhcp range: 192.168.1.100-192.168.1.254

- this modem is connected to access switch (3560) on the port and this switchport is configured on vlan 10

- the clients in vlan are sucessfull able to get the dhcp ip from this modem and they browse internet

- client in vlan are getting folowing ip:

IP:    192.168.1.101

SM:  255.255.255.0

GW: 192.168.1.1

DNS: 192.168.1.1

If you had any question here pleas let me know.

Hall of Fame Super Blue

Re: Need Help...Please

samirshaikh52 wrote:

Hi Jon,

Thanks for your notes.

But let me tell you something that I have been already cleared everything and in one my previous post.


-I have 2 vlans configured on layer 3  (6500)switch for eg. vlan 10 and vlan 20

- vlan 10 subnet 10.1.10.0/24

-vlan 20 siubnet 10.1.20.0/24

- below is the vlans configuration

interface vlan 10

ip address 10.1.10.1 255.255.255.0


interface vlan 20

ip address 10.1.20.1 255.255.255.0


- further i have adsl modem. dsl has default configuration with dhcp service enabled

modem subnet: 192.168.1.0/ 24, dhcp range: 192.168.1.100-192.168.1.254

- this modem is connected to access switch (3560) on the port and this switchport is configured on vlan 10

- the clients in vlan are sucessfull able to get the dhcp ip from this modem and they browse internet

- client in vlan are getting folowing ip:

IP:    192.168.1.101

SM:  255.255.255.0

GW: 192.168.1.1

DNS: 192.168.1.1

If you had any question here pleas let me know.

Okay, so the modem is connected to a port in vlan 10 ie. the subnet 10.1.10.0/24. So what is the modem IP address ie. it has to have an IP address from the 10.1.10.x subnet range ?

This is where the confusion arrises from i think. You say that the modem is handing out IP's for the 192.168.1.0/24 subnet. And that it is connected to vlan 10 on the switch. And that clients in vlan 10 are getting IPs in the 192.168.1.x range with 192.168.1.1 (presumably the modem) acting as the gateway. This works for clients in vlan 10 because they are broadcasting their DHCP request and are receiving an answer from the modem. But it can't work for any other vlans because how does the switch communicate with the modem ie. the modem has 192.168.1.1 address but the switch thinks that vlan 10 subnet is 10.1.10.x.

So if you want any other clients to receive an IP address from the modem you will need to -

1) setup another DHCP pool on the modem - can this be done ? because the modem may only be able to hand out addresses for the subnet it's interface is in ie. 192.168.1.x/24

2) critically though you must make the modem routable from the 3560 and it isn't because the 3560 thinks that the vlan the modem is in is 10.1.10.x. So you either need to either -

a)  change the vlan 10 ip address to be an address from the 192.168.1.x subnet which assumes there are no other clients in vlan that have 10.1.10.x addressing ie. they all get their address from the modem

or

b) you need to create a new vlan and vlan interface on your 3560 switch eg. an unused vlan -

3560(config)# vlan 40

3560(config)# int vlan 40

3560(config-if)# ip address x.x.x.x    <--- where x.x.x.x is an address from the 192.168.1.x range

then you need to allocate the modem and all the clients in vlan 10 that you want to get a 192.168.1.x address to vlan 40

If you do either a) or b) above then you can then use 192.168.1.1 as the "ip helper-address" under the other vlan interfaces and it should work.

Having said all that if the modem cannot support multiple DHCP pools then neither a) or b) will work for any of your other vlans ie. they won't be able to get an address from the modem. In this case you need something else to setup up the DHCP pools on. Personally i'm in favour of using an OS such as windows or unix to do this but if you can't do that you can setup DHCP pools on the 3560.

Regardless of how you setup the pools you really need to sort out that modem to vlan 10 issue.

Please come back if you need clarification on anything. Key thing at the moment is to find out whether your modem supports multiple DHCP pools.

Jon

Re: Need Help...Please

Ok Jon. I'll try and let you know.

Re: Need Help...Please

Hi Jon,

My Modem does not suppor multiple dhcp pools

I created a vlan on l3 switch such as follows

vlan 192

name WHATEVER

interface vlan 192

ip address 192.168.1.254

I configured the port of the modem into this vlan

then i configured ip helper-address command on vlan 10 and vlan 20

interface vlan 10

ip address 10.1.10.1 255.255.255.0

ip helper-address 192.168.1.1

interface vlan 20

ip address 10.1.20.1 255.255.255.0

ip helper-address 192.168.1.1

But still the clients in vlan 10 and vlan 20 are not able to get the dhcp ip.

Hall of Fame Super Blue

Re: Need Help...Please

samirshaikh52 wrote:

Hi Jon,

My Modem does not suppor multiple dhcp pools

I created a vlan on l3 switch such as follows

vlan 192

name WHATEVER

interface vlan 192

ip address 192.168.1.254

I configured the port of the modem into this vlan

then i configured ip helper-address command on vlan 10 and vlan 20

interface vlan 10

ip address 10.1.10.1 255.255.255.0

ip helper-address 192.168.1.1

interface vlan 20

ip address 10.1.20.1 255.255.255.0

ip helper-address 192.168.1.1

But still the clients in vlan 10 and vlan 20 are not able to get the dhcp ip.

No, they won't be able to because they are in different subnets. Basically you can't just allocate a 192.168.1.x pool and then expect clients that are in vlan with 10.1.10.x and 10.1.20.x addressing to be able to get a 192.168.1.x address. They won't be able to.

What you can do for the clients in vlan 10 is move them also into vlan 192 so they can then get a 192.168.1.x address from the modem.

For vlan 20 and any other vlans you will need to setup pools on a different device. Like i said windows or unix server would be good but if you don't have these then you can use the 3560 switch itself. So you would setup a pool on the switch eg. for vlan 20

ip dhcp excluded-address 10.1.20.1   <-- you  must exclude the 10.1.20.1 address assigned to the vlan interface on the switch from the pool

ip dhcp pool vlan20
   network 10.1.20.0 255.255.255.0
   dns-server 4.4.4.2 4.4.4.1  <-- obviously change these to be the DNS servers the modem would hand out
   default-router 10.1.20.1    <-- this must be the address of the vlan 20 interface on the 3560

   lease 3

!

Ideally for cleanness you should have all the pools on the 3560 switch rather than one on the modem and some on the switch but it depends if the modem is happy to have no DHCP pool.

If the modem is the gateway to the internet then on the 3560 you will also need to add (if you don't already have it) -

3560(config)# ip route 0.0.0.0 0.0.0.0 192.168.1.1

Jon

1012
Views
14
Helpful
30
Replies