Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Need help to setup 2821 router with IPoA ADSL connection

Hi to all,

I try to replace my box with a Cisco router and switch, my hardware setup is :

- 1 Cisco router 2821 with ADSL2+ HWIC-1ADSL-M modul

I use the lastest IOS version with it => Advanced Enterprise Services, IOS version 15.1(4)M7

- 1 Cisco switch 2960G connected to 2821.

My Internet Service Provider offer "IP over ATM" connection type.

My internet détails is :

  Etat                           Showtime               

  Protocole                      ADSL2+                 

  Mode                           Interleaved            

                         Downstream         Upstream          

                         --                 --               

  Débit ATM              6570 kb/s          887 kb/s         

  Marge de bruit         5.40 dB            7.30 dB          

  Atténuation            46.00 dB           25.00 dB         

  FEC                    5211               27735            

  CRC                    76                 0                

  HEC                    3                  267

I would like to use my router as the same as my box (modem) provided from my ISP :

On WAN side, my router will recover IP from my ISP with HWIC ADSL modul, the modul will use the same MAC@ as my BOX.

On LAN side, the router provide DHCP with a default gateway 192.168.1.50, it provide DNS details recovered from my ISP (Lan is a /24) for all ip device connected on the switch

I need to do some port forwarding, so i need to have one or two line with it as example.

I use Putty with console port for setup all devices.

My router Setup :

C2821#show config

Using 1860 out of 245752 bytes

!

! Last configuration change at 09:19:32 UTC Sun Nov 10 2013

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname C2821

!

boot-start-marker

boot system flash:c2800nm-adventerprisek9-mz.151-4.M7.bin

boot-end-marker

!

!

logging buffered 4096

enable secret 5 $**************************************

enable password ************

!

no aaa new-model

!

no process cpu autoprofile hog

!

dot11 syslog

ip source-route

no ip routing

!

!

no ip cef

!

!

!

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

!

voice-card 0

!

crypto pki token default removal timeout 0

!

!

!

!

license udi pid CISCO2821 sn F***********2

archive

log config

hidekeys

!

redundancy

!

!

controller DSL 0/1/0

!

!

!

!

!

interface GigabitEthernet0/0

ip address 192.168.1.50 255.255.255.0

ip nat inside

ip virtual-reassembly in

no ip route-cache

duplex auto

speed auto

no cdp enable

no mop enabled

hold-queue 100 out

!

interface GigabitEthernet0/1

no ip address

no ip route-cache

shutdown

duplex auto

speed auto

no cdp enable

!

interface ATM0/0/0

mac-address 0007.****.****

no ip address

no ip redirects

no ip proxy-arp

no ip route-cache

no atm ilmi-keepalive

!

interface ATM0/0/0.1 point-to-point

ip address dhcp

ip nat outside

ip virtual-reassembly in

no ip route-cache

pvc 8/36

encapsulation aal5mux ip

!

!

ip forward-protocol nd

ip http server

no ip http secure-server

!

!

ip nat inside source list 1 interface ATM0/0/0.1 overload

ip route 0.0.0.0 0.0.0.0 ATM0/0/0.1

!

access-list 1 permit any

!

!

!

!

snmp-server community public RO

!

!

control-plane

!

!

!

mgcp profile default

!

!

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

session-timeout 9999

exec-timeout 9999 0

password ************

login

transport input all

!

scheduler allocate 20000 1000

end

I hide password, mac@ et serial number for security reasons.

The "dsl operating-mode auto" command pass properly in ATM0/0/0 interface but it's not recorded when i do a show config, but it seems that HWIC setup is in auto by default !?

The synchronisation with my ISP (through the DSLAM) seems correct, the green light near the module is fix after some seconds, i have no disconnection.

This is the informations provided on ATM interface :

C2821>show interface ATM0/0/0.1
ATM0/0/0.1 is up, line protocol is up
  Hardware is HWIC-DSLSAR (with Alcatel ADSL Module), address is 0007.****.**** (bia dc7b.94d9.5423)
  Internet address will be negotiated using DHCP
  MTU 4470 bytes, BW 900 Kbit/sec, DLY 560 usec,
     reliability 81/255, txload 1/255, rxload 1/255
  Encapsulation ATM
  Keepalive not supported
     530 packets input, 42611 bytes
     15 packets output, 3880 bytes
     0 OAM cells input, 0 OAM cells output
  AAL5 CRC errors : 0
  AAL5 SAR Timeouts : 0
  AAL5 Oversized SDUs : 0
  Last clearing of "show interface" counters never

C2821>show interface ATM0/0/0
ATM0/0/0 is up, line protocol is up
  Hardware is HWIC-DSLSAR (with Alcatel ADSL Module), address is 0007.****.**** (bia dc7b.94d9.5423)
  MTU 4470 bytes, sub MTU 4470, BW 900 Kbit/sec, DLY 560 usec,
     reliability 108/255, txload 1/255, rxload 1/255
  Encapsulation ATM, loopback not set
  Keepalive not supported
  Encapsulation(s): AAL5
  23 maximum active VCs, 256 VCs per VP, 1 current VCCs
  VC Auto Creation Disabled.
  VC idle disconnect time: 300 seconds
  Last input 00:00:00, output 00:00:10, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: Per VC Queueing
  5 minute input rate 2000 bits/sec, 3 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     739 packets input, 58437 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     19 packets output, 4936 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out

A "show ip interface brief" result :

InterfaceIP-AddressOK?MethodStatusProtocol
GigabitEthernet0/0192.168.1.50YESNVRAMupup
GigabitEthernet0/1unassignedYESNVRAMadministratively downdown
ATM0/0/0 unassignedYESNVRAMupup
ATM0/0/0.1unassignedYESDHCPupup
NVI0192.168.1.50YESunsetupup

 

I make two tests on ATM0/0/0.1 interface with static ip and DHCP setup, both test are KO, here a the results :

1° => Interface ATM0/0/0.1 with Static IP (ip address 88.xx.xx.xx 255.255.255.0)

C2821#show dsl interface atm0/0/0
ATM0/0/0
Alcatel 20190 chipset information
                ATU-R (DS)                      ATU-C (US)
Modem Status:    Showtime (DMTDSL_SHOWTIME)
DSL Mode:        ITU G.992.5 (ADSL2+) Annex A
ITU STD NUM:     0x03                            0x2
Chip Vendor ID:  'STMI'                          'BDCM'
Chip Vendor Specific:  0x0000                    0xA197
Chip Vendor Country:   0x0F                      0xB5
Modem Vendor ID: 'CSCO'                          'BDCM'
Modem Vendor Specific: 0x0000                    0x0000
Modem Vendor Country:  0xB5                      0xB5
Serial Number Near:    FO******** 2821
Serial Number Far:
ModemChip ID:    C196 (3) capability-enabled
DFE BOM:         DFE3.0 Annex M (3)
Capacity Used:   99%                             99%
Noise Margin:     7.0 dB                          7.0 dB
Output Power:    18.0 dBm                        12.5 dBm
Attenuation:     47.0 dB                         26.0 dB
FEC ES Errors:   22                              12001
ES Errors:        3                               4
SES Errors:       1                               0
LOSES Errors:     1                               0
UES Errors:       0                              4094
Defect Status:   None                            None
Last Fail Code:  None
Watchdog Counter: 0xC9
Watchdog Resets: 0
Selftest Result: 0x00
Subfunction:     0x00
Interrupts:      342012 (0 spurious)
PHY Access Err:  0
Activations:     1
LED Status:      OFF
LED On Time:     0
LED Off Time:    0
Init FW:         init_AMR-4.0.015_no_bist.bin
Operation FW:    AMR-4.0.015.bin
FW Source:       embedded
FW Version:      4.0.15

                 DS Channel1      DS Channel0   US Channel1       US Channel0
Speed (kbps):             0             6016             0               900
DS User cells:            0             2075
US User & Idle cells:                                     0           764053
Reed-Solomon EC:          0               33             0             27746
CRC Errors:               0                5             0                17
Header Errors:            0                5             0               273
Total BER:                0E-0           4531E-9
Leakage Average BER:      0E-0           4531E-9
Interleave Delay:         0                8             0                61
                        ATU-R (DS)      ATU-C (US)
Bitswap:               enabled            enabled

LOM Monitoring : Disabled


DMT Bits Per Bin
000: 0 0 0 0 0 0 0 8 B B B B B B B B
010: B A A A A A A A A A A B B B B A
020: 0 6 7 7 7 8 8 8 9 9 9 A A A A A
030: A A A A 9 9 9 8 7 7 8 9 A A A A
040: A A A A A 2 A A A A A A A A A A
050: A A 9 9 9 9 9 9 9 9 9 9 9 9 9 9
060: 9 9 9 9 9 9 9 9 9 8 9 8 8 8 8 8
070: 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8
080: 8 8 8 7 8 8 8 8 8 8 7 8 8 7 7 7
090: 7 7 7 7 7 7 7 7 7 7 7 7 7 7 7 7
0A0: 7 7 7 7 7 7 7 7 7 7 7 7 7 7 7 7
0B0: 7 7 7 7 7 6 6 6 6 6 6 6 6 6 6 6
0C0: 6 6 5 5 5 4 2 0 0 0 2 4 5 5 5 5
0D0: 5 5 5 5 5 5 5 5 5 5 5 5 5 5 5 5
0E0: 5 5 5 5 5 5 5 5 5 5 5 4 4 4 4 4
0F0: 4 4 4 4 4 4 4 4 4 4 4 4 4 4 4 4
100: 4 4 4 4 4 4 4 4 3 3 3 3 3 3 3 3
110: 3 3 3 2 2 2 2 2 2 2 2 2 2 2 2 2
120: 2 2 2 2 2 0 0 0 0 2 2 2 2 2 2 2
130: 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 1
140: 1 1 1 0 0 0 0 0 0 0 0 0 0 0 0 0
150: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
160: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
170: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
180: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
190: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
1A0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
1B0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
1C0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
1D0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
1E0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
1F0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

DSL: Training log buffer capability is not enabled


Ping from router to my WAN IP address 88.XXX.XXX.156 => OK
Ping from router to my WAN Default Gateway (IP = 88.XXX.XXX.254) => OK
Ping from router to 173.194.45.56 (Google) => KO

Ping from a PC (IP is 192.168.1.2, DG is 192.168.1.50) to my WAN IP address 88.XX.XX.XX  => OK
Ping from a PC (IP is 192.168.1.2, DG is 192.168.1.50) to my WAN Default Gateway (IP = 88.XXX.XXX.254)  => KO

Ping from a PC (IP is 192.168.1.2, DG is 192.168.1.50) to 173.194.45.56 (Google) => KO

2° => Interface ATM0/0/0.1 with DHCP setup

C2821>show dsl interface atm0/0/0
ATM0/0/0
Alcatel 20190 chipset information
                ATU-R (DS)                      ATU-C (US)
Modem Status:    Showtime (DMTDSL_SHOWTIME)
DSL Mode:        ITU G.992.5 (ADSL2+) Annex A
ITU STD NUM:     0x03                            0x2
Chip Vendor ID:  'STMI'                          'BDCM'
Chip Vendor Specific:  0x0000                    0xA197
Chip Vendor Country:   0x0F                      0xB5
Modem Vendor ID: 'CSCO'                          'BDCM'
Modem Vendor Specific: 0x0000                    0x0000
Modem Vendor Country:  0xB5                      0xB5
Serial Number Near:    F*********** 2821
Serial Number Far:
ModemChip ID:    C196 (3) capability-enabled
DFE BOM:         DFE3.0 Annex M (3)
Capacity Used:   99%                             99%
Noise Margin:     6.5 dB                          7.0 dB
Output Power:    18.0 dBm                        12.5 dBm
Attenuation:     47.0 dB                         26.0 dB
FEC ES Errors:   12001                           262
ES Errors:        4                               4
SES Errors:       0                               1
LOSES Errors:     0                               1
UES Errors:      4365                             0
Defect Status:   None                            None
Last Fail Code:  None
Watchdog Counter: 0x26
Watchdog Resets: 0
Selftest Result: 0x00
Subfunction:     0x00
Interrupts:      8816 (0 spurious)
PHY Access Err:  0
Activations:     1
LED Status:      OFF
LED On Time:     0
LED Off Time:    0
Init FW:         init_AMR-4.0.015_no_bist.bin
Operation FW:    AMR-4.0.015.bin
FW Source:       embedded
FW Version:      4.0.15

                 DS Channel1      DS Channel0   US Channel1       US Channel0
Speed (kbps):             0             6029             0               900
DS User cells:            0             5771
US User & Idle cells:                                     0          3241224
Reed-Solomon EC:          0              348             0              1922
CRC Errors:               0                4             0                 4
Header Errors:            0                4             0               101
Total BER:                0E-0           9037E-10
Leakage Average BER:      0E-0           9037E-10
                        ATU-R (DS)      ATU-C (US)
Bitswap:               enabled            enabled

LOM Monitoring : Disabled


DMT Bits Per Bin

Not able to get complete DMT bin information.Please retry "show dsl" after few seconds.

DSL: Training log buffer capability is not enabled

Ping from router to my WAN IP address 88.XXX.XXX.156 => OK

Ping from router to my WAN Default Gateway (IP = 88.XXX.XXX.254) => KO

Ping from router to 173.194.45.56 (Google) => KO

Ping from a PC (IP is 192.168.1.2, DG is 192.168.1.50) to my WAN IP address 88.XX.XX.XX  => KO

Ping from a PC (IP is 192.168.1.2, DG is 192.168.1.50) to my WAN Default Gateway (IP = 88.XXX.XXX.254)  => KO

Ping from a PC (IP is 192.168.1.2, DG is 192.168.1.50) to 173.194.45.56 (Google) => KO

Can you help me to troubleshoot my setup ?

Many thanks for your help.

4 REPLIES
New Member

Re: Need help to setup 2821 router with IPoA ADSL connection

I answer to my issue, LAN issue for access to internet was due to "no ip routing" in my setup.

From now, all is working when i use static IP with my ISP, DHCP mode doesn't work for unknow reason.

My Service Providers restricted DHCP addressing with MAC addresses, but i spoof it with "Mac-address" command in ATM interface.

So i dunno why i'm not able to use DHCP mode with my ISP, if someone know how to fix this problem, it will be fine.

I monitor during two days the connexion from my PC (ping the default gateway on Wan side) and i notice some interesting things.

I loose my connection every 30 minutes all time, my connection is going up just one minute after...

From my point of view, it can be due :

  • From my ISP who reinit the connexion for unknow reason
  • From my router, maybe for administrative reasons

*Nov 11 07:36:04.863: %LINK-3-UPDOWN: Interface ATM0/0/0, changed state to up

*Nov 11 07:36:05.863: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/0/0, changed state to up

*Nov 11 08:03:44.859: %LINK-3-UPDOWN: Interface ATM0/0/0, changed state to down

*Nov 11 08:03:45.859: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/0/0, changed state to down

*Nov 11 08:04:44.863: %LINK-3-UPDOWN: Interface ATM0/0/0, changed state to up

*Nov 11 08:04:45.863: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/0/0, changed state to up

Someone know how to troubleshoot it for know why ?

I loose 13% of bandwidth with my router when i compare it with my ISP modem.

With the router : download rate : 4,70 mbps / upload rate : 0,72 / ping @ 66ms

With the modem from my ISP : download rate : 5,40 mbps / upload rate : 0,72 / ping @ 42ms

Ping and download is better with the modem provided by my ISP.

Someone can help me to optimise my bandwidth/connection ?

I notice that telnet and http port of my router is open from WAN side, someone can help me to fix for be accessible only from LAN side please ?

Many Thks.

New Member

Re: Need help to setup 2821 router with IPoA ADSL connection

UP!

New Member

Re: Need help to setup 2821 router with IPoA ADSL connection

About my DHCP issue :

As you can see, the router doesn’t acquire IP from my ISP but i notice that the Client-ID provided include “cisco-“ and “-AT0/0/0.1”, it can explain my DHCP issue because my ISP attempt only to have a mac-address.

I use “mac-address” command in my setup to have only “0007.XXXX.XX4b” but in fact the router client-ID is “cisco-0007.XXXX.XX4b-AT0/0/0.1”

I need to avoid “cisco-“ and “-AT0/0/0.1” in DHCP Client-ID and change my mac adresse for be in format XX:XX:XX:XX:XX:XX, instead of XXXX.XXXX.XXXX.

It can be possible with "ip address dhcp client-id" command but the router doesn't accept it ! Shocked

I find this information here => http://blog.ipspace.net/2007/0.....nt-id.html

Someone can help me to doing it properly with my setup please ?

DHCP Debug log :

Code:
*Nov 17 10:16:33.659: DHCP: DHCP client process started: 10
*Nov 17 10:16:33.659: RAC: Starting DHCP discover on ATM0/0/0.1
*Nov 17 10:16:33.659: DHCP: Try 1 to acquire address for ATM0/0/0.1
*Nov 17 10:16:33.663: DHCP: allocate request
*Nov 17 10:16:33.663: DHCP: new entry. add to queue, interface ATM0/0/0.1
*Nov 17 10:16:33.663: DHCP: Client socket is opened
*Nov 17 10:16:33.663: DHCP: SDiscover attempt # 1 for entry:
*Nov 17 10:16:33.663: Temp IP addr: 0.0.0.0  for peer on Interface: ATM0/0/0.1
*Nov 17 10:16:33.663: Temp  sub net mask: 0.0.0.0
*Nov 17 10:16:33.663:    DHCP Lease server: 0.0.0.0, state: 3 Selecting
*Nov 17 10:16:33.663:    DHCP transaction id: F9D
*Nov 17 10:16:33.663:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs
*Nov 17 10:16:33.663:    Next timer fires after: 00:00:04
*Nov 17 10:16:33.663:    Retry count: 1   Client-ID: cisco-0007.****.**4b-AT0/0/0.1
*Nov 17 10:16:33.663:    Client-ID hex dump: 63697363****************************2E
*Nov 17 10:16:33.667:                        6363*********************302F302E31
*Nov 17 10:16:33.667:    Hostname: C2821
*Nov 17 10:16:33.667: DHCP: SDiscover placed class-id option: 64736C666F72756D2E6F7267
*Nov 17 10:16:33.667: DHCP: SDiscover: sending 312 byte length DHCP packet
*Nov 17 10:16:33.667: DHCP: SDiscover 312 bytes
*Nov 17 10:16:33.667:             B'cast on ATM0/0/0.1 interface from 0.0.0.0
*Nov 17 10:16:37.291: DHCP: SDiscover attempt # 2 for entry:
*Nov 17 10:16:37.291: Temp IP addr: 0.0.0.0  for peer on Interface: ATM0/0/0.1
*Nov 17 10:16:37.291: Temp  sub net mask: 0.0.0.0
*Nov 17 10:16:37.291:    DHCP Lease server: 0.0.0.0, state: 3 Selecting
*Nov 17 10:16:37.291:    DHCP transaction id: F9D
*Nov 17 10:16:37.291:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs
*Nov 17 10:16:37.291:    Next timer fires after: 00:00:04
*Nov 17 10:16:37.291:    Retry count: 2   Client-ID: cisco-0007.****.**4b-AT0/0/0.1
*Nov 17 10:16:37.291:    Client-ID hex dump: 63697363****************************2E
*Nov 17 10:16:37.291:                        6363*********************302F302E31
*Nov 17 10:16:37.291:    Hostname: C2821
*Nov 17 10:16:37.291: DHCP: SDiscover placed class-id option: 64736C666F72756D2E6F7267
*Nov 17 10:16:37.291: DHCP: SDiscover: sending 312 byte length DHCP packet
*Nov 17 10:16:37.291: DHCP: SDiscover 312 bytes
*Nov 17 10:16:37.291:             B'cast on ATM0/0/0.1 interface from 0.0.0.0
*Nov 17 10:16:41.291: DHCP: SDiscover attempt # 3 for entry:
*Nov 17 10:16:41.291: Temp IP addr: 0.0.0.0  for peer on Interface: ATM0/0/0.1
*Nov 17 10:16:41.291: Temp  sub net mask: 0.0.0.0
*Nov 17 10:16:41.291:    DHCP Lease server: 0.0.0.0, state: 3 Selecting
*Nov 17 10:16:41.291:    DHCP transaction id: F9D
*Nov 17 10:16:41.291:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs
*Nov 17 10:16:41.291:    Next timer fires after: 00:00:04
*Nov 17 10:16:41.291:    Retry count: 3   Client-ID: cisco-0007.****.**4b-AT0/0/0.1
*Nov 17 10:16:41.291:    Client-ID hex dump: 63697363****************************2E
*Nov 17 10:16:41.291:                        6363*********************302F302E31
New Member

Re: Need help to setup 2821 router with IPoA ADSL connection

uP!

910
Views
0
Helpful
4
Replies
CreatePlease to create content